iPhone Keep iMessage working when traveling abroad?

Discussion in 'iOS 7' started by creativedogmedia, May 3, 2014.

  1. creativedogmedia macrumors 65816

    creativedogmedia

    Joined:
    Jun 26, 2011
    #1
    When I went to Barcelona a couple of months ago I pulled my verizon sim and replaced with a prepaid, data-only sim. I couldn't iMessage anyone. Is there a way to keep iMessage alive after pulling my sim when traveling abroad?
     
  2. ChristianJapan macrumors 601

    ChristianJapan

    Joined:
    May 10, 2010
    Location:
    日本
    #2
    iMessage via phone number/SMS-style can't work as with the switch of the SIM you change your identity. If you use iMessage with eMail-ID those would continue working. But of course only inside the Apple Family.

    Which way you use iMessage normally ?
     
  3. Harmonious Zen macrumors 6502a

    Joined:
    May 18, 2013
    #3
    What do you mean you couldn't iMessage anyone? What error message were you getting? It should work the same as your regular SIM. It just changes your phone number to the new phone number in Messages settings. It should work pretty seamlessly. I've done it myself several times.
     
  4. creativedogmedia thread starter macrumors 65816

    creativedogmedia

    Joined:
    Jun 26, 2011
    #4
    I have it set to my domestic phone number on my iPhone, iPad and MBP.

    ----------

    I couldn't message anyone using the data only SIM. It literally wouldn't go through.
     
  5. richwoodrocket macrumors 68020

    richwoodrocket

    Joined:
    Apr 7, 2014
    Location:
    Hamburg, NY
    #5
    Keep iMessage working when traveling abroad?

    Hmm. I can use iMessage from my phone number even without a sim.what you're describing should work.
     
  6. creativedogmedia thread starter macrumors 65816

    creativedogmedia

    Joined:
    Jun 26, 2011
    #6
    Will give it a shot on Monday. Would be awesome if it worked. Thanks.
     
  7. creativedogmedia thread starter macrumors 65816

    creativedogmedia

    Joined:
    Jun 26, 2011
    #7
    So once I land and put the data only SIM in and add the APN info, it should work as normal?
     
  8. Mlrollin91 macrumors G4

    Mlrollin91

    Joined:
    Nov 20, 2008
    Location:
    Ventura County
    #8
    I'm fairly certain you need to go to Settings -> Messages -> Send & Receive and check start new conversations from the email address. That way you can continue to use iMessage. You're contacts will need your email address under your contact on their phone to know who is messaging them, otherwise it will show an iMessage from just an email address.
     
  9. richwoodrocket macrumors 68020

    richwoodrocket

    Joined:
    Apr 7, 2014
    Location:
    Hamburg, NY
    #9

    This also works to get around people blocking you.
     
  10. aristobrat macrumors G4

    Joined:
    Oct 14, 2005
    #10
    You may have to activate the sim before it works. All of the ones I've used in Hong Kong required that before they'd start working.
     

Share This Page