Keep MBA awake when plugged in

NP Hard

macrumors newbie
Original poster
Mar 8, 2014
19
0
Brisbane, Australia
Hi all,

I have a 2013 13" MBA that I'd like to keep awake when plugged in and open. At the moment it goes to sleep after a period of inactivity and there seems to be no way to stop this.

Obviously this is fine when on battery, but when I have my laptop connected to power and an external screen, I'd it to remain awake even after the display turns off so I can remain connected to Skype and IRC. If I want it to sleep, I'll put it to sleep myself. At the moment I use Caffeine to keep it awake, but I'd still like the screen to go to sleep.

My MacBook Pro running 10.8 has a slider for this but my MBA running 10.9 does not.

Anyway to get this working?
 

Altemose

macrumors G3
Mar 26, 2013
9,089
444
Elkton, Maryland
Hi all,

I have a 2013 13" MBA that I'd like to keep awake when plugged in and open. At the moment it goes to sleep after a period of inactivity and there seems to be no way to stop this.

Obviously this is fine when on battery, but when I have my laptop connected to power and an external screen, I'd it to remain awake even after the display turns off so I can remain connected to Skype and IRC. If I want it to sleep, I'll put it to sleep myself. At the moment I use Caffeine to keep it awake, but I'd still like the screen to go to sleep.

My MacBook Pro running 10.8 has a slider for this but my MBA running 10.9 does not.

Anyway to get this working?
Go to :apple: --> System Preferences --> Energy Saver --> Power Adapter Tab and adjust the slider for Computer Sleep to "Never" and the Display Sleep slider to your desired timeframe.
 

Crazy Badger

macrumors 65816
Apr 1, 2008
1,151
472
Scotland
Keep MBA awake when plugged in

Because it's easier! No digging into system preferences and then messing with sliders. Surely just adding a hot-key to switch on the screensaver and set it as blank would work with caffeine?
 

NP Hard

macrumors newbie
Original poster
Mar 8, 2014
19
0
Brisbane, Australia
Go to :apple: --> System Preferences --> Energy Saver --> Power Adapter Tab and adjust the slider for Computer Sleep to "Never" and the Display Sleep slider to your desired timeframe.
The point is that I don't have that slider.

However, I did just realise there's a checkbox which says "Prevent computer from sleeping when screen is off". How silly of me. :rolleyes: I guess that solves my problem!
 

Attachments

Altemose

macrumors G3
Mar 26, 2013
9,089
444
Elkton, Maryland
The point is that I don't have that slider.

However, I did just realise there's a checkbox which says "Prevent computer from sleeping when screen is off". How silly of me. :rolleyes: I guess that solves my problem!
That is different on Power Nap compatible Macs in my experience. Glad the System Preference worked for you.