Keep router from showing in Finder

Discussion in 'Mac Accessories' started by jbsmithmac, Dec 19, 2013.

  1. jbsmithmac macrumors regular

    Joined:
    Sep 11, 2011
    #1
    I'm not sure if this is the right forum but here goes...

    I just got a Cisco E4200v1 router...it has the capability to share a usb hard drive though it. I'm not using that functionality as a I have a dedicated NAS (synology).

    However the Cisco shows up in the finder...I assume from its ability to share a drive. I'd like to turn that off...so it doesn't show in the Finder, I don't see any setting in the router's admin panel to do this.

    Is it possible?
     
  2. McGiord macrumors 601

    McGiord

    Joined:
    Oct 5, 2003
    Location:
    Dark Castle
    #2
    In the Finder click on the eject button, and it will be gone.
    Also check in System Settings, in your user account if it is showing up in Login items and remove it from there.
     
  3. jbsmithmac thread starter macrumors regular

    Joined:
    Sep 11, 2011
    #3
    It's not mounted.

    There isn't actually any disk attached to the router. It's showing in the finder under the "Shared" section. I'm on 10.8.5 by the way.


    [​IMG]

    ----------

    I wouldn't mind getting rid of the other one under shared (the string of numbers) - that's the wireless printer.
     
  4. McGiord macrumors 601

    McGiord

    Joined:
    Oct 5, 2003
    Location:
    Dark Castle
    #4
    If you go to Finder Preferences there you can change what is shown in the Finder.
     

    Attached Files:

  5. jbsmithmac thread starter macrumors regular

    Joined:
    Sep 11, 2011
    #5
    ^^Yes but doing that will also remove the share that I want - the NAS - Diskstation412.

    Perhaps its not possible.
     
  6. skorpien macrumors 68020

    Joined:
    Jan 14, 2008
    #6
  7. jbsmithmac thread starter macrumors regular

    Joined:
    Sep 11, 2011
    #7
    yeah, the media server has been disabled all along.
     
  8. NewbieCanada macrumors 68030

    Joined:
    Oct 9, 2007
    #8
    I have the same issue with a WiFi printer showing up in Network with an unfriendly name (3830e7000000) and listed as a PC!
     
  9. Altemose macrumors G3

    Altemose

    Joined:
    Mar 26, 2013
    Location:
    Elkton, Maryland
    #9
    Try turning off Anonymous Disk Access in Storage ---> Administration.

    :apple: Altemose :apple:
     
  10. jbsmithmac thread starter macrumors regular

    Joined:
    Sep 11, 2011
    #10
    Thanks...but already off.
     
  11. Altemose macrumors G3

    Altemose

    Joined:
    Mar 26, 2013
    Location:
    Elkton, Maryland
    #11
    Does it show an option in disk management to safely remove disk though nothing is attached?
     
  12. jbsmithmac thread starter macrumors regular

    Joined:
    Sep 11, 2011
    #12
    I can see the button, but it's not enabled/press-able.
     
  13. Altemose macrumors G3

    Altemose

    Joined:
    Mar 26, 2013
    Location:
    Elkton, Maryland
    #13
    That is a really interesting problem. I do not see why it shows up, but I have seen some Linksys routers do the same. Maybe someone else knows…

    :apple: Altemose :apple:
     
  14. jbsmithmac thread starter macrumors regular

    Joined:
    Sep 11, 2011
    #14
    Well it doesn't harm anything...just an annoyance.
     
  15. Altemose macrumors G3

    Altemose

    Joined:
    Mar 26, 2013
    Location:
    Elkton, Maryland
    #15
    Try enabling and disabling the media server. However, before you apply delete the name for the server. Then click save settings.

    Give it a try.

    :apple: Altemose :apple:
     
  16. jbsmithmac thread starter macrumors regular

    Joined:
    Sep 11, 2011
    #16
    I just enabled/disabled, but it won't let the name be blank....still shows up in finder. :confused:
     
  17. Altemose macrumors G3

    Altemose

    Joined:
    Mar 26, 2013
    Location:
    Elkton, Maryland
    #17
    You have a pesky little router there. The best I can say to you is to go to Finder --> Preferences --> Sidebar and uncheck Bonjour Computers. This will give you a "All" list in Shared which you must click to see all network shares. This is kind of annoying but at least makes it a little less cluttered. :cool:
     
  18. jbsmithmac thread starter macrumors regular

    Joined:
    Sep 11, 2011
    #18
    Does seem odd...nonetheless thanks for the help!
     
  19. sliceoftoast macrumors 6502

    sliceoftoast

    Joined:
    Mar 3, 2012
    Location:
    In a Toaster
    #19
    Are there any options in there to disable CIFS/SMB/NFS/AFP?
     
  20. jbsmithmac thread starter macrumors regular

    Joined:
    Sep 11, 2011
    #20
    That's what I was originally looking for but none that I could find. That's why I went in and turned off a. The "servers" thinking they were just named weird... But still no luck.
     
  21. sliceoftoast macrumors 6502

    sliceoftoast

    Joined:
    Mar 3, 2012
    Location:
    In a Toaster
    #21
    Have you come across anything called uPnP ? Turn that off see if that makes a difference. If you click on the device in the finder does it bring up a connect as or list anything in the finder window?
     
  22. jbsmithmac thread starter macrumors regular

    Joined:
    Sep 11, 2011
    #22
    I'm try this tonight... But I think I already have.

    Yeah when I click on it it tries to connect, then fails, then gives me the connect as option. Trying connect as with the routers admin id and password fails as well... I have no other id or password for it.
     
  23. jbsmithmac thread starter macrumors regular

    Joined:
    Sep 11, 2011
    #23
    The upnp is what cisco calls the media server...so yeah we turned that off as noted earlier in the thread.
     
  24. skorpien macrumors 68020

    Joined:
    Jan 14, 2008
    #24

Share This Page