Keeping music on the iPad

Discussion in 'iPad' started by Richard L, Feb 22, 2012.

  1. Richard L macrumors newbie

    Joined:
    Jul 17, 2010
    Location:
    Durham, UK
    #1
    My apologies if this has been raised elsewhere but I could not find it on a search.

    I have an iMac, MacBook, iPhone and iPad (iPad 1). I have opened iTunes Match and upload my music library into iCloud (it took 4 days!).

    When I first synced the iPad after this and had the setting for music to come from iCloud it cleared out the music I already had stored on the iPad leaving me to have to download music I want to listen to via iCloud all the time. That is no good to me and I guess most others. If I have no WiFi access for example, in a bad spot, or on an airplane I want the music on the iPad as I cannot connect to iCloud.

    I switched off the setting that tells it music is in iCloud and then synced the iPad again with my iMac. I selected the special playlist I have for the iPad and it appeared to sync all music ok - about 28gb. However when I go into music on the iPad I still have to download it all from iCloud even though it was meant to have been loaded on to the iPad. What is more confusing is that for one or two albums I do not have to do this, even though they are in iCloud, but for most to play a track it needs to download. Yet looking at the volume of data stored on the iPad it appears the tracks must be on it after the sync.

    For some reason, even though the iPad is not set to get its music from iCloud it over rides this and says I have to. This is no good if I have no wireless connection.

    There may be an easy answer I am missing. Anybody else had this problem? All I want is to have some music physically stored on the iPad and accessible when I do not have a wireless connection.
     
  2. Macman45 macrumors demi-god

    Macman45

    Joined:
    Jul 29, 2011
    Location:
    Somewhere Back In The Long Ago
    #2
    In itunes, check the location of your library...If the default is the cloud ( I don't use it myself ) then change it back to your preferred location.
     
  3. Zcott macrumors 68020

    Joined:
    Oct 18, 2009
    Location:
    Belfast, Ireland
    #3
    Download the stuff you want to hear and stick it in a playlist called Offline. Or am I missing something?
     
  4. Macman45 macrumors demi-god

    Macman45

    Joined:
    Jul 29, 2011
    Location:
    Somewhere Back In The Long Ago
    #4
    Makes sense...One of the reasons I don't use iTunes Match. I prefer my library on my devices.
     
  5. Richard L thread starter macrumors newbie

    Joined:
    Jul 17, 2010
    Location:
    Durham, UK
    #5
    Thanks for the comments so far. Dealing with these:

    My media library is saved and accessed from an external hard drive and such is set as the preferred location.

    I do have a playlist specially for the iPad as mentioned in my original post and yes it appears to sync and load up the iPad but as said if I go to music on the iPad I am told about 90% of it all has to be downloaded from iCloud even though iCloud access is not switched on and it is meant to be on the iPad. It seems that the iPad is loaded with the tracks from the playlist but they cannot be played unless they are downloaded again from iCloud. I would have thought that with iCloud switched out on the iPad it reverts to what is stored within but it does not.
     
  6. Zcott macrumors 68020

    Joined:
    Oct 18, 2009
    Location:
    Belfast, Ireland
    #6
    Why would you switch off iCloud? And why can't you just download what you need and then choose 'show only music on this device'?
     
  7. Richard L thread starter macrumors newbie

    Joined:
    Jul 17, 2010
    Location:
    Durham, UK
    #7
    Its a long haul to download each individual album when they should already be in the iPad. What is needed is a way to tell the music app to look at what it stored on the iPad after the sync.

    I don't appear to have a "show only music on this device" option on the iPad. What am I missing?
     
  8. Richard L thread starter macrumors newbie

    Joined:
    Jul 17, 2010
    Location:
    Durham, UK
    #8
    As an addendum to my original post where in Muisc on the iPad it is showing that I need to download the track which is most of them even though they are already there, I have started to so download from iCloud. I have had to stop as it has filled up the iPad yet the playlist the iPad is synced to is about 28gb (I have a 64gb iPad). This seems to indicate that it is loading a second copy and not touching what is already there. I can though play those downloaded when I switch off all Internet connection but those synced and showing a cloud picture will not then play.
     
  9. Zcott macrumors 68020

    Joined:
    Oct 18, 2009
    Location:
    Belfast, Ireland
    #9
    Settings > Music > uncheck 'Show All Music'.
     
  10. Richard L thread starter macrumors newbie

    Joined:
    Jul 17, 2010
    Location:
    Durham, UK
    #10
    Thanks again.

    That option does not exist on my iPad, nor incidentally on my iPhone.
     
  11. Zcott macrumors 68020

    Joined:
    Oct 18, 2009
    Location:
    Belfast, Ireland
    #11
    It's just below the toggle for iTunes Match on your device.
     
  12. Richard L thread starter macrumors newbie

    Joined:
    Jul 17, 2010
    Location:
    Durham, UK
    #12
    My only options in the music settings are:

    iTunes match
    Sound check
    Eq
    Volume limit
    Group by album artist
    Home sharing.
     
  13. verwon macrumors 68030

    verwon

    Joined:
    Jul 26, 2011
    Location:
    Seattle
    #13
    iTunes Match has to be turned on for that option to show up.
     
  14. Richard L thread starter macrumors newbie

    Joined:
    Jul 17, 2010
    Location:
    Durham, UK
    #14
    Thanks Verwon. I'll give this a go and see what happens. It does not though solve the problem in that I sync my iPad playlist to the iPad from the iMac but when I go into Music on the iPad it does not all show unless it has been downloaded from iCloud yet it is in there as if I check in "About" under Settings/General it shows its there plus the amount of space left takes it into account.

    Will see what happens from here but remain unconvinced.
     
  15. mrholder macrumors regular

    Joined:
    Jan 3, 2009
    #15
    I had similar problems with itunes match turned on (ipad). Most of my problems were from purchased albums. All of them showed the cloud symbol even after I deleted them from the ipad. But my biggest pet peeve was that having itunes match turned on (on the mac) reset all of my playcounts on anything that was purchased from the itunes store.

    I downloaded the matched version of everything and now have itunes match off. I've also started a support ticket to get a refund for Match. I don't care to use it until they get all of the bugs fixed.
     
  16. Richard L thread starter macrumors newbie

    Joined:
    Jul 17, 2010
    Location:
    Durham, UK
    #16
    I think I have solved the problem but an odd way to do so.

    I ensured iTunes Match was switched off on the iPad.

    Connected the iPad by cable to the iMac.

    Edited the settings so that no music would be downloaded to the iPad and it would be wiped of what is there.

    Then synced.

    First time it did nothing. When the sync was finished, despite the bar at the bottom telling me there was little music on the iPad it was all still there.

    I did it again. This time it wiped the iPad of all music.

    I then edited settings so that my iPad Playlist would load and it loaded the whole lot.

    I now have music on the iPad I can play when I have no wireless connection.

    I never thought of running through the process twice to achieve it though.
     
  17. M87 macrumors 65816

    Joined:
    Jul 18, 2009
    #17
    I don't get it. It seems you're using iCloud and your problem is you don't want to use iCloud. iCloud doesn't require you to have any kind of active data connection to listen to your music. Download what you want and listen to it anytime, anywhere, just as you would with music synced from iTunes. The whole point of iTunes Match is that you can manage the music on your device from wherever you are without a computer. I, for one, think it is incredible.
     
  18. Cynicalone macrumors 68040

    Cynicalone

    Joined:
    Jul 9, 2008
    Location:
    Okie land
    #18
    To undo the mess iTunes match made on my iPhone and iPad I had to turn it off. Then remove all music with the devices connected to iTunes. Then resync everything like I had before iTunes match.

    iTunes Match is way to buggy to be a shipping product.
     
  19. Richard L thread starter macrumors newbie

    Joined:
    Jul 17, 2010
    Location:
    Durham, UK
    #19
    Re M87's reply.

    Its not what I said in my initial post. I want to use iTunes but I want to have the ability to listen to music when I cannot. There is a myth that storage is not needed, its all in the clouds and use wireless. Fine if you have a wireless connection but the moment I walk out of my house I do not (unless I am near or in an hotel or somewhere and then have to pay heavily for it) and I suspect this is the same for most people. We therefore need to be able to store selected material on our iPads or laptops etc. Wireless is just not available everywhere - very far from it.

    I have a playlist for the iPad. I synced it and loaded it on. But if iCloud was switched on most of this playlist was not available to me even though it was loaded on to the iPad as each time I selected a track I had to re-download it to the iPad. This seemed then to fill up the storage space on the iPad as the track was already there but a second copy was downloaded. iCloud would not let me play it unless I downloaded again - and of course you need a wireless connection for that! Not only that it was not every track this applied to. About 90% though and it was not all related to albums I had bought on iTunes. Some were ones where I had copied in my CD.

    As said in my previous post I seem to have over come the problem by having to go through the process of ensuring iCloud is off for music on the iPad, then sync it but select no music in order to wipe out what is there, then disconnect, then sync again but select the iPad playlist I have to load in. But I had to do this twice to achieve success.

    It is not correct to say that with iTunes Match you can "manage the music on your device from wherever you are without a computer". You need iCloud to connect to it and for that you need a wireless connection.

    I have now got my playlist on to the iPad using the method described above but note that:

    1. If iTunes Match is switched off in settings the whole of my playlist is available to me. Fine I want that.

    2. If iTunes Match is switched on in settings I should also have what is in iCloud that I have matched available to me. It is not. None of the tracks that are not in the playlist but I know are in iCloud come up, only what is in the playlist. So I cannot download from iCloud even if I wanted to. Yes "Show all music" is switched on but it does not "show all music".

    3. If I switch out "Show all music" in the music settings it makes no difference. I suppose all it is doing is what it is intended - show only music on the iPad but I get that with it switched on - 2 above.

    Whilst I now have music on the iPad I can listen to without having to download it again what I cannot do is get something in my collection that is not there from iCloud as it does not show what is in the cloud. Which is err.. the whole point of iMatch and iCloud!

    There is a bug or flaw in the software somewhere.
     
  20. amitch001 macrumors newbie

    Joined:
    Mar 1, 2012
    #20
    Try " MyuZik - Music on Demand " . Best music discovery app with full songs. Only app in App Store which lets users to discover, explore more than 3 million artists and to listen artists full songs.

    Here is the link: http://itunes.apple.com/us/app/myuzi...502437704?mt=8
     
  21. jefyou macrumors newbie

    Joined:
    Dec 16, 2006
    #21
    Keeping music on the iPad (solved)

    Richard,

    I too use iMatch on my Mac, iPhone, and iPad (Wi-Fi only) while I travel. iMatch is fine and dandy while I am at home or in a Wi-Fi zone but not on a plane, in a car, etc because iMatch requires a connection to the iCloud. So, I created a playlist called "iPad Favs" that contained about 10GB of music that I wanted to have on my iPad for those times I do not have a connection. However, I wanted to have access to my 125GB collection when I am in a wi-fi zone. I think this is what you want too.

    All I did was, go into "Music" app on my iPad, select the "iPad Favs" playlist. Then when it opened up it shows all my songs with a cloud icon next to them. Just scroll all the way to the very bottom of the playlist. Mine has 1,856 songs so it's a lot of scrolling. When you get to the bottom, there is a "Download All" button. Click that and it will download a copy to your iPad storage. Do it in a wi-fi the first time if you have a large playlist. Once that is completed, you will have that entire playlist on your iPad and all your other music will be available through iMatch when you are in a wi-fi zone.

    I hope this helps.

    Jeff
     
  22. InfiniteWill macrumors newbie

    Joined:
    Apr 12, 2008
    Location:
    Overland Park, KS
    #22
    iCloud and iTunes match a disaster IMHO

    While I applauded the ability to access my library from anywhere, this implementation is a train wreck. First, in order to access my library I must be connected via Wi-Fi (not very likely as I travel all the time) or use my 3G connection (HUGE overage fees that the providers just love to tack on). Second, I can't seem to find a way to be able to sync music manually to my iPad (ver 1) at all so if I am in an area where I have not network connection, I am S.O.L. regardless. Finally, finding any music on my iPad via the cloud is brutally slow. From the time I launch iTunes on my iPad it can take 5 minutes before the library info is downloaded and I can actually select a track, artist, album or audiobook. Wiping the iPad clean and disabling iTunes Match has been of no help at all :(

    End of rant :)

    Will
     

Share This Page