Keeps Asking me for a Master Password in my OS X ??

Discussion in 'macOS' started by fab5freddy, May 20, 2009.

  1. fab5freddy macrumors 65816

    fab5freddy

    Joined:
    Jan 21, 2007
    Location:
    Heaven or Hell
    #1
    My Mac OS X
    keeps Asking me for a Master Password in my OS X ??

    How can i stop this ? It is rather annoying to always type this in.....
     
  2. TuffLuffJimmy macrumors G3

    TuffLuffJimmy

    Joined:
    Apr 6, 2007
    Location:
    Portland, OR
    #2
    Switch to an admin account. What are you doing that requires a password?
     
  3. JediMeister macrumors 68040

    Joined:
    Oct 9, 2008
    #3
    Master password is set in your Security System Preferences and is usually associated with a FileVault protected account. Have you enabled FileVault recently?
     
  4. fab5freddy thread starter macrumors 65816

    fab5freddy

    Joined:
    Jan 21, 2007
    Location:
    Heaven or Hell
    #4
    How do i turn this off ?

    ie. When i log into Skype, Adium, and other apps,
    it keeps asking me for my master password......
     
  5. dejo Moderator

    dejo

    Staff Member

    Joined:
    Sep 2, 2004
    Location:
    The Centennial State
    #5
    You're not running those apps from within disk-images, are you?
     
  6. JediMeister macrumors 68040

    Joined:
    Oct 9, 2008
    #6
    Are you absolutely certain it says "Master Password"? Could you possibly be confusing it with the "login" keychain instead, which is managed by your Keychain Access application?
     
  7. Peace macrumors P6

    Peace

    Joined:
    Apr 1, 2005
    Location:
    Space--The ONLY Frontier
    #7
    You may be confusing the FileVault master password.

    Open system preferences and select security. It might look like this :
     

    Attached Files:

  8. savanahrose macrumors 6502a

    savanahrose

    Joined:
    Jul 31, 2006
    Location:
    greer SC
    #8
    had the same problem with the keychain

    I don't know how it got messed up, I didn't change anything but I kept having to put my password in also. I found where the key chain was as fixed it. I haven't had any problems since then.
     
  9. fab5freddy thread starter macrumors 65816

    fab5freddy

    Joined:
    Jan 21, 2007
    Location:
    Heaven or Hell
    #9
    yeah, it is the keychain that keeps asking me for the password.....

    What do i do to stop the keychain from asking me for my password ??
     
  10. JediMeister macrumors 68040

    Joined:
    Oct 9, 2008
    #10
    Open the Keychain Access application inside of /Applications/Utilities. Make sure you have the login keychain selected on the left sidebar. Near the red, yellow, green dots in the upper left should be a lock icon. If it's closed, click it like you would the lock in System Preferences, and enter in your password. This should fix the issue. If, however, its already open, you may need to change your keychain password from one of the menus above or consider resetting the keychain or pulling the actual login.keychain file from its location in Finder, I think in ~/Library/Keychains.
     
  11. fab5freddy thread starter macrumors 65816

    fab5freddy

    Joined:
    Jan 21, 2007
    Location:
    Heaven or Hell
    #11
    So Would Resetting the Keychain erase all my stored Passwords ??
     
  12. JediMeister macrumors 68040

    Joined:
    Oct 9, 2008
    #12
    Yes, resetting the Keychain will set aside all the saved passwords. This includes things like an iChat account password, an AirPort network password, an AirPort base station password (to allow changes to configuration) your Mail application passwords, etc.
     

Share This Page