kernal panic-no safe mode-no target disk mode

Discussion in 'macOS' started by nissin, Jul 6, 2010.

  1. nissin macrumors newbie

    Joined:
    Mar 19, 2008
    #1
    I have a 15" mbp with 10.6 Intel core duo, 4gb ram with a boot camp and ubuntu partition through parallels.
    The other day I was installing xcode from apple's website, which failed 3 times after downloading saying the package couldn't be expanded. I left my computer for a while and came back where i then had to log in again. it rejected my password numerous time (i'm positive it was correct). when i restarted my computer i got a kernal panic screen when the apple logo came up. it told me to restart the computer which i did... didn't work. i restarted with the osx cd to use the disk utility. when it checked the drive it found a bunch of errors, which i then tried to correct. it went for a couple minutes then told me they couldn't be fixed and i should try to back up my data and reinstall osx. i don't know how to back up my hard drive when i can't log into my account.
    i've tried to boot in target disk mode and copy some files that way, but the only disk the other computer sees is my windows partition- no mac partition.
    i've also tried these, none of these have worked:
    restarting in safe mode
    resetting the ram and pram
    booting with different sticks of ram
    all result in a kernal panic.

    my windows partition still works fine though (as much as i hate to say it)

    the only things I really care about on my computer are my files from school and my itunes library. is there any way i can get these files off my computer?
    does anyone have any other ideas i could try?

    thank you for the help in advance
     
  2. iBookG4user macrumors 604

    iBookG4user

    Joined:
    Jun 27, 2006
    Location:
    Seattle, WA
    #2
    When you booted into Target Disk Mode, did you connect your MacBook Pro into a Mac or a PC? If a PC, they cannot read or write to HFS formatted hard drives, so you wouldn't be able to see your Mac partition on there.
     
  3. nissin thread starter macrumors newbie

    Joined:
    Mar 19, 2008
    #3
    right, it was into a slightly older mbp.
    i just got off the line with a really helpful apple tech with another problem, and he said my best bet was to back up my disk with the disk utility by pushing c when i boot. i've tried this before but it says my mac hd isn't mounted and it wont mount. hello genius bar appointment.
     

Share This Page