Kernel panic after restoring with Time Machine backup

Discussion in 'Mac Basics and Help' started by Callum, Jun 26, 2011.

  1. Callum macrumors member

    Joined:
    Jun 20, 2009
    #1
    I made a full system Time Machine backup. I then did a clean reinstall of Snow Leopard. I couldn't use the Setup Assistant from Time Machine because the OS from the disk hadn't been updated. So I downloaded and installed the complete OS X update from System Update. I then booted from the CD again and chose the option to restore from a Time Machine backup. I did that, all went well, was prompted to restart, then an error occurred:

    ---------------------------------------------------------------------
    panic(cpu 0 caller 0x47f5ad): " Process 1 exec of /sbin/launchd failed, errno 8\n"@SourceCache/xnu/xnu-1504.15.3/bsd/kern/kern_exec.c:3145
    Debugger called: <panic>
    Backtrace (CPU 0), Frame : Return Address (4 potential args on stack)
    (Then 7 separate lines with a bunch of numbers & letters, not sure how important they are but I'll type them up later if it'll help find the problem).

    BSD process name corresponding to current thread: init

    Mac OS version:
    Not yet set

    Kernel version:
    Darwin Kernel Version 10.8.0: Tue Jun 7 16:33:36 PM
    System model name: MacBook4,1 (Mac-F22788A9)

    System uptime in nanoseconds: 925358496
    ------------------------------------------------------------------

    Then an overlay message hovers above it saying: "You need to restart your computer. Hold down the Power button until it turns off, then press the Power button again."

    This happens each time I start up.

    What I've tried doing:
    Booting in safe mode by holding shift (doesn't work).
    Restarting PRAM (3 chimes with PR key combo)
    Holding command S to enter single user mode (keyboard nonresponsive to any commands).
    I've booted from the CD and repaired the disk and verified permissions from Disk Utility, but that didn't help.


    Please help me. If you need any more info, feel free to ask.
    Thanks,
    -Callum.
     
  2. JediMeister macrumors 68040

    Joined:
    Oct 9, 2008
    #2
    Wait, I'm confused. If you were going to restore from a backup, what's the point of reinstalling the OS? And you can run Migration Assistant after setting up the system, you don't have to run it during Setup Assistant unless you want to avoid creating a user account. This backup, is it to an external hard drive or a Time Capsule? And does this backup volume have the backups of multiple computers? Could you have selected the wrong backup from which to restore from? The fact you can boot to the install disc is a pretty sure sign that there's some type of software issue and that your hardware is fine.
     
  3. Callum thread starter macrumors member

    Joined:
    Jun 20, 2009
    #3
    I ran Migration Assistant. It made a new user account which is annoying, and didn't copy over all my applications, just the ones that come with the OS (iTunes, iCal, etc). Everything else copied over fine (documents, music library/playlists etc). The Dock was full of question marks where my other apps should have been. I tried copying them over from the backup but that didn't work.

    There is just one Time machine backup on an external hard drive. I feel like I need to run the Setup Assistant from the OS disk for everything to work well, but I'm scared it'll do the kernel panic thing again.
     
  4. JediMeister macrumors 68040

    Joined:
    Oct 9, 2008
    #4
    Okay, just so I'm understanding the timeline correctly here, after the clean install of 10.6, you updated to 10.6.8, then ran Migration Assistant, and restarting after the Migration finished led to the kernel panic? If the computer restarted fine after installing 10.6.8, and only got kernel panics after you migrated, either the data that was migrated is bad, or it's incomplete somehow. I'd bet on the latter since you mentioned your Applications weren't brought over. When you browse the backup volume do your backups have copies of your Applications and Users folders? Do you remember if you had set up any exclusions to prevent specific files and folders from being backed up in Time Machine? If you can I'd recommend recovering manually from the backup (after doing another clean install) just your Documents, Movies, Music, Pictures folders (Desktop as well if you had anything saved there) and seeing how that works out.
     
  5. Callum thread starter macrumors member

    Joined:
    Jun 20, 2009
    #5
    I clean installed, updated, then went back to the OS disk to run Setup Assistant. This lead to the kernel panic. I then had to clean install again, update, then ran migration Assistant, which lead to another user account/missing apps etc. When I did the original time machine backup I made sure there was nothing on the exception list.

    I'm wondering maybe I'm not updating to recent enough. I ran the automatic update and I'm still on 10.5.8. It's very hard to download these updates for me since I have a 350mb daily data cap. What's the the most recent update at the moment, and can I just download the latest manual pack from Apple.com and it will contain all the updates up until that point? It'll take several days to get though :(
     
  6. jalamiller macrumors newbie

    Joined:
    Jul 22, 2011
    #6
    I did a full restore from time machine and my machine did not boot after the restore. I got the grey screen. But, I just reinstalled snow leopard and everything was then back and ready to go. I only lost the one hour of work I had done since the last back up.

    I know some have posted about the machine not booting up after a full restore and they offer all kinds of detailed instructions (messing in Terminal, etc.) You don't need to do it. Just run your system install disk AFTER you do your full restore.
     
  7. sirocc0 macrumors newbie

    Joined:
    Jun 20, 2011
    #7

Share This Page