Kernel panic and weird Hdd behavior

Discussion in 'OS X El Capitan (10.11)' started by Boege, Aug 15, 2016.

  1. Boege, Aug 15, 2016
    Last edited: Aug 15, 2016

    Boege macrumors newbie

    Joined:
    Aug 15, 2016
    #1
    Hi all.
    I have a MBP mid 2010. I changed the Hdd to a 1 GB and installed El Capitan. Everything was running fine for some months but couple of days ago it froze and went into kernel panic on boot and has done so ever since. I booted on the old disk via USB, worked fine. I Can access the new disk but I could not partition, make passive, or anything. Tried to install snow leopard from the dvd that came with it and Got an error saying that I cant install to that disk.

    So I took the new disk out and put the old one in. Works fine. Then I connected the new one via USB which worked. Now I could make passive and active again. And afterwards I could boot from the USB connected new disk and all was good. Put it back in and Got the same kernel panic again...

    The kernel panic says
    Panic CPU 1 caller... User space panic: Assertion failed...
    Library/caches/com.apple.xbs/sources/xnu/xnu-3248.60.10/båd/kern/kern_s

    Some memory addresses

    BSD processes name corresponding to current thread: launchd.

    Have some more info but must type it in manually...

    So my question is - I could just buy a new disk but the one with the problem seems to be sort if working. Can anyone explain to me what may be going on and how to fix it?
     
  2. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #2
    Sounds like you have a bad internal drive cable to me. The fact you can out the new drive in the USB enclosure and it works fine it pretty much the proof of that.

    Sometimes a newer drive pulls more power or moves data at higher rates and can bring out a bad cable like this.

    iFixit sells the cables.
     
  3. Boege thread starter macrumors newbie

    Joined:
    Aug 15, 2016
    #3
    Thanks. I wasn't aware of that difference between old and newer drives. Will go and get a new cable and let you know what happens
     
  4. Boege thread starter macrumors newbie

    Joined:
    Aug 15, 2016
    #4
    That did the trick - got a new cable and installed it. Everything is back in order! Thanks
     

Share This Page