Kernel Panic at boot - RAM Issue

Discussion in 'Mac Basics and Help' started by MathiasMM, Feb 21, 2013.

  1. MathiasMM macrumors newbie

    Mar 7, 2011
    I have a 15-inch mid-2010 MBP running Mountain Lion, that I upgraded from 4 to 8 Gb of memory in Sept. 2012. The memory i purchased was a 2x4 gb set of Corsair Value rated at 1333 MHz. The upgrade went smooth, and i did not have any problems for a few months.
    Then late in december or early in january, I had a few Kernel Panics. I didn't think too much of it, as I was busy with exams, and thought it might be a software issue or something, maybe related to VMware Fusion. The KP's started getting a bit more frequent, and suddenly one day the machine wouldn't boot at all, it just KP's at the Apple logo and then goes in a loop. I now suspected a memory problem, as my experience tells me that this is a usual cause of KP's.
    I started fiddling with the memory sticks, and determined that one of the blocks would boot, so i went to the place i bought the set and talked to them. They agreed that the one block was probably faulty, and replaced my memory with a 2x4 Gb set of Corsair Mac Memory. This is 1066 MHz CL7, and should be compatible with MB,MBP and iMac, according to the packaging. The problem is that the machine will not boot with this memory either. It just goes for the same loop and KP's at the Apple logo. I can't even get this to boot with one stick in the machine, so it's arguably worse.
    The machine works well with the original memory, It's been a rock solid main machine with 4Gb of ram for about a month now.
    I tried PRAM and SMC reset to no avail. I tried booting into boot camp with the new memory, but it just never seems to load Windows. This also works with the old memory.
    I've tried the memory in a friends HP PC, where it boots with no problems at all. I've also tried running Rember in Safe Mode overnight, and the machine was still running when I got up in the morning.

    I've attached the most recent KP log.

    Can anyone figure out the problem?

    Edit: Oh, I should add that I have replaced my optical drive with an SSD that i boot OS X from. This was done about two years ago, a has not caused problems. Windows boots from the HDD.

    Wed Feb 20 14:35:01 2013
    panic(cpu 0 caller 0xffffff8009c43d8e): "a freed zone element has been modified in zone: maps"@/SourceCache/xnu/xnu-2050.18.24/osfmk/kern/zalloc.c:219
    Backtrace (CPU 0), Frame : Return Address
    0xffffff80ec313b20 : 0xffffff8009c1d626 
    0xffffff80ec313b90 : 0xffffff8009c43d8e 
    0xffffff80ec313bd0 : 0xffffff8009c435d2 
    0xffffff80ec313cb0 : 0xffffff8009c663f7 
    0xffffff80ec313cf0 : 0xffffff8009c67398 
    0xffffff80ec313e40 : 0xffffff8009c66388 
    0xffffff80ec313f10 : 0xffffff8009ff3538 
    0xffffff80ec313f90 : 0xffffff8009c323cc 
    0xffffff80ec313fb0 : 0xffffff8009cb26b7 
    BSD process name corresponding to current thread: kernel_task
    Mac OS version:
    Not yet set
    Kernel version:
    Darwin Kernel Version 12.2.0: Sat Aug 25 00:48:52 PDT 2012; root:xnu-2050.18.24~1/RELEASE_X86_64
    Kernel UUID: 69A5853F-375A-3EF4-9247-478FD0247333
    Kernel slide:     0x0000000009a00000
    Kernel text base: 0xffffff8009c00000
    System model name: MacBookPro6,2 (Mac-F22586C8)
    System uptime in nanoseconds: 1255606831
    last loaded kext at 522264221:	3.0.1 (addr 0xffffff7f8bf1d000, size 16384)
    loaded kexts:	3.0.1	1.0.0d1	1.0.0d1	34	404	2.2.2	5.2.5	4.9.6	3.2.5b3	602.15.22	5.2.5	2.4.1	5.4.0	161.0.0	1.6.1	1.6	1.5	1.7	1.9	1.6	1.6	196.0.0	4.0.39	2	196.0.0	5.2.5	5.2.5	5.2.5	4.5.5	1.0.2b1	500.15	3.0	2.2.1	5.4.0	1.6.1	1.8.0	1.1	220	1.0.0d1	7	344	1.8	28.21	1.6	2.7.2	1.4	1.0
  2. kpgh554 macrumors regular


    Dec 29, 2011
    iver england
    have you tried running with 6gb ram if put too much ram in it will k.panic as found out myself when run an app that was ram intensive it went into k.panic would not restart until put old ram back in then just added 6gb ram been running smooth since. 1x2gb bank 0 1x4gb bank 1
  3. MathiasMM thread starter macrumors newbie

    Mar 7, 2011
    I can't even boot with just one of the new sticks. Nothing. At least i could with one of the old blocks.
    What I don't get is that it used to work, but has now stopped. I would think it's the memory controller, but I don't get how it has problems with 8 gb, but not with 4 gb. I don't get how it has deteriorated like that either.
    And I don't get how it can work pretty well in Fail Safe mode, but then again, that mode IS Fail Safe, and I don't know what they did to make it so...
  4. kpgh554 macrumors regular


    Dec 29, 2011
    iver england
    if go to ifixit .com says there that your comp takes pc3-8500 ram so you could be putting wrong modules in
  5. MathiasMM thread starter macrumors newbie

    Mar 7, 2011
    That's exactly what i have :)
    Also, the machine used to work with the other modules.
  6. MathiasMM thread starter macrumors newbie

    Mar 7, 2011

Share This Page