Kernel Panic at startup - what to do?

Discussion in 'macOS' started by Jvhowube, Oct 25, 2007.

  1. Jvhowube macrumors member

    Joined:
    Aug 11, 2006
    #1
    hey guys,

    i'm really bumming right now. after i ran maintenance 3.6 yesterday, my computer (see specs in sig) restarted. It seemed fine, it 'bonged', I saw the apple logo on the gray screen, and then bam. Kernel panic. So, as per the instructions, I tried to restart - several times - to no avail. Same thing every time. I tried to reset the pRAM, no dice. I tried start up discs, and every time I put the disc in, I could boot from it, but when I got to the install screen (to open disk utility), I got "Alert: You cannot install any software from this disc." I tried slaving it via firewire to another mac, and then tried to run disk utility - the permissions options were grayed out, so i rana verify disk and repair disk, and there were several problems: volume header, volume bitmap, etc. After repairing those with disk utility, I ran techtool pro, and it saw the same problems again, apparently they had not been fixed, and techtool couldn't fix 'em either. The computer still doesn't start up.

    Is my last option to reformat? is it definitely something wrong with my drive? Do i need a new drive or is reformatting gonna take care of the problem?

    Oh and since i get the alert every time i start up from the boot disk, would I need to erase the disk as a firewire slave, and then install os x?

    Currently freaking out,
    Jordan
     
  2. projectle macrumors 6502

    Joined:
    Oct 11, 2005
    #2
    I have seen this happen every once in a while if the kernel itself becomes corrupted.

    One thing that you may want to try is pushing out one of the updates onto your computer from another Mac when yours is in Target Disk Mode and just mounted on the other computer.

    Additionally, you could try just replacing the kernel itself from another computer and hopefully that will resolve your issue.

    That would be the "mach_kernel" located at the root of your hard disk.

    /mach_kernel
     
  3. Jvhowube thread starter macrumors member

    Joined:
    Aug 11, 2006
    #3
    Instructions for Replacing mach_kernel

    This optional alternative may resolve the issue in limited circumstances in which the file "mach_kernel" needs to be replaced. It does not replace any of the other files included with a full reinstallation. The following steps should not be used for replacing items other than "mach_kernel". If these instructions are not followed precisely, Mac OS X may not start up correctly.

    Your computer has to be able to start from Mac OS 9 to use this method.

    1. Start up from a Mac OS 9 CD.
    2. Open the Startup Disk control panel.
    3. Select the Mac OS 9 System Folder.
    4. Restart the computer.
    5. Eject the Mac OS 9 CD.
    6. Insert the Mac OS X Install CD. A window opens showing the Installer window. Close this window.
    7. Double-click the Mac OS X Install CD icon.
    8. Drag the "mach_kernel" file from the top (or root) level of the CD to the top (or root) level of the Mac OS X hard disk volume.
    9. Replace the existing "mach_kernel" file in that location, if prompted for confirmation.
    10. Open the Startup Disk control panel, choose the Mac OS X System, and restart.
    11. If this resolves the issue, stop here.
    12. If the issue persists, return to the top of Reinstalling Mac OS X above.

    As per these instructions, I am currently unable to do this, as whenever I tried popping in the start disc, I got that Alert that locked me out. From what you said though, you can grab this file from another mac when in target disk mode? Isn't it invisible? Where do you grab it from?

    Thanks.

    -Jordan
     
  4. dr_lha macrumors 68000

    Joined:
    Oct 8, 2003
    #4
    Mac OS 9 will not boot on an Intel Mac, so that method is clearly not going to work!
     
  5. rodobrodo macrumors newbie

    Joined:
    Feb 13, 2008
    #5
    Kernel Panic At Startup Powerbook G4 17" Osx 10.4.11

    Good Day

    I left my laptop off for 3 months with no baterrie, duo a trip to EU, after trying to turn it on , I could not get pass by the Kernel display,
    I did backup my system through firewire as slave HD, I can start the computer holding down shift at startup, but then a few functions wont work, it is just the safe boot.

    I re-install my MAC OSX 10.4 then the up date to 10.4.11 but still no lock.

    I also try to connect it to the internet via ethernet cable but I guess it is disable.

    I really don't know what else to do,
     

Share This Page