Kernel panic at startup

Discussion in 'macOS' started by Heleen, Apr 21, 2010.

  1. Heleen macrumors newbie

    Heleen

    Joined:
    Oct 25, 2008
    Location:
    York, UK
    #1
    Hello,

    Yesterday I was helping someone getting to know their MacBook Pro (early 2008, Intel core 2 duo 2.4GHz, Mac OS X 10.5.2). I installed Perian and Flip4Mac and Firefox 3.6. I also checked for updates because she's on a very old version. I tried downloading the updates, but because we had a very bad internet connection I stopped the download quite early on and told her to do it at home.
    However after I left she tried to shut down the computer but it hanged. She manually shut it down using the power button. When she tried to turn it on again she got a kernel panic message saying she should reboot. This however didn't work.
    Now I've tried all sorts of things. I've removed Perian and Flip4Mac manually. I did a disk verification (all was well) and a permissions verification and repair. None of it seemed to help. I tried booting in safe mode (still won't boot) clearing the SMC and resetting PRAM, none of it worked.

    I am out of ideas. I just wanted to check here first before either taking it to an Apple store or reinstalling Mac OS X. I've read on forums about hardware failing (RAM mostly). No idea if that's the case. I tried a hardware test, but I don't have her DVDs and used my own with version 10.5.5. The Standard test said it was all ok, but the extended test seemed to hang. I could ask for her own DVDs which I will need anyway if I'm going to reinstall Mac OS X.

    Some details of the kernel panic:
    The error code is: 0x000000010
    Apart from that it says the following:
    Backtrace terminated-invalid frame pointer 0
    Kernel loadable modules in backtrace (with dependencies):
    com.apple.driver.AppleIntelCPUPowerManagement(76.2.0)@0x2e63c000->0x2e65afff

    And later on it says:
    Mac OS version:
    Not yet set.

    And of course it shows some more info with lots of hex codes, I can type them out for you if you like, but I read elsewhere that the error message is usually not very useful.

    I hope someone has any idea of what's going on. Would you recommend going to an Apple store to see if the RAM is faulty? Or do a reinstall of Mac OS X? Or do you have any other ideas?
    Thanks very much!
    Heleen
     
  2. dacreativeguy macrumors 68020

    Joined:
    Jan 27, 2007
    #2
    Do you have the original installation DVD? You can run the hardware test to see if it comes up with an error code. I had a 2.2ghz version of that generation and it and got power management errors like you are seeing. My temp sensor failed and the fans wouldn't come on to cool the machine. You may have a similar failure on the logic board. Either run the hardware test or just take it to Apple and let them do it.
     
  3. Heleen thread starter macrumors newbie

    Heleen

    Joined:
    Oct 25, 2008
    Location:
    York, UK
    #3
    Thanks for your reply. I will try to get the original installation DVDs and do the hardware test again. I was thinking it was making a weird sound. But it didn't really sound serious enough. My own MacBook (late 2008, aluminium) is very quiet so it might really be a normal sound (sort of a high continuous sound, maybe the fan or processor). But I'll do the test again tomorrow when I have the DVDs and see if that comes up with anything.
     

Share This Page