Kernel panic during boot camp asstnt partitioning

Discussion in 'Windows, Linux & Others on the Mac' started by xl1, Feb 12, 2008.

  1. xl1 macrumors newbie

    Joined:
    Feb 12, 2008
    #1
    During the attempt of bootcamp assistant to make a partition of 10gb on my hard disk with 44,72gb of free space i've got a kernel panic.
    Here is the log:
    Tue Feb 12 16:32:26 2008
    panic(cpu 0 caller 0x0031D1B3): "hfs_lock: locking against myself!"@/SourceCache/xnu/xnu-1228.3.13/bsd/hfs/hfs_cnode.c:986
    Backtrace, Format - Frame : Return Address (4 potential args on stack)
    0x3ccd36d8 : 0x12b0e1 (0x457024 0x3ccd370c 0x13321a 0x0)
    0x3ccd3728 : 0x31d1b3 (0x483cc0 0x0 0x3ccd3758 0x1f0d72)
    0x3ccd3758 : 0x31db5b (0x42f8840 0x3 0x0 0x3b96804)
    0x3ccd3848 : 0x1f2e30 (0x3ccd3860 0x0 0x3ccd3888 0x1f4d49)
    0x3ccd3888 : 0x1da8f0 (0x6547370 0x5d31844 0x340170 0x0)
    0x3ccd38a8 : 0x1da95d (0x6547370 0x0 0x283 0x43dfe40)
    0x3ccd38c8 : 0x3346c6 (0x6547370 0x68000 0x50e2cc0 0x43dfe40)
    0x3ccd3bc8 : 0x334a22 (0x5d31844 0x1937fff 0x2a616c 0x0)
    0x3ccd3c58 : 0x32bc00 (0x3b96804 0x38000000 0x19 0x5d31844)
    0x3ccd3cd8 : 0x1f5039 (0x3ccd3d08 0x0 0x3ccd3cf8 0x0)
    0x3ccd3d38 : 0x1e7e0c (0x3dcfc70 0x80006802 0x3ccd3ee0 0x0)
    0x3ccd3f78 : 0x3dbe77 (0x43dfe40 0x5d31740 0x5d31784 0xb0080d78)
    0x3ccd3fc8 : 0x19f084 (0x46faee0 0x0 0x1a20b5 0x46faee0)
    No mapping exists for frame pointer
    Backtrace terminated-invalid frame pointer 0xb0080d88

    BSD process name corresponding to current thread: DiskManagementTo

    Mac OS version:
    9C31

    Kernel version:
    Darwin Kernel Version 9.2.0: Tue Feb 5 16:13:22 PST 2008; root:xnu-1228.3.13~1/RELEASE_I386
    System model name: MacBookPro2,2 (Mac-F42187C8)

    I was running Leopard 10.5.2 and everything was fine.
    Please try to solve my issue.
    Thanks.

    macbook pro core 2 duo 15" Mac OS X (10.5.1) Upgraded to 10.5.2
     
  2. 01jamcon macrumors 6502a

    01jamcon

    Joined:
    Jul 24, 2006
    Location:
    London
    #2
    I had the exact same problem with my Macbook when I tried to partition it using Boot camp assistant and making the windows partition 8gb and it had a kernel panic part way through. I'm also running 10.5.2.

    The bad part is that there is an 8gb portion of my hard drive hard drive gone, which I can't find anywhere, not in disk utility, or in finder, or even when searched for in spotlight. If you find a solution please PM me.
     
  3. Tara Davis macrumors regular

    Joined:
    Mar 29, 2007
    #3
    Boot from OS X Install Disk
    Run Disk Utility
    Run "Repair Disk" on the boot drive

    That gets you back to square 1 with all your HD capacity. I'm still struggling to figure out how to do the partition without crashing. :(
     
  4. kens411 macrumors newbie

    Joined:
    Jan 29, 2008
    #4
    Bootcamp problems....

    I'm having the same problem with my new air. When creating a new partition, I get an error message before it finishes, the system shuts down and I have to reboot. I tried twice, each time using the disk utility on the install disk to repair the problem and recover the disk space back to normal. So far, all my searching points to no solution and that is is a common problem.

    Arrrgggggg......
     
  5. xl1 thread starter macrumors newbie

    Joined:
    Feb 12, 2008
    #5
    Finally i solved...

    Well, it looks strange but it's a problem of fragmentation.
    If you have a good application to defragment the unit you're going to use with Boot Camp, use it and probably will work.
    I didn't have it so i used carbon copy cloner, that is free, to clone a bootable copy of my macintosh hd on a firewire external disk and then, booting from there, i ran the same app to copy back all on my internal disk.
    This operation erases and rewrites the system in a contiguos way with the result of a defragmented volume where Boot Camp runs fine.
    That's it, now i can fly with my Macbook pro in the FlightSim skyes:D.
    Hoping that in the future Apple will provide a defrag utility in his os,
    bye to all.
     
  6. zolblu macrumors newbie

    Joined:
    Mar 23, 2008
    #6
    It did work!

    Good job xl1!

    I had the same problem using a MacBook running 10.5.2; moving the content of the hard drive back and forth, using SuperDuper and an external hard drive, resolved the issue.

    Thank you xl1!

    zolblu
     
  7. hajime macrumors 68030

    Joined:
    Jul 23, 2007
    #7
    iDefrag can solve your problem

    I am using 10.5.2. I used to have the same problem but iDefrag solved my problem. I am now using WinXP under Bootcamp happily. Have a look at: http://www.coriolis-systems.com/iDefrag.php
     

Share This Page