Kernel panic leaves no kernel log

Discussion in 'macOS Sierra (10.12)' started by souko, Jul 11, 2017.

  1. souko macrumors member

    Joined:
    Jan 31, 2017
    #1
    Hi,

    I have some kernel panics on my MacBook Pro 13" 2015. It began with macOS Sierra, I have tried revert to El Capitan, it was OK for some time, but after Kernel Panics again. So I went back to Sierra and 10.12.3 was with any kernel panic. But on all the other version it is about 1 kernel panic in 7-20 days. Kernel panics happen at random. Allways with black screen and: "Your computer restarted because of problem. Press a key or wait a few seconds to continue starting up." However, the kernel panic never leaves any logs in the /System/Logs/DiagnosticReports folder. I have problems with crashing sites on Safari, but it has logs and it is probbably different problem.
    As I revert back to El Capitan, I did two clean installs, without Time Machine restoring. However, I have used installators and data from my backup on external HDD.

    I have tried Apple hardware test, but it shows, that everything is ok. ( https://support.apple.com/en-us/HT201257 )

    My question is, what can I do? What kind of kernel panics do not dump logs in the DiagnosticReports directory? Can it be hardware problem? Is there some way to enforce writing kernel logs?
     
  2. treekram macrumors 6502a

    Joined:
    Nov 9, 2015
    Location:
    Honolulu HI
    #2
    Did you actually look in /System/Logs/DiagnosticReports or did you mis-type? The location should be
    /Library/Logs/DiagnosticReports for El Capitan and Sierra. (There is also a Library/Logs/Diagnostic reports in your home directory, but the one of interest is the one not in the home directory.) You can also use the Console app, press on "System Reports". The kernel panic logs start with "Kernel" and end with ".panic".

    It's possible that the system couldn't write the log file. If it can, it will write the log file. It could be a hardware problem, but most times it's a 3rd-party software issue, it can also be a OS-hardware combination issue or a 3rd-party hardware issue.

    Check to see if you actually have the kernel panic logs or not. That will determine the next step to take.

    Is 7 days the minimum time between kernel panics? If you have a long period between kernel panics, it would tend to rule out certain diagnostic approaches.
     
  3. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #3
    You are looking in the wrong folder. KP logs get written to NVRAM, then upon reboot transferred to this folder with the date/time of the KP. Note this is the main Library folder and not your user ~/Library folder.

    Code:
    /Library/Logs/DiagnosticReports 
     
  4. souko, Jul 11, 2017
    Last edited: Jul 11, 2017

    souko thread starter macrumors member

    Joined:
    Jan 31, 2017
    #4
    I am sorry, I looked into user Library.
    The shortest time between two Kernel panics was 1 day. But I think average is something about 7-10 days if I do not count with 10.12.3.

    So in Library there was one Kernel Panics from today, so here it is:

    Tue Jul 11 13:51:20 2017

    *** Panic Report ***
    panic(cpu 1 caller 0xffffff800a96c0df): initproc exited -- exit reason namespace 2 subcode 0xb description: none

    uuid info:
    0x112fbc000 uuid = <322c06b7-8878-311d-888c-c8fd2ca96ff3>
    0x10569a000 uuid = <acffe021-d0e3-316c-b168-1880d8c8fd1d>

    Thread 6 crashed

    RAX: 0x00000000ffffffff, RBX: 0x0000000105a29d40, RCX: 0x00007f80b1f00000, RDX: 0x0000000000010000
    RSP: 0x00007000028e1c70, RBP: 0x00007000028e1c80, RSI: 0x00007f80b1f00000, RDI: 0xffffffffffffffff
    R8: 0x00007f80b4164070, R9: 0xfffffffd00000001, R10: 0x0000000400000000, R11: 0x003fffffffffffff
    R12: 0x0000000105a06f00, R13: 0x00007f80b41640a8, R14: 0x0000000000010000, R15: 0x00007f80b1f00000
    RFL: 0x0000000000010286, RIP: 0x00007fffb5fa4d3d, CS: 0x000000000000002b, SS: 0x0000000000000023

    Thread 0: 0xffffff801d1d8050
    0x00007fffb60ee1e6
    0x00007fffb5f9724f
    0x0000000000000000

    Thread 1: 0xffffff801d1d4dc8
    0x00007fffb61d8070

    Thread 2: 0xffffff8020aca078
    0x00007fffb61d8070

    Thread 3: 0xffffff8028632930
    0x00007fffb60ee44e
    0x00007fffb61d807d
    0x0000000000000000

    Thread 4: 0xffffff8028633260
    0x00007fffb61d8070

    Thread 5: 0xffffff8028635bb8
    0x00007fffb60ee44e
    0x00007fffb61d807d
    0x00007f80b1ccac30

    Thread 6: 0xffffff80285c8930
    0x00007fffb5fa4d3d
    0x00007fffb5f94cd0
    0x00007fffb5f8c243
    0x00007fffb5f9f7db
    0x00007fffb5f92306
    0x00007fffb5f8b6b5
    0x00007fffb5f8b48c
    0x00007fffb61d85a2
    0x00007fffb61d807d
    0x0000000000000000


    Mac OS version:
    16F73

    Kernel version:
    Darwin Kernel Version 16.6.0: Fri Apr 14 16:21:16 PDT 2017; root:xnu-3789.60.24~6/RELEASE_X86_64
    Kernel UUID: FB2170A8-257D-3C64-B14D-BC06CC94E34C
    System model name: MacBookPro12,1 (Mac-E43C1C25D4880AD6)

    System Profile:
    AirPort: spairport_wireless_card_type_airport_extreme (0x14E4, 0x133), Broadcom BCM43xx 1.0 (7.21.171.126.1a2)
    Bluetooth: Version 5.0.4f18, 3 services, 17 devices, 1 incoming serial ports
    Thunderbolt Bus: MacBook Pro, Apple Inc., 27.1
    Memory Module: BANK 0/DIMM0, 4 GB, DDR3, 1867 MHz, 0x80AD, 0x483943434E4E4E424C54414C41522D4E5544
    Memory Module: BANK 1/DIMM0, 4 GB, DDR3, 1867 MHz, 0x80AD, 0x483943434E4E4E424C54414C41522D4E5544
    USB Device: USB 3.0 Bus
    USB Device: Bluetooth USB Host Controller
    Serial ATA Device: APPLE SSD SM0256G, 251 GB
    Model: MacBookPro12,1, BootROM MBP121.0167.B24, 2 processors, Intel Core i5, 2,7 GHz, 8 GB, SMC 2.28f7
    Network Service: Wi-Fi, AirPort, en0
    Graphics: Intel Iris Graphics 6100, Intel Iris Graphics 6100, Built-In

    But in Library is only this Kernel Panic, but I had another KP one I think week back.
    And maybe another note: this was KP during restarting my Mac. As I hit restart, than it looked OK, but after few seconds KP. All the other KPs were during normal operation.
     
  5. treekram macrumors 6502a

    Joined:
    Nov 9, 2015
    Location:
    Honolulu HI
    #5
    Take a look at the other logs (if there are others) and see if there are any similar to the following - if there is, post it here.

    Anonymous UUID: AC738F4F-1692-8E57-707B-C07769B7C3C8

    Tue Jun 9 20:51:02 2015

    *** Panic Report ***
    panic(cpu 5 caller 0xffffff8008417cc2): Kernel trap at 0xffffff80083cf5a6, type 14=page fault, registers:
    CR0: 0x000000008001003b, CR2: 0xffffffbf79397a28, CR3: 0x0000000427c32060, CR4: 0x00000000001626e0
    RAX: 0xffffff7f80000000, RBX: 0xffffff802671e0c0, RCX: 0xffffff7f80000028, RDX: 0x0000003ff9397a00
    RSP: 0xffffff81f2fbbce0, RBP: 0xffffff81f2fbbd10, RSI: 0x000000004d4f53ef, RDI: 0xffffff800d1ffd40
    R8: 0xffffff80412e0b00, R9: 0x0000000000000000, R10: 0x0000000000000000, R11: 0x0000000000000000
    R12: 0xffffff800d1ffd40, R13: 0xffffff800c1e6000, R14: 0x000000000007f000, R15: 0xffffff803cdc2c30
    RFL: 0x0000000000010206, RIP: 0xffffff80083cf5a6, CS: 0x0000000000000008, SS: 0x0000000000000000
    Fault CR2: 0xffffffbf79397a28, Error code: 0x0000000000000000, Fault CPU: 0x5

    Backtrace (CPU 5), Frame : Return Address
    0xffffff81f2fbb990 : 0xffffff800832bda1
    0xffffff81f2fbba10 : 0xffffff8008417cc2
    0xffffff81f2fbbbd0 : 0xffffff8008434b73
    0xffffff81f2fbbbf0 : 0xffffff80083cf5a6
    0xffffff81f2fbbd10 : 0xffffff80083993f9
    0xffffff81f2fbbf20 : 0xffffff8008418224
    0xffffff81f2fbbfb0 : 0xffffff8008434a85

    BSD process name corresponding to current thread: Finder

    Mac OS version:
    14D136

    Kernel version:
    Darwin Kernel Version 14.3.0: Mon Mar 23 11:59:05 PDT 2015; root:xnu-2782.20.48~5/RELEASE_X86_64
    Kernel UUID: 4B3A11F4-77AA-3D27-A22D-81A1BC5B504D
    Kernel slide: 0x0000000008000000
    Kernel text base: 0xffffff8008200000
    __HIB text base: 0xffffff8008100000
    System model name: Macmini6,2 (Mac-F65AE981FFA204ED)

    System uptime in nanoseconds: 49893283445612
    last loaded kext at 48256683013362: com.apple.filesystems.msdosfs 1.10 (addr 0xffffff7f8abbb000, size 69632)
    last unloaded kext at 48532610960047: com.apple.iokit.IOUSBMassStorageClass 3.7.2 (addr 0xffffff7f8aba3000, size 69632)
    loaded kexts:
    com.apple.filesystems.smbfs 3.0.1


    What you should be looking for is the text "BSD process name corresponding to current thread:"
    and "last loaded kext".

    If you don't have any logs like this, that's OK, that also gives an indication of what kind of kernel panic it is.
     
  6. souko thread starter macrumors member

    Joined:
    Jan 31, 2017
    #6
    There are any other KP report. I had KP week back, but any other logs.
     
  7. treekram macrumors 6502a

    Joined:
    Nov 9, 2015
    Location:
    Honolulu HI
    #7
    The "initproc exited" seems to be associated with sleep issues. But because you got this as you were re-starting, and if you don't have kernel panics which occur when you wake, I would guess that it isn't associated with sleep-wake issues.

    There's not much else to go on. You can try resetting the NVRAM, see the following:
    https://support.apple.com/en-us/HT204063

    Resetting the NVRAM helped some people where having the sleep-wake issue mentioned earlier, so it may help.

    I would suggest running EtreCheck and posting the results here. Any data which identifies your computer or is blanked out in the report which is meant for uploading. If you want to try the NVRAM reset before doing EtreCheck, that's fine. The EtreCheck report can identify kernel extensions, plug-ins etc. that may be the cause of a kernel panic.
    https://www.etrecheck.com/

    If you are able to go to a Genius Bar at an Apple Store, you can try that - they can run more thorough hardware diagnostics.

    It's also possible that the problem is RAM-related, but because you can go multiple days without a kernel panic and because you have 8GB (vs. 16GB), I would suspect it isn't the RAM. But there are programs that can more extensively test the RAM, even more so that what they can do at an Apple Store (due to time constraints), so this is a possibility if you still can't find a solution.
     
  8. souko, Jul 11, 2017
    Last edited: Jul 11, 2017

    souko thread starter macrumors member

    Joined:
    Jan 31, 2017
    #8
    I have tried resetting the NVRAM, I think, 1 month back and it did not help.
    Unfortunately I do not have Apple Store in my country.
    Maybe we can try RAM, because I can go multiple days without KP, but not every day I use my MacBook.
    Here is log from EtreCheck:
    EtreCheck version: 3.4 (420)

    Report generated 2017-07-11 23:22:42

    Download EtreCheck from https://etrecheck.com

    Runtime: 2:10

    Performance: Excellent



    Click the [Lookup] links for more information from Apple Support Communities.

    Click the [Details] links for more information about that line.



    Problem: Computer is restarting



    Hardware Information:

    MacBook Pro (Retina, 13-inch, Early 2015)

    [Technical Specifications] - [User Guide] - [Warranty & Service]

    MacBook Pro - model: MacBookPro12,1

    1 2,7 GHz Intel Core i5 (i5-5257U) CPU: 2-core

    8 GB RAM Not upgradeable

    BANK 0/DIMM0

    4 GB DDR3 1867 MHz ok

    BANK 1/DIMM0

    4 GB DDR3 1867 MHz ok

    Bluetooth: Good - Handoff/Airdrop2 supported

    Wireless: en0: 802.11 a/b/g/n/ac

    Battery: Health = Normal - Cycle count = 211

    iCloud Quota: 125.98 GB available


    Video Information:

    Intel Iris Graphics 6100 - VRAM: 1536 MB

    Color LCD 2560 x 1600


    Disk Information:

    APPLE SSD SM0256G disk0: (251 GB) (Solid State - TRIM: Yes)

    [Show SMART report]

    EFI (disk0s1 - MS-DOS FAT32) <not mounted> [EFI]: 210 MB

    (disk0s2) <not mounted> [CoreStorage Container]: 250.14 GB

    Recovery HD (disk0s3 - Journaled HFS+) <not mounted> [Recovery]: 650 MB


    USB Information:

    USB30Bus

    Broadcom Corp. Bluetooth USB Host Controller


    Thunderbolt Information:

    Apple Inc. thunderbolt_bus


    Virtual disks:

    APPLE SSD SM0256G Media (disk1 - Journaled HFS+) / [Startup]: 249.78 GB (68.14 GB free)

    Encrypted AES-XTS Unlocked

    Physical disk: disk0s2 250.14 GB Online



    System Software:

    macOS Sierra 10.12.5 (16F73) - Time since boot: about 9 hours


    Gatekeeper:

    Mac App Store and identified developers


    Kernel Extensions:

    /Applications/ESET Cyber Security.app

    [loaded] com.eset.kext.esets-kac (6.4.200 - SDK 10.6) [Lookup]

    [not loaded] com.eset.kext.esets-mac (6.4.200 - SDK 10.6) [Lookup]

    [loaded] com.eset.kext.esets-pfw (6.4.200 - SDK 10.6) [Lookup]



    /Applications/iSkysoft iTube Studio.app

    [not loaded] com.Perfect.Driver.SystemAudioRecorder (1.1.0 - SDK 10.6) [Lookup]



    System Launch Agents:

    [not loaded] 6 Apple tasks

    [loaded] 177 Apple tasks

    [running] 99 Apple tasks


    System Launch Daemons:

    [not loaded] 42 Apple tasks

    [loaded] 167 Apple tasks

    [running] 108 Apple tasks


    Launch Daemons:

    [running] com.eset.esets_daemon.plist (ESET, spol. s r.o. - installed 2017-04-08) [Lookup]

    [loaded] com.microsoft.autoupdate.helper.plist (Microsoft Corporation - installed 2017-04-14) [Lookup]

    [loaded] com.microsoft.office.licensingV2.helper.plist (Microsoft Corporation - installed 2016-09-10) [Lookup]

    [loaded] com.skype.skypeinstaller.plist (Skype - installed 2017-03-22) [Lookup]

    [loaded] com.surteesstudios.Bartender.BartenderInstallHelper.plist (Surtees Studios Limited - installed 2017-04-28) [Lookup]

    [loaded] com.tunabellysoftware.TGFanHelper.plist (Tunabelly Software - installed 2016-12-27) [Lookup]


    User Login Items:

    ESET Cyber Security Aplikace

    (/Applications/ESET Cyber Security.app)


    Internet Plug-ins:

    QuickTime Plugin: 7.7.3 (installed 2017-05-15)



    Audio Plug-ins:

    BartenderAudioPlugIn: 1.0.0 (installed 2016-09-14) [Lookup]



    3rd Party Preference Panes:

    None


    Time Machine:

    Time Machine not configured!



    Top Processes by CPU:

    16% kernel_task

    9% nsurlsessiond

    6% cloudd

    5% accountsd

    5% WindowServer


    Top Processes by Memory:

    901 MB kernel_task

    236 MB com.apple.WebKit.WebContent

    227 MB CalNCService

    215 MB com.apple.WebKit.WebContent

    139 MB Safari


    Top Processes by Network Use:

    Input Output Process name

    69 MB 14 KB nsurlsessiond

    2 MB 84 KB com.apple.WebKit.Networking

    269 KB 91 KB mDNSResponder

    58 KB 87 KB netbiosd

    22 KB 20 KB Spotify


    Top Processes by Energy Use:

    9.44 nsurlsessiond

    6.70 WindowServer

    6.42 cloudd

    2.08 bird


    Virtual Memory Information:

    1.87 GB Available RAM

    56 MB Free RAM

    6.13 GB Used RAM

    1.82 GB Cached files

    470 MB Swap Used


    Software installs:

    Fotor Photo Editor: 3.3.0 (installed 2017-06-24)

    T-Timer: 2.1 (installed 2017-07-03)

    Fotor Photo Editor: 3.3.1 (installed 2017-07-04)



    Install information may not be complete.


    Diagnostics Information:

    2017-07-11 13:51:20 Kernel Panic [Open] [Details]

    3rd Party Kernel Extensions: None



    And thanks for helping!
     
  9. treekram macrumors 6502a

    Joined:
    Nov 9, 2015
    Location:
    Honolulu HI
    #9
    Make sure you have the latest version of the software that's listed under the "Kernel Extensions" and the "Launch Daemons". Also check the websites of these companies to make sure they are compatible with Sierra. After you update the software, see if the kernel panics recur. I noticed that for ESET Cyber Security, for example, you have 6.4.200 and the latest version on their website is 6.4.200.1 (there may be a discrepancy in how they report but you get the idea - check the software versions).

    If, after the software is updated, you are still getting kernel panics, look for the kernel panic log similar to the example I posted above and post it here. Of all the software you have listed, my guess is that it would be the ESET software that would be the issue. You can try disabling it and see if kernel panics recur. You may need to go through each of the software (you can probably skip the Microsoft updaters) and try disabling it. You will know that the software is disabled by re-running the EtreCheck and see that it's either "not loaded" or "not running" or doesn't appear on the list.

    Based on the software you have, I think it's more likely a software issue than a hardware issue.
     
  10. souko, Jul 12, 2017
    Last edited: Jul 12, 2017

    souko thread starter macrumors member

    Joined:
    Jan 31, 2017
    #10
    OK, I updated everything (ESET was on current version 6.4.200.1 - probbably some issue with reading it by EtreCheck). But I was running my mac without Eset for some time and there were KP too.
    OK I will try disabling apps, maybe reinstalling macOS, with few software installed.
    I will let you know, how it is working.

    Thanks for your help.
     
  11. treekram macrumors 6502a

    Joined:
    Nov 9, 2015
    Location:
    Honolulu HI
    #11
    The EtreCheck version may be different than the ESET version because whatever file that EtreCheck uses for the version check may not have been changed in the .1 version.

    When you test to see if software ESET is causing the issue, you should run the EtreCheck and check the "Kernel Extensions" and "Launch Daemons" sections to make sure they are "not loaded" or not running. Some software may have a disable or stop running option but may not unload the kernel extension. If you disable the software and you find that the kernel extensions and/or launch daemons are still running, you can try rebooting and see if that clears it. If it doesn't, there are commands that can be used to unload the software but it may just be better to uninstall the software.

    If you're thinking of reinstalling the OS, one approach would be to start with none of the software listed in the "Kernel Extensions" and "Launch Daemons" (again the Microsoft software should be OK) and then adding it one at a time. But with your current setup I think there's a good chance that the next time (if there is a next time) the kernel panic happens and if it is software related, a more helpful kernel panic log will be produced (similar to the one I listed in post #5) and that should help narrow down the cause.
     
  12. souko thread starter macrumors member

    Joined:
    Jan 31, 2017
    #12
    So I have reinstalled macOS, and install only important software. I have nothing in these two categories. So I hope it will be OK.

    Thanks for your help!
     

Share This Page