Kernel Panic, nothing works..

Discussion in 'Mac Basics and Help' started by roychen, Mar 4, 2007.

  1. roychen macrumors newbie

    Nov 14, 2006
    Hello all,

    Been trying to troubleshoot a friend's MacBook for hours now. I've found out that it's a kernel panic by booting into verbose mode.

    Basically, the MacBook won't boot into OS X. It also won't read the OS X install disc to allow me to do a fresh install. It gets stuck at that screen when it says you have to restart your Mac.

    Stuff I've tried:
    1. It's not a memory issue, I've replaced the memory with the sticks from my own MacBook, and they're working.

    2. I've tried booting into single user mode to do /sbin/fsck -fy, it claims the hard disk is fine.

    3. The install disc is fine, I've just booted from it on my own MacBook.

    4. Both MacBooks are C2D ones, so it's definitely not an OS X version problem with the install disc.

    Interestingly, this MacBook has Boot Camp and Windows XP installed, and Windows won't boot either! Apparently it's missing a hal.dll file, which I've tried to replace with no success. I've tried doing a repair installation of Windows XP first, but setup hangs when it detects the MacBook's wireless card (possibly due to the fact I'm doing a repair, plus I've installed Apple's Windows drivers previously).

    I'm really at my wit's end, and any help would be greatly appreciated. Thanks.
  2. robbieduncan Moderator emeritus


    Jul 24, 2002
    Have you tried running the hardware test?

    It sounds like a terminal logic board issue...
  3. roychen thread starter macrumors newbie

    Nov 14, 2006
    Thanks for the quick reply.

    Everything is fine according to the short hardware test. I'm running the extended one now just to be sure.

    EDIT: Extended hardware test reports no errors either.

    Would you have any more ideas on what could be wrong?
  4. Frisco macrumors 68020

    Sep 24, 2002
    Can you post a Kernel Panic log? I wonder if it's your Airport Card that's causing this.
  5. roychen thread starter macrumors newbie

    Nov 14, 2006
    I'm afraid I can't, there is no panic.log file in /Library/Logs.

    I suppose it's because the kernel panic occurs before OS X even fully starts and has a chance to trap it.

    Booting into single user mode shows that the panic is an unresolved kernel trap (CPU 0, Type 14=page fault), and no mapping exists for frame pointer, and the backtrace terminates with an invalid frame pointer. (Sorry, there's plenty other of lines with hex addresses and stuff which would take ages to type out..)

    Looking at it it would appear that it's a memory issue, but as stated in my original post I've already tested the memory and they appear to be fine.
  6. Shadow macrumors 68000


    Feb 17, 2006
    Keele, United Kingdom
    Yeah we really need a Panic Log in order to properly diagnose this. Try going into Firewire Disk Mode and getting it from there.

    EDIT: Just missed getting the post in time. Anyway, if the KP happens before OS X starts enough for it to log it, then you almost definitely have a hardware problem. I would go into Firewire Disk Mode and recover as much as you can and ring AppleCare. Sorry!

    EDIT 2: Having thought about it, if you can get that far into the boot in startup mode, it implies there is some software that is causing the problem. Go into /System/Library/StartupItems and /Library/StartupItems and /Users/[Username]/Library/StartupItems.
  7. roychen thread starter macrumors newbie

    Nov 14, 2006
    Looking in /System/Library/StartupItems, there are:

    Apache, AppServices, AppleShare, AuthServer, CrashReporter, Disks, FibreChannel, IFCStart, IPServices, Metadata, NFS, NIS, NetworkTime, PrintingServices, RemoteDesktopAgent, SNMP

    All the above are directories, is there something in them I should be looking for?

    Looking in /Library/StartupItems, there is only Parallels, again a directory.

    There is no StartupItems directory in /Users/<user>/Library/.
  8. robbieduncan Moderator emeritus


    Jul 24, 2002
    If neither XP or OSX can start it really points towards a hardware issue. If the installer DVD won't even boot this just points that way more strongly. I'd try and recover the data if you can the take it in for repair.
  9. roychen thread starter macrumors newbie

    Nov 14, 2006
    Thanks, I guess that's my only option now, will be heading to my uni's Apple store to get them to take a look at it.
  10. gsabin macrumors newbie

    Jan 6, 2004
    I am having the exact same problem.

    MacBook Pro, Boot Camp, *and* Parallels (which I believe is a large portion of the problem).

    I can (eventually, see below) boot into windows by holding down option when booting, then choosing windows, then repeatedly hitting the down arrow, then choosing "Windows" (the non-Parallels choice).

    I get the hal.dll file error when trying to boot into Windows, because the default Windows "OS choice" is parallels. I am able to boot into Windows fine if I can catch the "OS choice" menu, by pressing the down arrow repeatedly (note: it takes many tries!).

    If you get this figured out please let me know.
  11. sahajesh macrumors member

    Dec 12, 2004

    Get this same issue myself on a MacBook with Boot Camp and Parallels (this is using the Boot Camp partition). I can boot into XP (thankfully), again the OSX Install DVD does not load (although it works fine on other machines).

    I'll try deleting Parallels from the StartupItems and reboot and look for a panic log as well. The first time I got into XP, I changed the boot.ini to make Boot Camp XP (rather than Parallels XP) the default OS.

    The fact that XP works fine leads me into thinking it's NOT a hardware issue with the MacBook ie logic board etc.

    Any ideas??
  12. gsabin macrumors newbie

    Jan 6, 2004
    Sorry I did not reply sooner. There seems to be quite a few people wiht this issue...

    Here is what worked for me (originally obtained from

    1) Boot into single user mode (hold apple-s when booting).
    2) Run "fsck_hfs -d -r -y -f /dev/rdisk0s2" at the command prompt, may take a while to complete.
    3) Type "reboot" and press enter when done
    This fixed quote a few problems for me and then I was able to reboot into OSX without any problems. Good luck!
  13. cowm007 macrumors regular

    Feb 2, 2005
    Hey, I had a similar problem with my MacBook. I deleted my Windows partition using Boot Camp, then restarted and FileVault asked to reclaim some space, which I accepted. Then on restart, 10 seconds in I would get a Kernel Panic. I did the fsck stuff and that seems to have fixed the problem. Thanks.

Share This Page