Kernel Panic on boot with fresh install (PB 17")

Discussion in 'MacBook Pro' started by z16bitsega, Jan 12, 2007.

  1. z16bitsega macrumors newbie

    Jan 12, 2007
    I bought a used 17 inch Powerbook G4 (1ghz, 512mb ram, superdrive) that was advertised as needing a hard drive and a battery. I put in a new (known working) hard drive and installed Tiger on it (with some difficulty, it locked up once on the "preparing for installation" screen), but whenever it tries to boot after the installation finishes, I get a kernel panic before the OS loads. I tried reinstalling twice and got the same thing. I think it's probably the logic board, but is there anything else I should try before I give up and list it on ebay as a parts unit?
  2. rijiMacDij macrumors regular

    Hey! Me Too!!


    I have a similar problem. Bought a 17" 1.5 with new HD fitted. I have performed 20+ instals of various types, from fresh 10.4 to restoring from another machine with 10.8 and installing from the release 10.3.4 disc that shipped with the machine. It has various symptoms including the "FU buddy, I'm going to panic instead of booting into Mac OS".

    I have been able to get it to boot into the OS with most instals but they become corrupted at a very early stage. Things start happening such as:

    * you open a finder window in column view and the icons are missing.
    * the system begins to run very slowly, lots of spinning beach balls.
    * apps wont start because support files have gone AWOL?
    * You restart only to get the gray screen of Mac-Coma!

    About a month ago I ran the Apple Hardware Test from the gray disc that comes with the machine, and I got mixed results. It passed on about 1 in 4 attempts at running the extended test, but the HD fails in 3 out of 4 runs with the following message:

    2STF/8/3: ATA- 100 ata-6 - Master


    I contacted the seller who offered to replace the drive as it was under warranty, but after zero-ing the disc again, I couldn't get it to fail another test. After running the test 20 or more times I re-installed by using the restore from another mac using firewire target disc mode and it ran without fault for about a month.

    It has now reverted back to the previous problem behaviour and fails 3 out of 4 tests with the same error message as before.

    Have you run the Apple Hardware Test?

    I am thinking "intermittent HD fault" of a minor, but disastrous nature?

    Maybe a tiny short in the HD wiring?

    Is there anybody out there who can shed some light on this problem?
  3. TraceyS/FL macrumors 601

    Jan 11, 2007
    North Central Florida
    I was having weird issues last month with teh kids eMac. I cleaned the hard drive, got it to format, but could NOT install OSX at all. It would just die.

    Turns out I had a bad RAM chip - wasn't it FUN figuring out which one of the 2 it was :D But, when I removed it all was well - and all is back running well with the replacement one.

    Prior the major issues that made me erase and start over, i was just getting funky freezes and quits. I never thought it was the RAM though - and everything passed on the Hardware tests.

    SOOO, that is my "help" for the day. I hope it is as "easy" as that for you guys.
  4. rijiMacDij macrumors regular

    Yeah, thanks, but tried that once!

    Yep, RAM was my first suspicion so I reefed out one of the 512s and replaced it with a GIG.

    It seemed to help a bit but before long things were mucking up again. That's when I ran the Apple Hardware Tests which indicated that the RAM was in good order.

    I may pull the other 512 stick out yet, but I thought that the stuff I was losing should have been on the hard drive, not in the RAM. These were system files, application support files, etc.

    One recurring problem was that the Volume where the OS was installed was becoming unreadable due to basic directory errors developing?

    Please excuse my guesswork due to lack of background knowledge, I am a late starting immigrant in the computer world.
  5. z16bitsega thread starter macrumors newbie

    Jan 12, 2007
    I'm pretty certain it's not the hard drive, I've been using it in my PC laptop for the past year without a problem (as a matter of fact I put it back in my pc and I'm using it now, since I'll need a laptop tomorrow).

    As for the RAM, I did try that, but got weird results. When I tried a generic 512 from my PC, it gave a memory error (probably because the Powerbook is apparently picky about memory). But when I tried a Samsung (same brand as used by Apple) 256 out of my PC, the screen came on for a couple seconds, then shut off. Not sure what was up there, maybe there are problems running a powerbook with less than stock ram, or maybe I didn't have it seated right.

    As for the apple hardware test, I don't have the restore CD/DVD that came with the system originally, so I can't try that.
  6. IJ Reilly macrumors P6

    IJ Reilly

    Jul 16, 2002
    The Hardware Test CD is worth a try in situations like this, but in fact the only helpful result is a positive one -- the CD not finding a problem doesn't mean much, especially if the problem is bad RAM (which it very often is). A better method of checking RAM is "memtest" which can be downloaded from VersionTracker.
  7. rijiMacDij macrumors regular

    Thanks IJ,

    I paid the miniscule buck or so and downloaded MemTest. It ran like a dream and after several passes I am now a lot more confident that the RAM is not to blame.

    I have downloaded a piece of diagnostic software from Samsung to have a closer look at the HDD.

    I think I need to start a new thread to find out how to run a DOS program now!
  8. z16bitsega thread starter macrumors newbie

    Jan 12, 2007
    Bumping this to give an update, just in case anyone else has this issue. The problem turned out to be the internal modem; I disconnected it, and the computer hasn't given me a problem since.
  9. IJ Reilly macrumors P6

    IJ Reilly

    Jul 16, 2002
    Thanks for the update. I suspect this is an unusual hardware issue but it's certainly worth knowing what caused it.
  10. Gokhan macrumors 6502a

    Oct 7, 2003

    ahhh finally thanks guy mu ibook had the exact same issue it would always see the hardrive but cause bad sectors after a while so i think ill try your solution **** i tried everything else !!!
  11. rijiMacDij macrumors regular


    Modem Huh! Sounds like an easy fix but I only have Dial-Up! I suppose I could use an external USB modem but I've heard they suck.

    Somebody told me that the computer writes a little file to the 'Boot Sector' on the hard drive before it shuts down. I'm told this is an instruction to the computer to follow on booting, so it knows which disk to boot from and which files to open etc.

    I am still curious to find out why the directories, overflows, hierarchies and permissions are being trashed?

    I want to rip out the hard drive and send it back to Samsung but they don't want to take it unless I have run their diagnostic utility and the unit has been found guilty as charged. All the info and utility downloads at Samsung are DOS and instructions relate strictly to MicroSoft Windows.

    The upside of all this is that I am actually learning stuff(?) that I wouldn't if things were going swimmingly.

Share This Page