Kernel Panic on installing Mountain Lion

Discussion in 'OS X Mountain Lion (10.8)' started by gotanimac, Jul 26, 2012.

  1. gotanimac macrumors member

    Aug 24, 2010
    Downloaded Mountain Lion and started the install... now on boot up my iMac just says I need to reboot.

    It has a kernel panic on kern_exec.c:3546.

    How do I run a disk check or some sort of restore mode? I'm not even sure I have a restore disk, I do have a Time Machine.
  2. gotanimac thread starter macrumors member

    Aug 24, 2010
    Anyone else having this problem, I had to erase PRAM and it fixed the problem and went through the install.
  3. LDaniele macrumors newbie

    Oct 31, 2011
    Northampton, MA USA
    Kernel Panic on installing Mountain Lion

    I'm seeing a kernel panic after installing Mountain Lion on my MacBook Air as well. It cycles three times through the panic, reboot sequence and then gives up.

    I've attached a photo of my screen which has details about the panic. Haven't found a solution yet. Will consider the "erase PRAM" idea.

    Attached Files:

  4. LDaniele macrumors newbie

    Oct 31, 2011
    Northampton, MA USA
  5. TimRMortis macrumors newbie

    Jul 27, 2012
    Fixed kernel panic on iMac ML install

    I too was getting a kernel panic when the ML install restarted my early-2009 iMac. Zapping the parameter RAM fixed that.
  6. grega3, Jul 27, 2012
    Last edited: Jul 28, 2012

    grega3 macrumors newbie

    Jul 27, 2012
    I had the same issue, after much head scratching did the following which solved it:

    Reboot in safe mode (hold Shift)

    Head to /System/Library/Extensions

    Remove 'AppleProfileFamily.kext'

    Reboot and done!
  7. LDaniele macrumors newbie

    Oct 31, 2011
    Northampton, MA USA
    Problem Solved: Deleted AppleProfileFamily.obsolete.kext

    Thanks, grega3. Problem solved! I deleted AppleProfileFamily.obsolete.kext from the "/System/Library/Extensions" folder and the system is behaving normally now.


  8. heutger macrumors newbie

    Oct 11, 2012
    Many thanks @ all

    Erasing PRAM worked out for me (CMD+ALT+P+R at boot time), safe boot (always pressed SHIFT at boot time) didn't helped/worked out.
  9. aldo818 macrumors regular

    Nov 18, 2009
    South of France
    Interval Since Last Panic Report: 406759 sec
    Panics Since Last Report: 2
    Anonymous UUID: 78CF0864-662B-BB20-0ADA-FA9D42915365

    Thu Nov 1 07:52:32 2012
    panic(cpu 0 caller 0xffffff80168b7bd5): Kernel trap at 0xffffff801682da10, type 13=general protection, registers:
    CR0: 0x000000008001003b, CR2: 0xffffff8089296000, CR3: 0x0000000019479000, CR4: 0x0000000000000660
    RAX: 0x0000000000000001, RBX: 0xffffff8021ba3550, RCX: 0x0000000009000000, RDX: 0xffffff8083223078
    RSP: 0xffffff808ea33e50, RBP: 0xffffff808ea33e80, RSI: 0xffffff8083223068, RDI: 0x0000000000000000
    R8: 0xffffff8016ebec60, R9: 0xffffffffffffffff, R10: 0x00000000ffffffff, R11: 0x00000000ffffff80
    R12: 0xffffff8016ebebe8, R13: 0xffffff8021ba0030, R14: 0x01ffff8021ba0000, R15: 0x0000000000000000
    RFL: 0x0000000000010002, RIP: 0xffffff801682da10, CS: 0x0000000000000008, SS: 0x0000000000000000
    Fault CR2: 0xffffff8089296000, Error code: 0x0000000000000000, Fault CPU: 0x0

    Backtrace (CPU 0), Frame : Return Address
    0xffffff808ea33af0 : 0xffffff801681d626
    0xffffff808ea33b60 : 0xffffff80168b7bd5
    0xffffff808ea33d30 : 0xffffff80168ce4ed
    0xffffff808ea33d50 : 0xffffff801682da10
    0xffffff808ea33e80 : 0xffffff8016c2e1e9
    0xffffff808ea33ec0 : 0xffffff8016c2ca47
    0xffffff808ea33f30 : 0xffffff8016c2d3a2
    0xffffff808ea33f70 : 0xffffff8016c31e99
    0xffffff808ea33fb0 : 0xffffff80168b26b7

    BSD process name corresponding to current thread: kernel_task

    Mac OS version:
    Not yet set

    Kernel version:
    Darwin Kernel Version 12.2.0: Sat Aug 25 00:48:52 PDT 2012; root:xnu-2050.18.24~1/RELEASE_X86_64
    Kernel UUID: 69A5853F-375A-3EF4-9247-478FD0247333
    Kernel slide: 0x0000000016600000
    Kernel text base: 0xffffff8016800000
    System model name: MacBookAir3,2 (Mac-942C5DF58193131B)

    System uptime in nanoseconds: 986209572
    last loaded kext at 268302244: 196.0.0 (addr 0xffffff7f9868f000, size 20480)
    loaded kexts:
    com.rim.driver.BlackBerryUSBDriverInt 0.0.74 196.0.0 2.4.1 5.4.0 602.15.22 1.6.1 5.2.5 161.0.0 1.5 1.7 1.6 1.9 1.6 1.6 4.0.39 2 196.0.0 2.2.1 500.15 3.0 1.11 2.2.9 1.6.1 1.8.0 1.1 220 1.0.0d1 7 344 28.21 3.5.0 5.2.5 3.5.1 1.8 3.5.1 5.4.0 1.6 2.7.2 1.4 1.0
    Model: MacBookAir3,2, BootROM MBA31.0061.B07, 2 processors, Intel Core 2 Duo, 2.13 GHz, 4 GB, SMC 1.66f60
    Graphics: NVIDIA GeForce 320M, NVIDIA GeForce 320M, PCI, 256 MB
    Memory Module: BANK 0/DIMM0, 2 GB, DDR3, 1067 MHz, 0x80AD, 0x484D54333235533642465238412D47372020
    Memory Module: BANK 1/DIMM0, 2 GB, DDR3, 1067 MHz, 0x80AD, 0x484D54333235533642465238412D47372020
    AirPort: spairport_wireless_card_type_airport_extreme (0x14E4, 0xD1), Broadcom BCM43xx 1.0 (
    Bluetooth: Version 4.0.9f33 10885, 2 service, 11 devices, 1 incoming serial ports
    Network Service: AirPort, AirPort, en0
    Serial ATA Device: APPLE SSD TS256C, 251 GB
    USB Device: FaceTime Camera (Built-in), apple_vendor_id, 0x850a, 0x24600000 / 2
    USB Device: Internal Memory Card Reader, apple_vendor_id, 0x8403, 0x26100000 / 2
    USB Device: BRCM2070 Hub, 0x0a5c (Broadcom Corp.), 0x4500, 0x04500000 / 3
    USB Device: Bluetooth USB Host Controller, apple_vendor_id, 0x821b, 0x04530000 / 6
    USB Device: Apple Internal Keyboard / Trackpad, apple_vendor_id, 0x0240, 0x04300000 / 2

    That s what i get frequently lately with an macbook air
  10. ECUpirate44 macrumors 603


    Mar 22, 2010
    I'm not seeing this file in my extensions folder :confused:

Share This Page