Become a MacRumors Supporter for $50/year with no ads, ability to filter front page stories, and private forums.


macrumors newbie
Original poster
Nov 25, 2020
Just upgraded to Big Sur after having this issue start while still on Catalina.

Was just browsing in Safari with the touchpad when the entire screen became unresponsive and the system rebooted. Got a kernel panic as follows. After trying numerous times to get macOS recovery to work, it finally got going. Decided to just go ahead and upgrade to Big Sur (had originally wanted to put it off until some updates).

Once Big Sur was updated, I thought maybe the issue would disappear. Well it just wouldn't go away and my MBP is still at the point where it gets to halfway loading the OS after log in and then shuts down. Appreciate any suggestions on this.

panic(cpu 4 caller 0xffffff7fa23b115b): "virtual bool IOAccelLegacyDisplayMachine::display_mode_did_change(uint32_t): Uninitialized NVIDIA GPU driver returns false"@/AppleInternal/BuildRoot/Library/Caches/

Backtrace (CPU 4), Frame : Return Address

0xffffffb0c60fb5a0 : 0xffffff8002abc66d

0xffffffb0c60fb5f0 : 0xffffff8002bff073

0xffffffb0c60fb630 : 0xffffff8002bef6aa

0xffffffb0c60fb680 : 0xffffff8002a61a2f

0xffffffb0c60fb6a0 : 0xffffff8002abbf0d

0xffffffb0c60fb7c0 : 0xffffff8002abc1f8

0xffffffb0c60fb830 : 0xffffff80032bee1a

0xffffffb0c60fb8a0 : 0xffffff7fa23b115b

0xffffffb0c60fb8b0 : 0xffffff7fa235bea6

0xffffffb0c60fb8f0 : 0xffffff7fa23a3a61

0xffffffb0c60fb930 : 0xffffff7fa24d35bc

0xffffffb0c60fba70 : 0xffffff7fa24bdbbd

0xffffffb0c60fbb00 : 0xffffff7fa24c8fd5

0xffffffb0c60fbb20 : 0xffffff7fa24cd6f2

0xffffffb0c60fbba0 : 0xffffff7fa24c39e4

0xffffffb0c60fbc30 : 0xffffff7fa2996eb1

0xffffffb0c60fbc80 : 0xffffff80031e80fb

0xffffffb0c60fbce0 : 0xffffff800324ec82

0xffffffb0c60fbd40 : 0xffffff8002baa52f

0xffffffb0c60fbd90 : 0xffffff8002ac1d77

0xffffffb0c60fbe00 : 0xffffff8002a985d5

0xffffffb0c60fbe60 : 0xffffff8002aafb82

0xffffffb0c60fbef0 : 0xffffff8002bd3823

0xffffffb0c60fbfa0 : 0xffffff8002a62216

Kernel Extensions in backtrace:[BCCD5611-3116-3255-ADBF-C5521D3B39C6]@0xffffff7fa24b3000->0xffffff7fa24e1fff











Process name corresponding to current thread: WindowServer

Mac OS version:


Kernel version:

Darwin Kernel Version 20.1.0: Sat Oct 31 00:07:11 PDT 2020; root:xnu-7195.50.7~2/RELEASE_X86_64

Kernel UUID: 84C6DC45-6B02-335F-9439-5D2A9BC385A4

KernelCache slide: 0x0000000002800000

KernelCache base: 0xffffff8002a00000

Kernel slide: 0x0000000002810000

Kernel text base: 0xffffff8002a10000

__HIB text base: 0xffffff8002900000

System model name: MacBookPro11,3 (Mac-2BD1B31983FE1663)

System shutdown begun: NO

Panic diags file available: YES (0x0)

Hibernation exit count: 0

System uptime in nanoseconds: 20950867161

Last Sleep: absolute base_tsc base_nano

Uptime : 0x00000004e0c4e047

Sleep : 0x0000000000000000 0x0000000000000000 0x0000000000000000

Wake : 0x0000000000000000 0x00000013fc7d7b5d 0x0000000000000000

last started kext at 20208494007: >AGPM 119 (addr 0xffffff7fa0c66000, size 118784)

loaded kexts:

>AGPM 119

>!APlatformEnabler 2.7.0d0

>X86PlatformShim 1.0.0

u/fileutil 20.036.15

u/filesystems.autofs 3.0

>!AGraphicsDevicePolicy 6.1.27

u/AGDCPluginDisplayMetrics 6.1.27

>!AHDAHardwareConfigDriver 283.15

>pmtelemetry 1

>LuaHardwareAccess 1.0.16

|IOUserEthernet 1.0.1

>!AUpstreamUserClient 3.6.8

>usb.!UUserHCI 1

>!AHDA 283.15

|IO!BSerialManager 8.0.1f5

>eficheck 1

u/GeForce 16.0.0

u/Dont_Steal_Mac_OS_X 7.0.0

>!AHV 1

>!A!IHD5000Graphics 16.0.0

>AGDCBacklightControl 6.1.27

>!ALPC 3.1

>!ADiskImages2 1


>ACPI_SMC_PlatformPlugin 1.0.0

>!AMuxControl 6.1.27

>!AThunderboltIP 4.0.3

u/nvidia.NVDAStartup 16.0.0

>!A!ISlowAdaptiveClocking 4.0.0

>!A!IFramebufferAzul 16.0.0

>!ABacklight 180.3

>!AMCCSControl 1.14

>!ACameraInterface 7.6.0

>!AFIVRDriver 4.1.0

|IO!BUSBDFU 8.0.1f5

|SCSITaskUserClient 436.40.6

>!UCardReader 511.40.9

>!UTCKeyEventDriver 256

>!UTCKeyboard 256

>!UTCButtons 256

>!AFileSystemDriver 3.0.1

u/filesystems.tmpfs 1

u/filesystems.hfs.kext 556.41.1

u/BootCache 40

@!AFSCompression.!AFSCompressionTypeZlib 1.0.0

@!AFSCompression.!AFSCompressionTypeDataless 1.0.0d1

u/filesystems.apfs 1677.50.1

>!AAHCIPort 346

>AirPort.BrcmNIC 1400.1.1

u/private.KextAudit 1.0

>!ASmartBatteryManager 161.0.0

>!ARTC 2.0

>!AACPIButtons 6.1

>!AHPET 1.8



>!AAPIC 1.7

@!ASystemPolicy 2.0.0

u/nke.applicationfirewall 310

|IOKitRegistryCompatibility 1

|EndpointSecurity 1

u/kext.triggers 1.0

>DspFuncLib 283.15

u/kext.OSvKernDSPLib 529

|IOSerial!F 11

|IOAVB!F 900.12

u/nvidia.driver.NVDAGK100Hal 16.0.0

u/nvidia.driver.NVDAResman 16.0.0

>!ASMBusPCI 1.0.14d1

>IOPlatformPluginLegacy 1.0.0

>!AGraphicsControl 6.1.27

u/plugin.IOgPTPPlugin 900.11

|IOEthernetAVB!C 1.1.0

>X86PlatformPlugin 1.0.0

>IOPlatformPlugin!F 6.0.0d8

>!AThunderboltEDMSink 5.0.3

>!AThunderboltDPOutAdapter 8.1.4

@!AGPUWrangler 6.1.27

|IOSlowAdaptiveClocking!F 1.0.0

|IOAccelerator!F2 439.35.4

@!AGraphicsDeviceControl 6.1.27

>!ABacklightExpert 1.1.0

|IONDRVSupport 585

>!ASMBus!C 1.0.18d1

>!AHDA!C 283.15

|IOHDA!F 283.15

|IOGraphics!F 585

|IOAudio!F 300.6.1

u/vecLib.kext 1.2.0

|Broadcom!BHost!CUSBTransport 8.0.1f5

|IO!BHost!CUSBTransport 8.0.1f5

|IO!BHost!CTransport 8.0.1f5

>usb.!UHub 1.2

>!UMultitouch 264

>usb.IOUSBHostHIDDevice 1.2

>usb.cdc 5.0.0

>usb.networking 5.0.0

>usb.!UHostCompositeDevice 1.2

>!AThunderboltDPInAdapter 8.1.4

>!AThunderboltDPAdapter!F 8.1.4

>!AThunderboltPCIDownAdapter 4.1.1

>!ABSDKextStarter 3

|IOSurface 289.3

u/filesystems.hfs.encodings.kext 1

>!AXsanScheme 3

|IOAHCIBlock!S 332


>!AThunderboltNHI 7.2.8

|IOThunderbolt!F 9.3.2

>usb.!UHostPacketFilter 1.0

|IOUSB!F 900.4.2

|IO80211!F 1200.12.2b1

|IOSkywalk!F 1

>mDNSOffloadUserClient 1.0.1b8

>corecapture 1.0.4

>!A!ILpssGspi 3.0.60

>usb.!UXHCIPCI 1.2

>usb.!UXHCI 1.2


>!AEFIRuntime 2.1

|IOSMBus!F 1.1

|IOHID!F 2.0.0

$!AImage4 3.0.0

|IOTimeSync!F 900.11

|IONetworking!F 3.4

>DiskImages 493.0.0

|IO!B!F 8.0.1f5

|IOReport!F 47

|IO!BPacketLogger 8.0.1f5

$quarantine 4

$sandbox 300.0

u/kext.!AMatch 1.0.0d1

|CoreAnalytics!F 1

>!ASSE 1.0

>!AKeyStore 2

>!UTDM 511.40.9

|IOUSBMass!SDriver 184.40.6

|IOSCSIBlockCommandsDevice 436.40.6

|IO!S!F 2.1

|IOSCSIArchitectureModel!F 436.40.6

>!AMobileFileIntegrity 1.0.5

u/kext.CoreTrust 1

>!AFDEKeyStore 28.30

>!AEffaceable!S 1.0

>!ACredentialManager 1.0

>KernelRelayHost 1

|IOUSBHost!F 1.2

>!UHostMergeProperties 1.2

>usb.!UCommon 1.0

>!ABusPower!C 1.0

>!ASEPManager 1.0.1

>IOSlaveProcessor 1

>!AACPIPlatform 6.1

>!ASMC 3.1.9

|IOPCI!F 2.9


>watchdog 1

u/kec.pthread 1

u/kec.corecrypto 1.0

u/kec.Libm 1


macrumors newbie
Jan 10, 2014
I had a similar issue on a late 2013 macbook 15" (A1398) and while I can get to a login screen it never boots into macos successfully - not into recovery, internet recovery, not even onto a usb drive linux iso. SSD/RAM is fine, only booted once into recovery mode can't get back - everything hangs. Issue first occurred while using laptop in a car on battery. I'll go over the observed issues, what I've tried, and what it possibly could be:

#What it possibly could be:

One possibility is it might be some of the voltage regulators failing, a video by TCRS Circuit delves into this:
. Not entirely convinced yet this is the issue though.

#Observed issues / What I've tried:

- kernel panic excerpt was:
panic(cpu 0 caller 0xffffff7fa9f70deb): "virtual bool IOAccelLegacyDisplayMachine::display_mode_did_change(uint32_t): Uninitialized NVIDIA GPU driver returns false"@/System/Volumes/Data/SWE/macOS/BuildRoots/2288acc43c/Library/Caches/

Kernel Extensions in backtrace:[CC341A35-707F-3C8B-8EFD-925F742166A1]@0xffffff7faa09b000->0xffffff7faa0c9fff

- Trying to boot into macos
Can get to the login screen, but after entering password and continuing boot load-up it hangs for a few seconds, goes to the error screen saying the machine will reboot in a few seconds and issue repeats

- Trying to boot into recovery
Starts trying to boot recovery but hangs - generally end up holding hte power button for several seconds to make it go hard off.

- Trying to boot into internet recovery
Starts off okay downloading the image, but similarly hangs on boot.

- Running Test Mode
this works, no issues found.

- running memtest86
booted over usb, this works, no issues with ram found

- booting into linux
doesn't seem to work, seemingly hangs but was using a beta iso of elementary os.
Last edited:


macrumors 6502a
Apr 3, 2015
Mexico City
You are trying to install an old version of macOS Big Sur 11.0.1 (20B50)
Download from the Apple Store the latest version and create a bootable USB stick
macOS Big Sur 11.4 (20F71) - May 24, 2021

Hope it helps


macrumors newbie
Jul 9, 2021
I am currently having exactly the same issue with the same error message.

panic(cpu 4 caller 0xffffff7f9d604deb): "virtual bool IOAccelLegacyDisplayMachine::display_mode_did_change(uint32_t): Uninitialized NVIDIA GPU driver returns false"@/System/Volumes/Data/SWE/macOS/BuildRoots/e90674e518/Library/Caches/

If anybody managed to solve it or knew a solution please tell me.


macrumors newbie
Jul 14, 2021
+1, I too have the same issue on a MacBook Pro Late 2013, macOS Big Sur 11.4.

panic(cpu 2 caller 0xffffff7fa4204deb): "virtual bool IOAccelLegacyDisplayMachine::display_mode_did_change(uint32_t): Uninitialized NVIDIA GPU driver returns false"@/System/Volumes/Data/SWE/macOS/BuildRoots/e90674e518/Library/Caches/

This happens every time I attempt to wake the computer from sleep which has continued for more than 3 hours.

I have attempted to disable all deep sleeps that might trigger this to no avail.

sudo pmset -a standby 0; sudo pmset -a autopoweroff 0; sudo pmset -a hibernatemode 0; sudo pmset -a gpuswitch 0;

My next step will be to disable the discrete GPU or just install Linux and leave macOS behind given Apple now see this machine as legacy. Does any one have any ideas before I do?


macrumors newbie
Jul 10, 2021
This happens almost every day booting my iMac 4K 2017.
Sometimes I see the panic streen 5 times in a row until it can boot, sometimes boot works on the first try.
Used to happen daily, then after I switched to Catalina I was safe for a full year, and out od nowhere now it's my daily routine to panic-boot several times every morning.

I notice that when boot works, the apple logo blinks once or twice, the cursor appears on the top left corner, and then I know the progress bar will reach the end.
Looks like the panic comes when it's time to blink. Something happens at that moment that will crash or continue.
That's the only clue I have.

Could say it's when it switches GPU, but as far as I know, theres is just the AMD in it.



macrumors newbie
Nov 27, 2021
I am currently having exactly the same issue with the same error message.

panic(cpu 4 caller 0xffffff7f9d604deb): "virtual bool IOAccelLegacyDisplayMachine::display_mode_did_change(uint32_t): Uninitialized NVIDIA GPU driver returns false"@/System/Volumes/Data/SWE/macOS/BuildRoots/e90674e518/Library/Caches/

If anybody managed to solve it or knew a solution please tell me.

I have the exact same panic report as yours. I just recently updated to Big Sur and fingers crossed at all the moment to see whats gonna happen next time i boot. Let me know if you found a solution. I have posted about my similar situation to the reply to another post.

I had the same issue with the exact same panic report. I recently noticed that my Graphic card details is not showing up on 'About this mac' modal. It only shows detail about my Intel graphics card along with other system details. Also, my fan screams loud all day long and its annoying.

View attachment 1919098 View attachment 1919102

I should have tried the solution mentioned by @Nhat99 above but sadly i updated from Mojave to BigSur latest one just yesterday ?‍♂️

Is there anything i can down without tearing out the PC?
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.