Kernel panic problem, Macbook Air 2012

Discussion in 'MacBook Air' started by damiengibson, May 13, 2013.

  1. damiengibson, May 13, 2013
    Last edited: May 13, 2013

    damiengibson macrumors newbie

    May 13, 2013
    Good evening all, I have tried to do a few searches but not finding a solution that I quite understand, so hopefully some here can help me out.

    When booting up my Macbook Air 2012 I keep getting the grey start up screen with a load of text referring to a panic of some sort (i have attached an image of what I am getting). This only lasts for around 5 seconds and it then switches to another screen (same grey background with apple logo) with text saying that my computer shut down suddenly and to press any key to carry on etc and after doing so, it goes back to the original screen and simply keeps looping between the two.

    I have tried booted up using the Comd + R combination and launched Disk Utility and when trying to verify the HD, many lines of text in read appear stating 'Missing thread record (id = xxxxxxxx) and I am then told the HD needs repairing. After clicking on Repair Disk, about 2 minutes into it, I am told that Disk Utility can not repair the disk and that it needs reformatting. I then try to reinstall OS X but again, told I can't use the current disk.

    Is my only option to reformat the disk? If so, is there anyway I can access the data currently on there first? It's mostly backed up, but could do with a quick check, but no worries if not. Restoring from TM backup is not an option right now.

    Many thanks in advance for any advice offered.


  2. jdblas69 macrumors regular

    Aug 15, 2012
    This link shows you how to back up to an external source using disk utility. Also gives instructions how to restore via disk utility. I had a problem where I had to reformat. I did not use the restore instructions as I did have a TM backup but it was not current, so I at least had the disk utility back up to look through for any documents/files that may not have been on the TM backup.
  3. damiengibson thread starter macrumors newbie

    May 13, 2013
    Thanks for your reply, I had a try but I was told I am unable to create the backup due to an input/output error. I guess the HD is that corrupt! Funny, everything was working perfectly yesterday but now all this. I guess a complete reformat is in store, but would this still reinstall Mac OS X with my licence?
  4. old-wiz macrumors G3

    Mar 26, 2008
    West Suburban Boston Ma
    You can reinstall with no problems relative to the license.

    You might try booting to safe mode and see how that goes.

Share This Page