Kernel panic - what do you make of this log?

Discussion in 'macOS' started by The General, Feb 9, 2007.

  1. The General macrumors 601

    Jul 7, 2006
    Okay so I was using Stellarium, and I closed the lid on my MBP with it running, walked back to my room, opened the lid and plugged in my mouse as it was waking up, and it worked for like 3 seconds and then I got the kernel panic. Here's the log, what can you make of this?

    Fri Feb 9 18:14:59 2007
    panic(cpu 0 caller 0x001A3135): Unresolved kernel trap (CPU 0, Type 14=page fault), registers:
    CR0: 0x8001003b, CR2: 0x25523cfc, CR3: 0x00f2c000, CR4: 0x000006e0
    EAX: 0x0730d600, EBX: 0x0730d600, ECX: 0x00000014, EDX: 0x004af038
    CR2: 0x25523cfc, EBP: 0x253fbf78, ESI: 0x25523cfc, EDI: 0x0057f6ce
    EFL: 0x00010206, EIP: 0x0057f6f3, CS: 0x00000008, DS: 0x03ab0010

    Backtrace, Format - Frame : Return Address (4 potential args on stack)
    0x253fbd68 : 0x128d08 (0x3c9afc 0x253fbd8c 0x131de5 0x0)
    0x253fbda8 : 0x1a3135 (0x3cf7b0 0x0 0xe 0x3cefe0)
    0x253fbeb8 : 0x19a904 (0x253fbed0 0x297 0x253fbf58 0x2b8185)
    0x253fbf78 : 0x13d7d9 (0x730d600 0x25523cfc 0x19d23a 0x3be5320)
    0x253fbfc8 : 0x19a77c (0x0 0x0 0x19d0b5 0x3be52dc) Backtrace terminated-invalid frame pointer 0x0

    Kernel version:
    Darwin Kernel Version 8.8.2: Thu Sep 28 20:43:26 PDT 2006; root:xnu-792.14.14.obj~1/RELEASE_I386


    Thanks. :D
  2. savar macrumors 68000


    Jun 6, 2003
    District of Columbia
    Is that the entire log? In that form, it's pretty useless. What I can tell is that your stack (where the backtrace comes from) is corrupted -- that's why you get an invalid frame pointer. Stack corruption is usually due to a buffer overflow -- which shouldn't happen in Cocoa. So it could be stellarium. If it happened just after waking up with a mouse plugged in it might also be a driver problem.

    Is this a recurring problem?
  3. The General thread starter macrumors 601

    Jul 7, 2006
    No, I've tried many times to reproduce the kernel panic to no avail. That was in /Library/Logs/panic.log, that was the whole file. I dunno, if it happens again I guess I'll post back.

Share This Page