Kernel Panic

Discussion in 'MacBook' started by Ajfirestarter, Feb 21, 2011.

  1. Ajfirestarter macrumors newbie

    Joined:
    Feb 21, 2011
    Location:
    Carlisle, UK
    #1
    My flat mate just bought a new MacBook Pro and her mum is having her old MacBook.

    She tried re-installing Mac OS X from Install Disc 1, followed the on disc installation app. and restarted.
    Her problem was that after restarting, the disc would eject and display a panic message, the top line being;
    panic(cpu 0 caller 0x00431DA3): "Unable to find driver for this platform: \"ACPI\".\n"@/SourceCache/xnu/xnu-1228.4.20/iokit/kernel/IOPlatformExpert.cpp:1407

    So I tried it a few times, dis-abled extensions during boot up, attempted booting from disc via key command (C) and safe boot up.

    After these I attempted starting the MacBook in FireWire target mode, erasing the hard drive, opening the installation app. via my MacBook Pro but to no avail.
    The disc wouldn't load after restart, just a plain white screen on which eventually using the option key I was able to boot from Macintosh HD.


    Current situation, MacBook has no OS, trying to use the Disc to reinstall is proving to be a no go because of the above and any help would be well appreciated.
     
  2. Eddyisgreat macrumors 601

    Joined:
    Oct 24, 2007
    #2
    If you are trying to use the install disk 1 from the Macbook Pro on an older Macbook then, well, that's your issue.

    You can't use retail disks older than model you're trying to install on, nor can you use grey installation disks from other models.
     
  3. Ajfirestarter thread starter macrumors newbie

    Joined:
    Feb 21, 2011
    Location:
    Carlisle, UK
    #3
    Initially I was using the install disc which came with the MacBook for installing leopard but it would just, and still does, display the message mentioned above.

    Do you know whether using another MacBook of the same age would work then? Installing leopard onto an external HD?
     
  4. BrianBaughn macrumors 601

    BrianBaughn

    Joined:
    Feb 13, 2011
    Location:
    Baltimore, Maryland
    #4
    Yes. Try installing Leopard from the MacBook's original install disk onto an external drive. Obviously, if you can get that running with no errors, then you've pinpointed the internal drive as the problem.

    It wouldn't surprise me. I have had many calls recently about HDs in MacBooks.
     
  5. Ajfirestarter thread starter macrumors newbie

    Joined:
    Feb 21, 2011
    Location:
    Carlisle, UK
    #5
    If only that had worked.

    Restarting via the install app. on my computer, blank white screen. No install options and no start up manager.

    Going to try using Disc Warrior to either install leopard or graft a time machine back up onto it.


    If not, well, good job it's not the main machine anymore
     

Share This Page