Kernel panics even after going through support pages

Discussion in 'Mac OS X 10.3 (Panther) Discussion' started by ricebag, Dec 11, 2004.

  1. ricebag macrumors member

    Aug 31, 2004
    Okay, so my girlfriend was watching some avi files off of a CD on my powerbook 1.33 (running 10.3.6), on VLC. She watched 6 fine, and then she clicked on number 7 and got the spinning wheel. I wasn't around so she got my roommate, the computer guy (ahem... the WINDOWS computer guy) who tried various key combinations until the computer restarted. Then they got me.

    When I got back, I was presented with white text on a black screen saying something about BSD/Darwin login and asking for my username and password. I was stupid and thought a restart would get me back to normal.

    Upon restart, I got the good old kernel panic (You need to restart your computer....) message. Since then, I've exhausted Apple's support page, zapping the PRAM, resetting the PMU (both ineffective), trying to start up in single user mode (gives me the white text on black screen but then says panic: we are hanging here... and stops), starting up from an OS X cd (hangs on gray apple screen), and starting up in target disk mode with my old computer (seems to work fine, but the hard drive doesn't show up on the other computer, only a CD I had in at the time). I had removed my 3rd party ram when I did this stuff, and haven't done anything new to my computer lately.

    Any help?
  2. ricebag thread starter macrumors member

    Aug 31, 2004

    One update, in case it actually makes anyone respond. I tried messing with the Open Firmware: reset-nvram worked fine, but reset-all gave me a "bad default" message.

    Can someone please at least tell me if this sounds like an impossible problem to solve, if nothing else? It's so much worse to see that no one even posted.

  3. Sun Baked macrumors G5

    Sun Baked

    May 19, 2002
    can you boot into single user mode (command-s)?

    Unless the OS is completely fragged, you should be able to boot into there and follow the directions on the screen for fsck... then type 'reboot' to restart.

    Almost sounds like one of the key unix files got messed up/trashed, but the drive could really be sick.

    If the OS is messed up enough you cannot boot to single user, use the CD -- you should be able to see the hard drive with Disk Utilities and try running Disk First Aid.

    However if you cannot see the drive with disk utilities, it may be dead.

    Can't remember is System Profiler works on the CD or target disk mode -- but you may also want to check to see if the drive is being seen by the OS at all under Profiler.
  4. Mechcozmo macrumors 603


    Jul 17, 2004
    If you can get into single-user mode, run (w/o the quotes) "fsck -yf"

    Otherwise... you have a 1 year warranty... it sounds pretty fragged. And I'm betting its because of the Windows guy... ;)

    I can't think of anything that could have happened to mess it up that badly, though.
  5. ricebag thread starter macrumors member

    Aug 31, 2004

    Sadly, when I boot into single user mode, it gives me a "panic: we are hanging here..." message. Booting from a working install disk hangs on the gray apple. I also can't think of what could have happened... it's so weird!

    But thanks for your help!
  6. ricebag thread starter macrumors member

    Aug 31, 2004
    More update

    So I finally managed to boot from an install disk, and got to the installer, but the installer can't find any volumes to install on. Likewise, disk utility sees the disk (Toshiba whatever) but the volume (Macintosh HD) is grayed out and has the status "not mounted." When I press mount, nothing happens.
    Is this bad?
  7. Makosuke macrumors 603

    Aug 15, 2001
    The Cool Part of CA, USA
    Yes, that's probably bad. If there's no data on the drive you need to get off, you can try using Disk Utility to reformat it, then try a fresh install. If that fails, at the very least your hard drive is toast, and needs to be replaced. Get to it while its still under warranty.

    I've never seen this, and it makes me wonder if there isn't something mroe severe wrong than just a dying hard drive--if Open Firmware is giving you errors, it might well be a dying motherboard (heck, the drive could even be ok, though you'd have to transfer it to another computer to find out, which isn't easy).

    Have you tried running the Hardware Test CD? That can sometimes identify problems, and if it does you'll certainly know it's time for a warranty repair.
  8. musicpyrite macrumors 68000


    Jan 6, 2004
    Cape Cod
    I had a similar thing happen to me a few months ago... p-ram, nv-ram, etc. did nothing. unplugging the mouse, keyboard, usb/firefire stuff, did nothing. I held the Shift key at start up and it worked. weird
  9. mkap macrumors newbie

    Dec 10, 2004
    I feel yer pain

    I feel your pain, brother.

    I have had some serious kernel panics lately, after doing the 10.3.7 upgrade to my PB 15" 1.25 mghz machine. After reinstalling the system, everything was fine, but after updating again to 10.3.7, I got another kernel panic. So I did another reinstall, and only updated to 10.3.6, and everything was fine for awhile, but then, WHAM, another kernel panic. This time, I did the "safe boot" startup, where you hold the shift key (as suggested in the previous post) takes a long time, because it does a few diagnostics and corrects some possible problems.......and it seems to have fixed my problem. Give it a try if you haven't already.

    Although it sounds like you have a more serious disk error going on- try to repair the disk using Disk First Aid, or else maybe an application like Drive 10, "Tech tool", or Disk Warrior. If these don't work, you may need to reformat it.


Share This Page