Kernel panics occurring with RocketRAID 3522 controller card

Discussion in 'Mac Pro' started by JimmyCrackCorn, Aug 27, 2010.

  1. JimmyCrackCorn macrumors newbie

    Joined:
    Aug 27, 2010
    #1
    Hi, I'm trying to fix an issue on a Quad-core MacPro4,1. It's being used as an edit station in a production company, to satisfy the storage needs for this, it has a RAID controller card fitted (Rocekt RAID 3522) connected by two mini SAS connectors to a ProAVIO edit box constituting a 3TB RAID configuration.

    The kernel panics are intermittent and impossible to predict but do seem to occur during actual editing rather than situations like now where it's light usage of the machine like web browsing. The panics have been happening for as long as we've had the machine which is going on for 2 months now. The problem is narrowed down to the high point card as it is the only configuration difference to all the other machines in the studio and because swapping the controller into another identically configured (except for the high point card), and working macpro reproduces the problem which then disappears when the card is swapped back.

    We've spoken to apple care about this who've run diagnostic tests to no avail. Solutions tried so far have involved removing the card which does stop the panics but obviously leaves us without a vital component, installing new drivers downloaded from manufacturer's website, and most recently deleting default snow leopard drivers, and downloading the newest available manufacturers drivers and updating once again. None of these solutions have worked and it's looking like we're going to have to simply write off this product as simply faulty and get a new RAID card. As a side note the manufacturer has discontinued this particular model.

    Does anyone know anything else that can be done to try to solve this issue?
     
  2. AZREOSpecialist macrumors 68020

    AZREOSpecialist

    Joined:
    Mar 15, 2009
    #2
    Unfortunately all I can offer is my experience with High Point products. Their RocketRAID products are hit and miss with the Mac, especially since the introduction of Snow Leopard. High Point is slow to release updates, and a product that supposedly worked and was supported one day is discontinued the next.

    I also have a RocketRAID, I think it's the 4320. I had major issues after upgrading to Snow Leopard - the RAID would not wake from sleep. After several SL updates from Apple, however, the issue resolved itself. High Point support was absolutely useless. My suggestion would be to back up your data and obtain a better supported RAID card. I'm sure people can chime in with suggestions.
     
  3. JimmyCrackCorn thread starter macrumors newbie

    Joined:
    Aug 27, 2010
    #3
    Help fixing a fix

    Okay so the card probably is, unfortunately a write-off. There's now another minor problem. In trying to fix the card I tried deleting the snow leopard RAID drivers as per a suggestion on a forum with somebody experiencing a similar issue. As I said, it didn't work, the symptons remained the same only now we don't have the drivers which at present we don't need but perhaps might need for using disk utility to create RAID arrays. So I've tried simply copying the .kext files I removed from the extensions folder back in to that folder but when I do so it causes an error message to pop up intermittently saying that the drivers had been improperly installed.

    How do I re-install them? I thought since they were part of the OS to begin with they would already be installed, I only moved the files, but moving the back seems to miss out something necessary for them to work.
     

Share This Page