Kernel panics on Sleep mode

Discussion in 'OS X Mountain Lion (10.8)' started by Edduvall, Jul 26, 2012.

  1. Edduvall macrumors newbie

    Joined:
    Aug 28, 2011
    #1
    After upgrading to ML from Lion this morning, my MBP 13 (early 2011) gets kernel panics when it is put into Sleep mode. It happens when I close the lid or when I manually select the Sleep command. This did not happen in Lion.

    Anyone else has this problem? I've sent the crash report to Apple. Hope they have a fix. Not sure if I should revert to a previous state using Time Machine in the meantime...
     
  2. Edduvall thread starter macrumors newbie

    Joined:
    Aug 28, 2011
    #2
    Seems to be Air Display

    I think I've figured it out. I uninstalled Air Display (from Avatron) and the problem is now gone.

    Hope there's an update soon!
     
  3. bobseverns macrumors newbie

    Joined:
    Nov 21, 2011
    #3
    more specifically..could be related to bluetooth

    I verified with Avatron that they are in fact aware of an issue with kernel panics when putting the mac to sleep under Mountain Lion. They also mentioned that they believe it could possibly be related to using a bluetooth mouse. They asked me specifically if I put the mouse to sleep before sleeping the computer (which I do not believe I did when I received the kernel panic).

    Do you use a Bluetooth mouse?
     
  4. heyloo macrumors 6502

    Joined:
    Nov 2, 2006
    Location:
    NY
    #4
    Thanks you guys for the information. My MacBook Air's been going through the endless cycle of kernel panic for the past couple days and have been looking for a solution.

    Going to uninstall Air Display until they release an update for the time being.

    That said, is this 'UPDATE' by Avatron telling us to turn the Bluetooth Wake option OFF or ON? Confused by the
     
  5. Edduvall thread starter macrumors newbie

    Joined:
    Aug 28, 2011
    #5
    Heyloo,

    Avatron is asking you to keep the setting ON.

    I've reinstalled Air Display on my MBP. The setting for Allow Bluetooth Devices To Wake Your Computer is now ON, and I also activate Caffeine to keep the laptop from going to Sleep mode when I'm at my desk using the Bluetooth keyboard and Magic Trackpad.

    I simply turn Bluetooth off on my MBP when I leave the office for meetings or home. No more kernel panics :)

    Excerpt from an email from Avatron customer support:
    "As far as we can tell at this point this looks to be a bug within Mountain Lion and not something we can fix. We'll be contacting Apple to get their assistance moving forward."
     
  6. heyloo macrumors 6502

    Joined:
    Nov 2, 2006
    Location:
    NY
    #6
    Thanks @Edduvall!

    Great tip. I'll keep that in mind about turning bluetooth off.

    I've removed the app for now as I haven't been using it too much lately but I'll be sure to keep that in mind when I start using it again! ;)
     

Share This Page