Kernel Task taking up 101% of my CPU???

Discussion in 'macOS' started by Kernel Custard, Mar 10, 2011.

  1. Kernel Custard macrumors newbie

    Joined:
    Mar 10, 2011
    #1
    Greetings, I left the following two posts his over on the MacbookPro forum (as thats the hardware im using) but seeing as this problem is OS X based im sure its relevent to all Mac Platorms.

    All and any Advice/Suggestions/Acknowledgment will be appreciated!

    Thanks


    :apple::apple::apple::apple::apple::apple::apple::apple::apple::apple:

    First Post -

    Hi

    Owner of a new MBP 13". Mad the unfortunate mistake of accidently quiting LAUNCHD. My system crashed so I had to reboot. What happens next now happens every time I turn it own.


    1) - No Chime at power up
    2) - Grey Apple screen takes 10 minutes to load
    3) - Login takes 5 minutes to recognise Keyboard (Trackpad OK)
    4) - After entering password and accessing account, Activity Monitor shows Kernal Task is taking up 101% of CPU!!!

    Obviously my system is running slow and it needs fixing. I tried a re-install of SL with hardware disc. That took hours and stopped with 20 mins left. Ran it again over night and it stopped at 1 minute left. Decided to reboot and Lo and Behold I was asked to create a new user account. BUT the four problems above were still evident for the new User account.

    Im about to try the NVRAM and SMC resets now bt I doubt they will work. How do you rest the P.O.S.T? Is it normal for LAUNCHD to cause this chaos or should I be thinking about something else I did on the same day I crashed the system?

    All suggestions will be appreciated guys!


    :apple::apple::apple::apple::apple::apple::apple::apple::apple::apple:

    Seond Post -



    (Excuse the spelling mistakes)

    Luckily I've got my old trusty 15" MBP to search online for help

    The SMC did absolutely nothing noticable.... except login to an "unknown account" with the default star wallpaper and freeze.

    I only have two accounts on my MBP, my Main account and the second account I created today after reinstalling SL. Both require passowrds, so im not sure "which" account my MBP logged into after the SMC reset

    Eitherway, pressing the SMC combo and then powering up took me to a delayed Grey Apple Screen. The next screen shown was the star wallpaper Desktop, where the Cursor froze in the top left hand corner. I wasn't shown the login Screen between the Grey Apple Screen and the Desktop

    Pressing the SMC combo clearly did something, so I waited ages with the frozen Desktop (20 mins) just incase the system was simply being slow, but nothing happened. The keyboard and trackpard were unresponsive so I eventually rebooted the system.

    THIS time I pressed nothing, and after the delayed Apple Screen it took me to the Login Screen. After the delay waiting to enter my Login details, Activity Monitor revealed that "Kernel Task" was still taking up 101% CPU. So SMC changed nothing...

    Im about to try RVRAM....


    (UPDATE: RVRAM DID NOTHING EITHER... ANY SUGGESTIONS???)
     
  2. mchcopl macrumors newbie

    Joined:
    Feb 13, 2010
    #2
    Well this isn't a good sign! Normally when I ask a question, 3 minutes later there's a response. So considering it has been hours and nothing, well that just isn't good!


    Oh yeah, 1st.
     
  3. Kernel Custard thread starter macrumors newbie

    Joined:
    Mar 10, 2011
    #3
    Victory!!! Victory is miiiiiiiiine !!! Bwaaahahaha !!!

    FIXED THE PROBLEM (NO THANKS 2U NO GOOD MOFOS ON HERE :D)


    When I searched online for an answer I found nothing relevent to Kernel Task taking up so much of my CPU.

    But considering all I did was accidently click LaunchD while the different processes were jumping around in Activity Monitor, I would've thought this type was crash was common? I can't be the only one? ;)


    Anyway, for the benefit of those who found THIS page in their search for help, all I did to solve MY problem was back up my files, boot from the DVD that came with my hardware, COMPLETELY ERASE/FORMAT the 'hard drive' in the Disc Utilities left hand window (HD meaning the physical HD inc all its "volumes"), then quit Disc Utilities and clicked "Install OS X".

    Once installed I restarted, did the PRAM reset, and heard the Chime :cool:
    My UMBP 13 2010 is back online B****ES!


    :apple::apple::apple::apple::apple:


    For everybody with big problems on their Mac you have my sympathies.
    Here's some advice - make sure you Run SMC first, if nothing, Run PRAM, if nothing, try a standard installation (keeping your User Account) and if that doesn't work either go NUCLEAR...

    Back up your data, Boot from the DVD, Erase/Format your HD and do a brand new fresh out the box Install of Snow Leopard. Worked for me. Good Luck!
     

Share This Page