Kernel_Task Eating Resources and Slowing Everything Down

Discussion in 'OS X Yosemite (10.10)' started by macUser2007, May 1, 2015.

  1. macUser2007, May 1, 2015
    Last edited: May 1, 2015

    macUser2007 macrumors 65832

    Joined:
    May 30, 2007
    #1
    I have periodic bouts of kernel_task going crazy for no apparent reason and ramping up to 500-600%, today it even hit 1800% for a bit.

    The computer slows down to a crawl in these cases and it's unusable.Sometimes it will do it even after a reboot, until left alone for a while, presumably finishing whatever it was doing.

    This is on a new Mac Book Air with 8gb RAM.

    I've had the same issue on a 2011 Mac Book Pro with 16gb of RAM too and it kept getting so hot that it fried the graphics card (which is bad on those Mac Book Pros, anyway).

    Anyone with a reasonable resolution?

    I see that people go as far as disabling kernel_task for their Mac model, but this seems likely to cause its own issues.

    As a side rant, I am noticing a host of issues with the last two Mac OS versions. OS10 also has a problem with Mail bleeding resources at times, requiring a restart of the app. I am sort of getting fed up.
     
  2. LCD macrumors member

    Joined:
    Dec 28, 2012
    Location:
    USA
    #2
    I started with 10.4.5 in March 06. 10.3.3.1 is by far the worst ever. Kernel panics, GPU hangs, sleep wake failures. I'm fed up too.
     
  3. macUser2007 thread starter macrumors 65832

    Joined:
    May 30, 2007
    #3
    Yep, it's getting annoying and I see this on more than one Mac, most of these pretty new machines.

    Has anyone figured out what is causing this resource-hogging by kernel_task?
     
  4. nontroppo macrumors 6502

    nontroppo

    Joined:
    Mar 11, 2009
    #4
    Not here, do you have an 3rd party kernel extensions installed? Does EtreCheck show up any problems?

    http://www.etresoft.com/etrecheck

    Um, I don't think OS X would boot if you disabled kernel_task!?!? :eek:
     

Share This Page