kernel_task

Discussion in 'OS X Mavericks (10.9)' started by daveuk82, Nov 16, 2013.

  1. daveuk82 macrumors newbie

    daveuk82

    Joined:
    Jan 13, 2012
    Location:
    Birmingham
    #1
    since installing mavericks my kernel_task usage on the cpu is massive its making my mbp run hot and slow is there a way to fixthis please
     
  2. satcomer macrumors 603

    satcomer

    Joined:
    Feb 19, 2008
    Location:
    The Finger Lakes Region
    #2
    What kernel task? Did you try to quit that task in /Applications/Utilities/Activity Monitor yet?
     
  3. daveuk82 thread starter macrumors newbie

    daveuk82

    Joined:
    Jan 13, 2012
    Location:
    Birmingham
    #3
    Kernel_task

    It is just called kernel_task and I attempted to quit it but the option was greyed out as it seems to be a essential things the os needs after some further digging it appears that this is a bug in mavericks and I've got 3 options 1 try and fix it. 2 wait for apple to fix it 3. Revert back to mountain lion
     
  4. Mr. Retrofire macrumors 601

    Mr. Retrofire

    Joined:
    Mar 2, 2010
    Location:
    www.emiliana.cl/en
    #4
    If you quit the kernel_task, you remove the OS from the RAM. Good luck with that! ;-)
     
  5. satcomer macrumors 603

    satcomer

    Joined:
    Feb 19, 2008
    Location:
    The Finger Lakes Region
    #5
    No. Some third party programs make kernel tasks that might not be supported in 10.9. Say like a external port device like an Express card for the older Mac Pro or older Mac Book Express Card drivers.
     
  6. Shrink macrumors G3

    Shrink

    Joined:
    Feb 26, 2011
    Location:
    New England, USA
    #6
    How massive is massive?
     
  7. bobr1952 macrumors 68020

    bobr1952

    Joined:
    Jan 21, 2008
    Location:
    Melbourne, FL
    #7
    Since it is PID 0, there is only one task--the first one. Do you mean some programs require assistance from kernel_task? As in creating threads? So I suppose that could cause a spike in CPU usage if the program is not compatible.
     
  8. Vianney, Dec 8, 2013
    Last edited: Dec 9, 2013

    Vianney macrumors newbie

    Joined:
    Dec 8, 2013
    #8
    the solution!

    Hello world,

    Apple told me the solution: you must delete your account's cache files. this solutions works perfectecly on my macbook pro 13 mid-2012.

    in the finder : go to your account folder, find the "Preferences" folder and empty it.

    After go to Macintosh HD/Library/Preferences/"System Configuration" and empty it.

    Clean the bean and reboot your Mac

    You will loose all your account preferences, your different desktops, JAVA and X11 (Maybe) but your mac will go faster!!!!

    Sorry for my English, I'm French. :)
     

Share This Page