<key> and iMessage spam

Discussion in 'OS X Mavericks (10.9)' started by BrownManUPS, Sep 18, 2014.

  1. BrownManUPS macrumors 6502a

    BrownManUPS

    Joined:
    Jul 30, 2007
    Location:
    California
    #1
    This has been a problem for me for about a year, and started when I had to reinstall Mac OS X from a time machine backup.

    I am trying to use iCloud and iMessage, and each time I sign in, my keychain has amnesia and continually asks me for the password. I checked keychain access and it shows a bunch of entries for:

    <key>
    iMessage Encryption Key
    iMessage Signing Key

    I get the pop up every time someone sends me an iMessage to my phone. iMessage sync DOES work on my iPad mini, but it is failing to send or receive from my Mac.

    Thanks,
     
  2. campyguy macrumors 68040

    Joined:
    Mar 21, 2014
    Location:
    Portland / Seattle
    #2
    Have you run Keychain First Aid?

    First, open up Keychain Access (I use Spotlight to find it), open the app's Preferences, then select the "First Aid" tab. If the box marked Keep login keychain unlocked is not checked, check it. Close the Preferences dialog box.

    From the Keychain Access Menu, run Keychain First Aid and you'll need your user name and password - run the Verify command, and if there are issues, run the Repair command.

    That's a start, and fixes a multitude of ills. I'd also use Disk Utility to Repair Permissions while you're at it...
     
  3. BrownManUPS thread starter macrumors 6502a

    BrownManUPS

    Joined:
    Jul 30, 2007
    Location:
    California
    #3
    Thanks for the reply. Yes I've run both multiple times.

    Code:
    Verification started
    Checking keychain configuration for ####### (user ID=502)
    Home directory is /Users/#######
    Checked login keychain
    Checked default keychain
    Checked contents of ~/Library/Keychains/login.keychain
    No problems found
    Verification completed
    
     
  4. campyguy macrumors 68040

    Joined:
    Mar 21, 2014
    Location:
    Portland / Seattle
    #4
    So the next step would be to first delete the two iMessage entries from Keychain Access, then restart your Mac, log in and try Messages again (you didn't offer which version of OS X you're using, but that's largely irrelevant for this). You'll be prompted for a password again, and hopefully you'll be good to go. This fix has addressed a multitude of hiccups for me...

    Next up would be deleting from and adding your account information to Messages again, and now you're down to your last option.

    Delete your old and add a new user account with your relevant account info again - the final option I can think of.

    That's all I've got, good luck!
     
  5. BrownManUPS thread starter macrumors 6502a

    BrownManUPS

    Joined:
    Jul 30, 2007
    Location:
    California
    #5
    This exactly worked! I deleted all of my keys related to iMessage and <key>, restarted, and then bam! Wow. Thanks.
     
  6. campyguy macrumors 68040

    Joined:
    Mar 21, 2014
    Location:
    Portland / Seattle
    #6
    You're welcome. I saw you are in Austin, I had to help. I was there a few "lifetimes" ago, miss the food and music - have some brisket at Frankin on me, if that's your thing. Miss that.
     

Share This Page