Key presses at startup don't work

Discussion in 'Mac Basics and Help' started by wilfried, Jan 9, 2008.

  1. wilfried macrumors member

    Joined:
    Jan 9, 2008
    #1
    I have a three month old 24" alu iMac running OS X 10.5.1 which has developed a bunch of niggley problems, and this is one of them. I hope someone can help.

    I have Windows XP installed in Boot Camp, and use Parallels as well. I used to be able to choose whether to boot into OSX or XP by pressing the Option key at startup. However, when I tried today, rather than show the two disk icons to choose from, it simply booted straight into OSX. I can boot XP by change the default startup disk in System Preferences, but the computer simply doesn't respond to the Option key like it used to.

    I then tried to boot into safe mode (I've never tried this before) by holding the Shift key at startup. Again, it didn't respond to the key press, and it booted normally. I can't get it to boot into safe mode.

    Finally, I tried to boot from the OSX install disk, by pressing "C" at startup. Yet again, nothing happened, and it booted normally off the hard disk; "About this Mac" in the Apple menu confirmed this. I can't get the computer to boot from the install disk at all. I also tried to select the install disk as the startup disk in System Preferences, but it ignored that too, and and when I rebooted, it ejected the disk and booted normally from the hard drive.

    So I guess I'm trying to solve a few problems. Why won't the computer respond as it should when I press and hold keys when I boot, and how do I get it to work again? How do I start in Safe Mode, and how do I boot from the OSX install disk?

    Please help. I'm pretty conversant with Windows, but am new to Mac, so I don't know how to begin to find the problem.
     
  2. richard.mac macrumors 603

    richard.mac

    Joined:
    Feb 2, 2007
    Location:
    51.50024, -0.12662
    #2
    hmm your mac may have a problem using the keyboard in startup mode. is it connected by USB or bluetooth? try these other startup shortcuts at the top like single user mode and verbose to see if your mac does actually respond to the keyboard while starting up. then we know if its a keyboard issue or not.
     
  3. iBecks macrumors 6502

    Joined:
    Nov 24, 2006
    Location:
    Nottingham, UK
    #3
    Have you used the Firmware password utility at all?

    If you have, this can stop any startup keys responding, although it should prompt for a password to be entered.
     
  4. PYR0M310N macrumors 6502a

    PYR0M310N

    Joined:
    Aug 29, 2006
    #4
    If you have a wireless keyboard of some sort, this may be affecting it. You could try it will a wired keyboard, if this is the case. Even if you have a wired keyboard you might want to try a different keyboard to rule out or not weather it is a keyboard issue, or a software issue
     
  5. wilfried thread starter macrumors member

    Joined:
    Jan 9, 2008
    #5
    Thanks for the input.

    I have a wired aluminum keyboard plugged directly into the USB port. I think you're right that the computer simply isn't responding to key presses during startup. The Option key to choose startup disk doesn't work. Pressing C to start from the OS install disk doesn't work (I can't get it to boot from disk at all). I can't reset PRAM either, since it requires pressing keys at bootup. I can't boot into Safe Mode by pressing the Shift key (is there another way to boot in Safe Mode, or reset PRAM?) At least the Option key used to work (I had never tried those other things before), but I have no idea what changed between then and now.

    What is the "Firmware password utility"?

    I don't have a wireless keyboard, and I don't have another keyboard to try; the only other computer around here is a laptop. I doesn't seem like a hardware issue though, since those keys work fine after the computer is booted up. One odd thing is lately, once in a while when I wake the computer from sleep, I get an error message to the effect that "Cannot connect to Bluetooth keyboard." I turned off Bluetooth for good measure.

    Finally, another minor annoyance I discovered is that the CD/DVD Eject key doesn't work anymore.

    Thanks again for the help. Any more ideas where I should look for the problem?
     
  6. richard.mac macrumors 603

    richard.mac

    Joined:
    Feb 2, 2007
    Location:
    51.50024, -0.12662
    #6
    hi again wilfried

    i think your Mac OS is not loading the keyboard drivers properly straight after booting. im not that knowledgeable of the Mac OS X boot process as it is highly complicated and the works of a 10 year hybrid unix/Mac OS operating system, but i think an Archive and Install is in order. this will reinstall Mac OS X while still keeping your files.

    also if you dont know what the firmware password utility is you obviously havent used it so i wouldnt worry about it.
     
  7. wilfried thread starter macrumors member

    Joined:
    Jan 9, 2008
    #7
    Well, I pulled the trigger and reinstalled the OS. I even did an erase and install (and later restored with Time Machine, pretty cool how that works). It didn't work! Option key, "C", Shift, key combination to reset PRAM still don't work. I'm at a loss.

    All the keys work when the system is booted up. As an aside, the disk eject key doesn't work at all anymore. I have no idea if that's related, but I'm grasping at straws.

    Is there another way to reset PRAM? I can't get it to work by press Command Option P R. I thought about running a hardware check, but I wonder if that will work, since it requires pressing D at startup.

    And this is strange too, and a bit hard to explain. Pressing "C" at startup to boot using the install disk doesn't work. I also inserted the disk, clicked on Install OS, and had the system reboot through the program, and that still didn't work. When the Mac restarted, it ejected the disk and booted normally. I finally got the install disk to run by rebooting by first clicking install from the disk, and then pressing C at startup.

    It's all highly perplexing. Don't know if anyone has any ideas.
     
  8. Squuiid macrumors 6502

    Joined:
    Oct 31, 2006
    #8
    We're having this EXACT same issue, carbon copy of what you said.
    However, our Mac is a G5 with 10.4.11. We have also tried all the suggestions to no avail.

    Anyone have any further ideas?! :confused:
     
  9. sg-mac macrumors newbie

    Joined:
    Jan 14, 2008
    #9
    Similar issue

    Hi. I was hoping someone had a good answer to this. I guess I'm just a little relieved to see I'm not the only one (misery loves company?).

    I might add that my issue wasn't apparent until a failed attempt at reinstalling a new boot camp partition with Windows XP (I'd deleted my old one, for a hal.dll error). Since the initial post here mentioned Boot Camp and Windows, too, I'm wondering if it's related.

    Also, all my keys DO work when the system is finally booted correctly, including the eject key, but my startup with the Option key is non-existent, and the "C" for the DVD didn't work the first few times. I'd really thought the failed XP install had killed my system for good.

    MacPro 2.66/ OS 10.5.1
     
  10. Squuiid macrumors 6502

    Joined:
    Oct 31, 2006
    #10
    Not sure Bootcamp is related as we have a G5 here with the problem.
    No Windows here..
     
  11. trainguy77 macrumors 68040

    Joined:
    Nov 13, 2003
    #11
    You could also reset the pram by taking out the battery for awhile. I don't know how long you would need to wait.
     
  12. sg-mac macrumors newbie

    Joined:
    Jan 14, 2008
    #12
    Good point. Should've noticed that.

    I did already try to reset the SMC and reset the pram (battery pull). No avail. Granted, I haven't tried it in a few days, but I'm a bit afraid of going into that loop I was stuck in.

    I'm surprised I haven't found any other references on the 'net about this.
     
  13. wilfried thread starter macrumors member

    Joined:
    Jan 9, 2008
    #13
    I have an iMac. Will pulling the plug reset the PRAM? I haven't found anything on the web about this either.
     
  14. trainguy77 macrumors 68040

    Joined:
    Nov 13, 2003
    #14
    No that will only reset the SMC. The pram is stored off battery power. So you would have to pop the battery out. :(
     
  15. Theatrics macrumors member

    Joined:
    Apr 1, 2007
    Location:
    San Diego
    #15
  16. wilfried thread starter macrumors member

    Joined:
    Jan 9, 2008
    #16
    If you read above, that precisely is the problem. Key presses at startup don't work, so I can't reset the PRAM.
     
  17. wilfried thread starter macrumors member

    Joined:
    Jan 9, 2008
    #17
    Just an update in case it offers anyone any insight. I finally called Apple tech support. The guy seemed helpful, but I'm not sure how knowledgeable, and he said he'd never of this problem.

    He had me run through a bunch of basic troubleshooting things, most of which I had tried, reboot, pull the plug to reset SMC, boot in safe mode (which of course didn't work), etc. The one thing that seemed to indicate something useful was hitting the caps lock key while the machine booted. Hitting it repeatedly, the green light didn't go on until the apple and spinning gear appeared. This seems to indicate that the Mac doesn't power the keyboard, or detect it until after OS X has booted. What normally drives the keyboard before the machine boots into the OS?

    The guy didn't have any bright ideas except try a different keyboard to see if therein lies the problem, which seems unlikely (and I don't have one handy; I'll have to see if I can drum one up). He tried to transfer me to the Leopard specialists, but after a long wait I gave up. It doesn't sound like a Leopard problem, seeing as it appears before Leopard boots.

    Does this sound like a hardware issue or a software issue? Is there anyone I should try to talk to before I drag the thing to the Genius Bar, a process I'd dearly like to avoid?
     
  18. Hyde macrumors newbie

    Joined:
    Apr 13, 2004
    #18
    here is the answer to your problem, sir:

    i have the same issue. I have a quad 2.5 and it came with the standard white keyboard. a few months ago i bought the aluminum keyboard. now, i dont know if you had to do this but i did. i had to install drivers and an update for this keyboard...

    i use applejack when there is an issue. i realized that i cannot start up in single-user mode or anything like that with this keyboard. the drivers for it load after the OS has started. if i plug my old white USB keyboard in - everything works. the problem is the new aluminum keyboard.

    i dont know why this hasn't been fixed. i have to keep my old keyboard laying around any time i need to hold the C key or start in SU mode, etc.

    sorry. its stupid and probably easily fixed. but at this time i dont know of any remedy.
     
  19. wilfried thread starter macrumors member

    Joined:
    Jan 9, 2008
    #19
    I'm going to try another keyboard when I can get my hands on one. However, the key presses worked just fine when I got the machine, which came with the aluminum keyboard. So, if it's a driver problem, it developed later.

    How do I reinstall drivers for this keyboard? Maybe I should give that a try?

    What's Applejack?
     
  20. Rower_CPU Moderator emeritus

    Rower_CPU

    Joined:
    Oct 5, 2001
    Location:
    San Diego, CA
    #20
    Same issue here with a Mac mini, Leopard 10.5.1 and a new wired alu keyboard. My old wireless Apple keyboard works fine for those boot up hotkeys, but no love for the new one.

    I can't believe that Apple would overlook something like this, especially on a keyboard directly wired in...I'm doing more research to see if there's a fix or knowledge of this over on the Apple boards.

    update:
    Nothing to report from the support forums, but I did find a few tidbits around the web-
    http://www.tuaw.com/2008/01/11/mac-101-boot-options/#c9782388
    http://groups.google.com/group/comp.sys.mac.misc/browse_thread/thread/e898f634d9030621

    Apparently, you can use the Apple Remote to get to the boot options screen by holding down the "menu" button. I think we're stuck waiting for a firmware fix on this because this keyboard isn't even being loaded until after the OS starts booting.
     
  21. wilfried thread starter macrumors member

    Joined:
    Jan 9, 2008
    #21
    I thought I'd check in to say that I finally solved the problem simply by replacing the keyboard. Apple swapped it out, and as soon as I had the new one plugged in, everything that had stopped working worked again. The eject key works again. The Mac wakes up from sleep when I press a key on the keyboard (till now I had to press the power switch on the back). I can boot into Boot Camp by restarting and holding down the option key. It turns out it was a hardware problem in the keyboard, though I'm still a bit perplexed. All the keys worked (except the eject key) when the machine was booted up and running, but but the computer didn't respond when I pressed keys as it was booting.

    It was a long road getting to the rather simple solution. First I tried all kinds of troubleshooting things, talked to tech support, and talked to a guy at the Genius Bar, who didn't have any great ideas; the Genius Bar guy wanted me to bring in the whole computer, which would have been a royal pain. I didn't have another USB keyboard lying around, so I eventually borrowed and old lucite Mac keyboard from a coworker. Everything worked fine. So I went back to the Genius Bar with my aluminum keyboard to test on another iMac, and sure enough the same problems appeared there too. They agreed to swap the keyboard, but it required yet another trip as they were out of keyboards (how does an Apple store run out of keyboards?), so they had to order one which arrived a couple of days later.

    So, it took a while, but all's well that ends well. None of the problems were showstoppers, so I kept doing what I needed to do. Anyway, I hope this might help other folks with similar problems. Test your keyboard! :D
     
  22. REYNE macrumors newbie

    Joined:
    May 1, 2008
    Location:
    Auckand, New Zealand
    #22
    Startup Keys

    Hyde bring's up a good point, which eventually solved mine.

    For my situation, I was booting my fantastic 8core MP in verbose mode (just to see what goes on) and needed to boot to the Leopard installer DVD simply to repair my permissions after a system update.

    It's interesting to note that the MacPro, found the DVD and started to boot up from it, however could not complete. More investigation required on that one.

    I then restarted to find that my aluminium keyboard would not work with any keyboard shortcuts.

    So I was left in verbose mode that couldn't boot up from a DVD, that I could not eject manually! and none of my startup keys were working!!! ARRRgGGHHH.

    So, as Hyde said, I used an old keyboard, pressed option and voila!

    However, what I did discover is that my aluminium keyboard was plugged into my 23" HD via USB - perhaps this is a reason it was not identified. When it was plugged into the front of the MP, no problems.

    Sorry for the long winded story - perhaps this will help someone out in the future - it certainly pissed me off no end!!



     
  23. ti-claude macrumors newbie

    Joined:
    Sep 30, 2008
    Location:
    Montréal Qc
    #23
    Key presses at startup don't work 'cause plug into my DELL USB

    No startup key combinations work at all on my Mac Pro early 2008.

    Thanks after much trying (Googling, reinstallling my system, trying different keyboard, calling Apple support) I solved my problem while reading the previous message from REYNE in NEW ZEALAND.

    I simply unplug my keyboard from my 30 inch Dell screen and plug it directly in my machine. IT WORKED!

    But why such an expensive machine like this on have so few USB ports?

    Thanks a lot!
     
  24. UloveIt777 macrumors newbie

    Joined:
    Feb 23, 2009
    #24
    BootCamp with Tiger is designed to not work with Alu keyboard

    Hi,

    just spent one hour on the phone with the Apple support.

    It appears that BootCamp for Tiger is a beta with an expiry date and thus new keyboards from Apple don't support Alt at boot.
    If you want to access your other bootable partitions at boot with new Apple keyboards, you're forced to upgrade to Leopard and hence get the new bootcamp:
    it's wanted to force upgrades. The M$ world...

    For Leopard, you need to install the latest keyboard firmware update (currently 1.2) and latest Leopard updates as a first troubleshooting step.

    ++
     
  25. trainguy77 macrumors 68040

    Joined:
    Nov 13, 2003
    #25
    The reason for this was they didn't even want to release a beta, however shortly after hackers found out how to install windows they didn't want everyone doing this so they released the beta which was supposed to only be a 10.5 feature. So since they were forced to release the beta they made it expire so people would still consider it a feature of 10.5
     

Share This Page