Keyboard and Mouse Not Working

Discussion in 'MacBook Pro' started by hudsora, Jan 5, 2009.

  1. hudsora Suspended

    Feb 24, 2008
    I am running 10.5.6 and I was trying to Jailbreak my iPod so I switched out the IOUSBFamily.kext file for the old one. Well that didn't work. and when I restarted the machine I no longer had mouse or keyboard. So I booted up with BootCamp and used MacDrive to enter my disk. From there I copied the backup files of IOUSBFamily.kext into the extentions folder.

    I then tried to boot back up, but the mouse and keyboard still don't work.

    So I believe that the permissions on the IOUSBFamily.kext are incorrect. So I am wondering how can I switch the permissions to 755 with Bootcamp?

    Thanks a lot for the help, I might be wrong about the permissions being the problem so if you have any other ideas, I will gladly consider them!

  2. iJimmy macrumors regular


    Feb 4, 2008
    I had the same problem yesterday. I'm not sure if it's the only way but I resolve this by reformatting the hard drive. There may be another solution out there.

    But if you have an external 2.5" hard drive (I used a WD Passport) and a Time Machine back up, then you're good to go.

    Here's the steps that I took:
    1: Take apart your WD Passport to use as a startup disc (you do not need to format the drive). Disconnect the usb adapter from the drive.
    2: Replace your internal hd with the passport hd (again there is no need to reformat the drive). Then connect the usb adapter to your original internal hd.
    3: Boot your mac and insert your Mac OS X Install disc 1.
    4: When they ask you what hd you want to install Mac OS X, connect your external hd to the usb port.
    5: Go to Utilities on the Menu Bar then select Disk Utility. Reformat your original internal hd.
    6: Exit Installer and shut down your mac.
    7: Swap out the hd again.
    8: While booting your mac hold the eject button. When your disc ejects, wait a few seconds then insert it back in.
    9: Install OS X and if you have a Time Machine... I'm sure there's no instruction needed for that.

    That's how I resolved (resolving) this problem. Goodluck. If you have any questions let me know. Again there may be another solution. But this worked for me.
  3. hudsora thread starter Suspended

    Feb 24, 2008
    Thanks for the help,
    I just decided to use my TimeMachine Backups and reinstalled from that. It sounds like that is what you did as well.

    But again thanks for the help!


Share This Page