Keyboard click volume

Discussion in 'iOS 7' started by NacSquared, Sep 14, 2013.

  1. NacSquared macrumors regular

    NacSquared

    Joined:
    Apr 14, 2011
    Location:
    Missouri
    #1
    Maybe it's just my phone is glitched or something..

    On my phone the keyboard clicks are actually louder when my phone volume is about halfway up.. And they get much quieter when my phone is on max volume.

    Now this only occurs in the messaging app, as I noticed while typing this on safari that its back to normal.

    Is anyone else experiencing this?
     
  2. photobiker macrumors member

    photobiker

    Joined:
    Feb 20, 2006
    #2
    I installed iOS 7 yesterday. Same problem here and, given the workarounds I found, that's one funny bug...

    As a summary, there are 2 counter-intuitive rules:
    - Under Settings > Sounds, the switch "Change with Buttons" works more or less in the opposite direction. If you want to control the volume of the key clicks with the buttons, turn it off. If you want to set it once and for all, turn it on.
    - The volume of the keyboard clicks is *inversely* proportional to the volume you set through the*buttons, or through the Music app volume slider.

    So let's see what happens in the 2 modes:

    1) If "Change with Buttons" is off...
    - With the finger, under Settings > Sounds, set the slider to the volume you want for the ringer and alerts.
    - Important: wait until your ringtone finishes playing.
    - With the buttons, set the "base volume" you want for the key clicks, knowing it will work in the opposite direction. This "base volume" can only be set with the buttons while under Settings > Sounds.
    - If you set the base volume very high, go to an editor (for instance, the Notes app), type some keys, the clicks are audible. While still in the editor, lower the volume with the buttons and the key clicks become louder and louder.
    - If you set the base volume fairly low, go to an editor, type some keys, the clicks are barely audible. While still in the editor, lower the volume with the buttons and the key clicks become louder but because your base volume was low, you can't increase by much. Now increase the volume with the buttons and the key clicks become less and less audible.

    1) If "Change with Buttons" is on… (that one was trickier to find!)
    - Go to the Music app. You don't need to play music; just set the volume to the desired level knowing it will work in the opposite direction. But since this volume is only the first component of the "base volume", you can leave it somewhere in the middle.
    - Go to Settings > Sounds and with the finger (not with the buttons!), adjust the slider to the desired level. This is the second component of the "base volume" and it works in the correct direction: higher means louder.
    - Important: wait until the ringtone finishes playing.
    - Go to an editor and type some keys: you can hear the key clicks at a normal volume.
    - Go to the Music app, lower the volume, go back to the editor, type some keys: the key clicks are louder.
    - Go to the Music app, increase the volume, go back to the editor, type some keys: the key clicks are fainter.

    Congratulations: you can set the volume of the key clicks through the volume slider of the Music app which works in the opposite direction!

    Don't ask how I found out. Some people have a lot of time on their hands. Others are just anal about things that don't work how they should.
     

Share This Page