Keyboard combination \ stopped working

Discussion in 'Mac Accessories' started by Timid&friendly, Sep 5, 2011.

  1. Timid&friendly macrumors newbie

    Timid&friendly

    Joined:
    May 20, 2007
    #1
    Hi,

    The keyboard shortcut combination "command+backslash" has stopped working. Both keys work fine separately. Tried another keyboard and it's the same problem so it must be a system setting somewhere.
    I have reset all shortcuts in the system preferences to standard settings and gone through the whole list and see no conflicts?

    Any ideas
     
  2. FearGhost macrumors member

    FearGhost

    Joined:
    Apr 4, 2011
    Location:
    Cambridge, UK
    #2
    Do you have 1Password installed? If I remember correctly, that is a keyboard shortcut for it?
     
  3. Timid&friendly thread starter macrumors newbie

    Timid&friendly

    Joined:
    May 20, 2007
    #3
    Yes I do. Coincidentally i this shortcut in Adobe dreamweaver and have the same issue. It used to work in both but now it doesn't work in either?
     
  4. flynz4, Sep 5, 2011
    Last edited: Mar 27, 2012

    flynz4 macrumors 68040

    Joined:
    Aug 9, 2009
    Location:
    Portland, OR
    #4
    Since OSX 10.7 Lion was released, 1Password has gone through a ton of revisions. It seems to be almost daily!

    My 1P hotkey has also come and gone like the tide. I cannot figure out the pattern that is causing it to happen. For me, it has mostly been on my 27" iMac. My MBA generally seems to work.

    I have deleted and reinstalled the safari plug-in over and over trying to fix the problem. When the hotkey is not working, I can still get to my bookmarks via the 1P icon on the safari toolbar so I resort to that once my hotkey is not working.

    I have been assuming that the folks at 1Password will sort this out soon enough, so I have been patient (it's not like they are not working hard on Lion). I'm going to subscribe to this thead in case others can help me figure out the secret handshake required to keep the hotkey working.

    *** Solved *** See my post below

    /Jim
     
  5. Timid&friendly thread starter macrumors newbie

    Timid&friendly

    Joined:
    May 20, 2007
    #5
    Just for clarity sake; Although 1password is a problem (software no-longer stable on PC or mac in FF 5 and 6), That is not the main issue, or indeed the reason for this thread.

    Key combo (command + backslash) doesn't work at all in any other program? It's been about a week; possibly since a snow leopard update, but not sure. (i'm still using snow leopard).
     
  6. Formul macrumors member

    Joined:
    Jan 29, 2010
    Location:
    Czech Republic
    #6
    i was puzzled by this for a long time and i finally figured out what the problem was (in my case at least)

    on my regional keyboard the '\' key is right next to the left shift and it was the key that was working prior to new safari, but the new extension is using the key next to the enter (where the usual mac keyboard has '\') for the shortcut no matter what it actually types when you press it

    it is confusing and i hope they resolve this awkward issue
     
  7. Timid&friendly thread starter macrumors newbie

    Timid&friendly

    Joined:
    May 20, 2007
    #7
    Sorry. I didn't understand you response?
     
  8. Ward Clark macrumors newbie

    Ward Clark

    Joined:
    Feb 27, 2010
    #8
    Works for a while after startup

    I've been experiencing the loss of Command-\ for quite some time in these apps on Snow Leopard:
    • OmniWeb - View menu > Login with 1Password
    • FileMaker Pro Advanced - Layout mode > Format menu > Align Text > Center
    OmniWeb treats the key as defined, i.e., there's no "unrecognized key" beep when I press the shortcut. I used to think the Command-\ was being ignored by 1Password. Discovering that the shortcut stops working in FileMaker makes me think something global is defeating Command-\.

    Another strange aspect is Command-\ works for a while (hours or days) after startup but then stops for no apparent reason.

    I've searched all of the places where an overriding keyboard shortcut might be defined:
    • System Prefs > Keyboard > Keyboard Shortcuts
    • QuicKeys
    • 3rd party prefPanes
    • Menu Extras
    -- Ward
     
  9. flynz4 macrumors 68040

    Joined:
    Aug 9, 2009
    Location:
    Portland, OR
    #9
    I have had problems with "command \" in 1Password on our iMac, but not on any of our MBAs. In my case, it appears to be a problem only when I have more than one user logged in on the iMac at a time. I have tested this and have been able to recreate the problem by leaving other users logged in. Since we typically use our MBAs as a single user machine, we do not see the problem.

    /Jim
     
  10. steveklein macrumors newbie

    Joined:
    Apr 3, 2006
    Location:
    Michigan
    #10
    I've just noticed the same problem. It's used in FileMaker Pro to "Align Text Center," but it doesn't work.

    After reading this thread, I thought maybe 1Password (which has been working fine) was somehow 'stealing' that key press from FileMaker. So I changed the shortcut in 1Password, but that didn't help FileMaker.

    What's worse is that now I can't change it back in 1Password! When I tried pressing ⌘\, 1Password only saw the ⌘ key.

    I was able to assign it as a keyboard shortcut in System Preferences -> Keyboard -> Keyboard shortcuts. So I know that the key works.

    I'm really frustrated right now.
     
  11. flynz4 macrumors 68040

    Joined:
    Aug 9, 2009
    Location:
    Portland, OR
    #11
    Do you have more than one user logged into your Mac? For me, my problem with ⌘\ only occurs when there are two people logged in (we use fast user switching). This problem is 100% repeatable and started with Lion.

    /Jim
     
  12. scotty321 macrumors regular

    Joined:
    Jun 4, 2003
    Location:
    Los Angeles, CA
    #12
    This same problem happened to me on Mac OS X 10.8.3 Mountain Lion. Suddenly, my "command backslash" keyboard shortcut stopped working in all my apps. It stopped working in FileMaker (which is the "Align Text > Center" function), it stopped working in 1Password, it stopped working everywhere. I checked through all the globally-running apps on my entire computer, but nothing else was hijacking that keyboard shortcut. No, there were no other logged-in users at the time. Finally, I just restarted my Mac, and everything was back to normal. I suppose I should have restarted my computer first! :)
     

Share This Page