Keyboard / expose / dashboard problems

Discussion in 'macOS' started by hamishniven, May 8, 2008.

  1. hamishniven macrumors newbie

    Joined:
    May 8, 2008
    #1
    I've been using my iMac for 3 months now and 4 days ago, it began doing strange things.

    After a short time 10 - 30 minutes the dashboard button - F4 stops bringing the dashboard up, the cmd and tab stops working bringing up the list of open open apps, and expose and spaces stop functioning - the shift arrowsto move between spaces does not work, and the active screen corners have stopped working.

    I have to use the dock to find open windows and its a PITA. Restarting solves the problem, for only for 10 - 30 minutes.
    The itunes buttons on the keyboard still work, but the brightness and darkness dont. I can use the cmd, alt, ctrl and shift keys for editing and selecting text when word processing, but they dont seem to work in conjunction with the function keys.

    I have not installed anything in the last week or 2 that could do anything.
    ( I also have no idea where the Fn key is - unless that is for laptops )

    Any help would be much appreciated.

    Mac OS X 10.5.2 software up to date
    2.4 Ghz intel core duo 4 Gb 667 Mhz DDR2 SDRAM
    320 Gb drive partitioned smaller one for windoze games and 2 external drives FAT 32 as externals.
    non apple mouse as the thing lasted a month.
     
  2. hamishniven thread starter macrumors newbie

    Joined:
    May 8, 2008
    #2
    now working

    Ok so this is getting boring,
    One thing I hate is problems that solve themselves unwittingly, for no aparent reason, then I stop and remember, hmmm so I've appzapped something I installed and expose is working (press F4 and dashboard that works ) 3 hours and many minutes.
    strange and frustrating especially as the app was a demo of some disk management software.
    Anyway thought you may like to know.

    ttfn
    Hamish
     
  3. hamishniven thread starter macrumors newbie

    Joined:
    May 8, 2008
    #3
    working or not

    Its started doing it again,
    I've taken the keyboard in for repair and got a replacement, and its still happening, any help would be appreciated, I really dont want to re install and spend days downloading updates etc etc as I pay $6 per gig here in South Africa.


    ideas or suggestions appreciated
    thanks
     
  4. hamishniven thread starter macrumors newbie

    Joined:
    May 8, 2008
    #4
    overwelmed

    Thanks for all your help everyone.
    I finally took the 3 month old keyboard back to the shop I bought the machine from and they lent me an old keyboard whilst they are testing the new one.
    Its the keyboard, a brand new keyboard that broke like the brand new mouse that broke after 2 months
    Apple you've got great machines, but sh crap peripherals made cheaply in china.
     

Share This Page