iMac Pro Keyboard goes crazy

Discussion in 'iMac' started by Scott6666, Apr 25, 2018.

  1. Scott6666 macrumors 65816


    Feb 2, 2008
    New base model iMac Pro. Every couple hours the keyboard goes crazy and adds a bunch of characters or deletes a bunch of characters. Even control-c has been duplicated resulting in a crazy # of pastes.

    Cannot be stopped by pressing again. Not a single key or group of keys.

    Even had the keyboard replaced by the Apple store so it's not the keyboard. High Sierra 10.3.2.

    Anyone else seeing this?

    Not sure I want to go to 10.3.4. Wondering what that does with the fan issue.
  2. JustMartin macrumors 6502a

    Feb 28, 2012
    Worth doing a search of this forum. Someone here was complaining about the same kind of thing - think they decided it was Bluetooth interference.
  3. campyguy macrumors 68040

    Mar 21, 2014
    Portland / Seattle
    I "fixed" this on all of my PCs and Macs at work and home after setting up a version of Tomato on a router in one of my field offices a few years ago - Bluetooth Coexistence Mode - when pretty much every BT device went crazy after installing the router, there's likely more on the interwebs about this. Almost all of my input peripherals have timeouts, don't utilize EDR (I use a StarTech BT dongle for my wideband usage when I need it), and there can be issues with BT when a low-power BT device times out and the non-low-power capable BT devices (mice, keyboards) try to connect with the computer. One of the first configurations I make to my Macs now is to enable hybrid coexistence - one of the first changes I made to my iMP, zero issues with any of my peripherals (Wacom Intuos Pro, Contour Mouse, Magic Trackpad 2/Keyboard). Enabled by this command (I keep it in my Notes app as I maintain about 30 Macs in my offices):

    sudo defaults write /Library/Preferences/ bluetoothCoexMgmt Hybrid

    followed by a reboot. I know exactly what you're alluding to, it used to drive me nuts but it's been a few years since I've had to deal with it. I also tend to disable 2.4GHz frequency on my networks, little need for it at my home and workspaces. A few changes to the Windows Registry effect the change in BT connection behavior. I don't know why it's disabled by default on non-laptop computers - enabling hybrid mode does use more power, but I don't care about this.
  4. Bryan Bowler macrumors 68040

    Sep 27, 2008
    My iMac Pro keyboard did this tonight. Out of nowhere, it started deleting characters as if the delete key was stuck. Totally pissed me off because it deleted several lines of a long email I was composing before I finally just turned the keyboard off. And then a few hours later, it started typing random keys on its own.

Share This Page