keyboard got lost after disabling USB bluetooth and CD DVD

Discussion in 'Mac OS X Server, Xserve, and Networking' started by prerna.bhand, Oct 9, 2010.

  1. prerna.bhand macrumors newbie

    Joined:
    Oct 9, 2010
    #1
    Hi,

    At work, I am supposed to disable USB, Bluetooth and DVD, CD from my mac book pro.. Its running snow leopard

    To disable it, I moved the kext files from the system/libary folder to another one.

    Now when I rebooted it, I cannot type in the password. The keyboard or touchpad inputs are not getting recognized. Since the lappie wants the user password, I cannot type that in and move forward. :confused:

    What can I do to replace these files? Should I boot from CD and then try to replace them? what are the commands for the same? I am really stuck with this and am new to the mac world.

    Thanks
    Prerna
     
  2. PurdueGuy macrumors regular

    Joined:
    Jun 23, 2010
    #2
    Disabling USB pretty much disables everything. The keyboard and trackpad connectd via USB. Not a good idea to mess around with kernel extensions.

    I assume you want to disable the USB ports? I don't know of a way to do that.

    You can disable Bluetooth by just turning it off.

    Why all the hassle? A Mac without USB is a paperweight.
     
  3. foidulus macrumors 6502a

    Joined:
    Jan 15, 2007
    #3
    Unfortunately like the previous poster said your keyboard is attached via the USB bus even if you cannot "see" the port. Unfortunately disabling individual ports doesn't seem like it's possible(you could try deleting the corresponding /dev file, but I wouldn't recommend it).

    However you CAN disable mounting of USB mass storage(which is most likely what you were after)

    Here is more info:

    http://blogs.techrepublic.com.com/networking/?p=297

    However messing with kexts can be a bit dangerous. Also don't be surprised if the kext shows up again next OS update. Apple has a habit of doing that.
     

Share This Page