Keyboard.Help

Discussion in 'MacBook Pro' started by davidtmarquez, Jun 16, 2007.

  1. davidtmarquez macrumors member

    Joined:
    Mar 14, 2007
    #1
    Im.typing.like.this.coz.my.spacebar,DELETE.and.TAB.button.doesnt.work.:( :(

    I.get.this.kinda.often.nowadays.
    Since.I.started.playing.Jedi.Knight.2.
    The.problem.goes.on.and.off.
    But,as.of.now.its.been.off.for.a.loong.time.:( :(

    Any.help.here?:D
     
  2. mkrishnan Moderator emeritus

    mkrishnan

    Joined:
    Jan 9, 2004
    Location:
    Grand Rapids, MI, USA
    #2
    are.you.talking.about.osx.or.windows:(:(

    does.it.go.back.to.normal.on.reboot.or.stay.messed.up:mad::mad:
     
  3. davidtmarquez thread starter macrumors member

    Joined:
    Mar 14, 2007
    #3
    OS.X

    Its.messed.up.forever.

    Is.this.replaceable.with.warranty?:)
     
  4. mkrishnan Moderator emeritus

    mkrishnan

    Joined:
    Jan 9, 2004
    Location:
    Grand Rapids, MI, USA
    #4
    I don't think Jedi Knight can make your hardware go bad... mmm... it sounds like it corrupted a preference file or something. Try to change the keyboard layout to a foreign locale (like if you use US-English, switch temporarily to UK-English or FR-French or whatever), and then switch back. See if that helps?
     
  5. davidtmarquez thread starter macrumors member

    Joined:
    Mar 14, 2007
    #5
    My.problem.really.is.the.hardware.
     
  6. mkrishnan Moderator emeritus

    mkrishnan

    Joined:
    Jan 9, 2004
    Location:
    Grand Rapids, MI, USA
    #6
    Then, if it's in warranty, of course they can replace it.
     
  7. davidtmarquez thread starter macrumors member

    Joined:
    Mar 14, 2007
    #7
    Now,Im.wondering.How.long.will.it.take.to.replace.or.repair.it?
    Btw,I.live.in.the.Phiilippines.:|Wonder.how.long.thatll.take
     
  8. TheAnswer macrumors 68030

    TheAnswer

    Joined:
    Jan 25, 2002
    Location:
    Orange County, CA
    #8
    I'm not so sure. That's a really wide span of keys (tab, delete, space) to all go malfunctioning (unless you either dropped it or spilled something on it).

    Try logging in under another account and see it the problem persists. If it doesn't, then mrkrishnan is correct and it's most likely a bad preferences file and it will come down to finding which one it is. If the problem persists in the new account, then it's a hardware issue.

    Either way, it's something simple and it may save you the hassle of trying to get it replaced.
     

Share This Page