Keyboard issue with lion

Discussion in 'Mac OS X Lion (10.7)' started by Tyler.Schmaltz, Jul 20, 2011.

  1. Tyler.Schmaltz macrumors member

    Joined:
    Jan 23, 2004
    Location:
    Velva
    #1
    Installed lion on a 2009 MacBook Pro. Anytime i switch spaces or desktops as they are called now. My keyboard, apple usb and built in, stops working.
     
  2. Patrick J macrumors 65816

    Patrick J

    Joined:
    Mar 12, 2009
    Location:
    Oporto, Portugal
    #2
    Sorry if this isn't any help, but it doesn't happen to mine (clean install). Did you have any funny hacks/extensions installed?
     
  3. Tyler.Schmaltz thread starter macrumors member

    Joined:
    Jan 23, 2004
    Location:
    Velva
    #3
    No funny hacks or extensions installed. Issue is no keyboard events will be sent to any application. However, I can see that the OS is still getting those events, because certain system-level key combos work (e.g. Opt+arrow to switch between spaces) and the Keyboard Viewer is still registering all keypresses. Despite this, no application (including the Finder and the password-entry box to unlock the screensaver) is getting any keyboard input.
     
  4. Joe 90, Jul 21, 2011
    Last edited: Jul 21, 2011

    Joe 90 macrumors newbie

    Joined:
    Jun 29, 2011
    #4
    USB Keyboard stopped responding

    Upgraded to lion early today on a 2011 imac with USB keyboard. Had keyboard stop responding twice on me, each time requiring a reboot. Caps lock light still worked but that appeared to be it. Changed USB connections with no luck. Haven't worked out why yet but has never happened before.
     
  5. Joe 90 macrumors newbie

    Joined:
    Jun 29, 2011
    #5
    USB and Bluetooth keyboards not working

    3rd hangup now on keyboard. I had a backup bluetooth keyboard setup as well and this displayed exactly same symptoms. It happened when I pressed <CTR><Right Arrow>/<left Arrow> to switch between desktops. I am no longer able to use the keyboard to type in any text in any app although the <CTR><Right Arrow>/<left Arrow> does still work for switching desktops.

    I believe that this was the same situation that hosed the keyboard before although I cannot reproduce on demand.
     
  6. mboeru macrumors newbie

    Joined:
    Jul 21, 2011
    Location:
    Bucharest
    #6
    I also am facing this problem.
    Even if i don't have multiple screens, i just press the key combination by accident and still get the keyboard stuck.

    Anyone figured out a way to fix this?

    Thanks!
     
  7. mcb001982 macrumors regular

    Joined:
    May 27, 2008
    Location:
    Manhattan NY
    #7
    I did have an issue with my bluetooth devices on the initial install but after plugging in the USB devices and re pairing once installed it worked fine.
     
  8. mboeru macrumors newbie

    Joined:
    Jul 21, 2011
    Location:
    Bucharest
    #8
    I see this behaviour on both bluetooth keyboard and also my mb pro builtin keyboard. Once I switched spaces, no keyboard access in applications.
     
  9. flash42 macrumors newbie

    Joined:
    Jul 22, 2011
    #9
    I'm experiencing the same problem.
    I noticed that if you kill the process Dock, through Activity Monitor, the keyboard gets responsive again, better way then having to reboot your mac every time you lose your keyboard.
     
  10. mboeru, Jul 22, 2011
    Last edited: Jul 22, 2011

    mboeru macrumors newbie

    Joined:
    Jul 21, 2011
    Location:
    Bucharest
    #10
    Seems to work this way.. Thanks.
    Let's just hope Apple fixes this soon.

    Update: the issue seems to appear only when I use the shortcut key ctrl + left arrow OR ctrl + right arrow.
    If i use gestures, like swap the keyboard keeps working without any issues
     
  11. rcarter236, Jul 24, 2011
    Last edited: Jul 25, 2011

    rcarter236 macrumors newbie

    Joined:
    Jul 24, 2011
    Location:
    New Jersey
    #11
    bluetooth worked fine with lion upgrade...till today.


    I upgraded to lion on my iMac (2009 model). I have a logitech dinovo bluetooth keyboard and magic mouse. I had no issues at all with the upgrade to lion from snow leopard. Bluetooth worked great......until today.

    Not sure if it was a bluetooth issue or if my machine just locked up, but I could not wake my iMac from sleep. I had to manually turn it on. Then both bluetooth devices would not respond. I had to plug in a usb mouse/keyboard. I checked the status of the devices and both were showing that they were connected, but just not responding. Then I noticed I couldn't get on the internet, Couldn't open system preferences, system was just frozen. (This has never happened since I bought the iMac nor while running snow leopard).
    After a reboot, everything is back to normal. I am typing this on the bluetooth keyboard. I tried the shortcuts you mentioned above, all works fine with no issues for me. I will let my mac go to sleep and see what happened. I'll repost if I have any updates.


    Update, issue happened again around 7pm tonight. Worked fine all day. iMac went to sleep, wake with bluetooth devices. Not sure what is causing this. I have no weird scripts or startup programs either. Hope a fix comes out soon.
     
  12. Fordzephyr macrumors newbie

    Joined:
    Jul 30, 2011
    #12
    I have downloaded the latest update but while my 2010 MacBookPro with 10.7 recognizes the DiNovo keyboard it does not respond to key strokes. It was working on a Macmini with 10.6 last week. It does not show in menu bar a no battery indicator.
     
  13. basher macrumors 6502

    basher

    Joined:
    May 27, 2011
    Location:
    Glendale, AZ USA
    #13
    OP I am not experiencing the same prob as you.
     
  14. inquirer5, Jul 31, 2011
    Last edited: Jul 31, 2011

    inquirer5 macrumors newbie

    Joined:
    Jul 31, 2011
    #14
    I have run into this issue before with Snow Leopard, but I don't remember what caused it. I know that killing the Dock process with Activity Monitor would solve it there as well. Eventually it stopped altogether.

    Today unfortunately I was able to reproduce the issue in Lion as well. It started when I enabled the ^+1 shortcut in Keyboard Shortcuts for Mission Control. After I did that the shortcuts worked for a few seconds, then the keyboard stopped responding. The trackpad on my keyboard works fine (Logitech DiNovo) so it's not the Bluetooth connection, just the keys are not providing any input. Killing the Dock process again resolves the problem, but only temporarily.

    Strange indeed. I'm disappointed that Apple still hasn't resolved such a serious bug.

    [EDIT]
    I also noticed a lot of these messages in the log whenever I would kill the Dock process:
    Code:
    com.apple.dock.extra: Could not connect the action buttonPressed: to target of class NSApplication
    Since the Ctrl+Arrow key combination still works for me it almost seems as though Mission Control (or Dock it appears) is holding onto all keyboard input for some reason.
     

Share This Page