Keyboard Keeps Illuminating by itself

Discussion in 'MacBook Pro' started by Syndacate, Jun 7, 2008.

  1. Syndacate macrumors regular

    Joined:
    Mar 16, 2008
    #1
    Alright, first let me start off by saying in system preferences >> keyboard and mouse, the "illuminate keyboard in low light conditions" is unchecked, I NEVER want the keyboard to illuminate under any circumstances.

    I also use this (possibly 3rd party) program called "Lock My Mac" - I use this to lock the screen, similar to the screen lock in windows (windows key + L) or the lock screen button in the Gnome window manager of Linux.

    Sometimes when I come back, I'll find the keyboard lit up like a christmas tree (and it's quite obvious since when I lock the screen I turn the lights off) - now I'm sure pple are going to ask "why not just close the lid" - because mac made this stupid ass assumption that when you close the lid you're "done with the computer" and you can't change that - therefore it goes into deep sleep, cuts off internet and the like, I can't have that - it's great for travel, not when your computer's hooked up as a desktop though. So I want to password protect (lock) my screen so nobody ****s with it - but keep internet connections, etc. open, you can do this on all other operating systems except mac, therefore I use the 3rd party app "lock my mac" - I don't use insomnia b/c I'm not looking to close the lid, it's connected to an external monitor.

    Does anybody know why the keyboard keeps randomly lighting up even though ti's unchecked in sys preferences? Only thing I can think of is that it's a bug in "Lock My Mac" - anybody have any input?
     
  2. Burnsey macrumors 6502a

    Joined:
    Jul 1, 2007
    Location:
    Canada
    #2
    A couple of things, when you are connected to an external monitor and you don't want to use the mbp display, you can close the computer, wait for it to go to sleep, wake it up again (by clicking an external mouse or something, computer must still be closed) and then your external monitor will be the main display and you can keep your mbp closed.

    Second, if you go to the Security pane in system preferences, you can choose the computer to require a password when waking up from sleep or after a screensaver.

    Finally I am having the same problems with the keyboard backlight, so I doubt it has something to do with your app and more with 10.5.3.
     
  3. CalBoy macrumors 604

    CalBoy

    Joined:
    May 21, 2007
    #3
    Have you tried pressing F8 (turns on/off backlight regardless of ambient light)?

    As for the lid and not wanting it to auto sleep, there's a program called Insomnia X that will allow you to control that so it won't sleep when the lid is shut.
     
  4. Syndacate thread starter macrumors regular

    Joined:
    Mar 16, 2008
    #4
    I have the newest generation macbook pro, the re-mapped the function keys, my F8 is "play/pause."

    @ Burnsey:
    Sometimes I use the MBP monitor as a twin monitor, sometimes I don't use it at all, I keep the lid open. I don't want to use it in clamshell mode. My computer will prompt me for a password on wake or screen saver shutoff, but that's why I said what I said - I don't want that. I don't want to have to wait 5 minutes for it to go into screen saver, and I don't want it to go to sleep because it'll kill the network adapter. Therefore I need to use a screen locking program, or be able to lock it on command. I'm surprised there's not a default screen saver or "lock" button by default - there is a lock command on every other operating system I've ever used ranging from windows, to ubuntu/kubuntu, to gentoo, to fedora, to redhat to debian, to centOS, to Solaris so on and so forth (the list just goes on and on), I'm surprised there's not one by default in OS X.
     
  5. CalBoy macrumors 604

    CalBoy

    Joined:
    May 21, 2007
    #5
    Ahh yes, I'm not familiar with that layout. :eek:

    However, if memory serves, pressing and holding the F5 key should turn off the backlight.

    Have you thought of allowing the keyboard sensor to be activated, letting it adjust to some light levels, and then turning it off? Perhaps your macbook pro hasn't yet realized what you want it to do. :p :shrugs:

    There is a way to do this.

    You said you use a password to wake from sleep/screensaver correct?

    You can set your screensaver to be a "hot corner" (dragging your cursor to the assigned corner will launch the screen saver) in the System Preferences pane:

    Go to System Preferences,

    Select "Exposé & Spaces" and then select your hot corners.

    [​IMG]
     
  6. Syndacate thread starter macrumors regular

    Joined:
    Mar 16, 2008
    #6
    Yes, I already looked at spaces/expose - not my cup of tea. I for some people expose is the best thing since sliced bread, others, like me, hate it.

    Yeah, I can turn off the backlight using the F5 key, but the point is that it shouldn't randomly be turning on while I'm sleeping.

    I just checked via the method you stated, I went into sys preferences and checked the box to let it turn on and adjust, then turned it off via the function key, I went back into the sys preferences and it was unchecked, I'm assuming it does that when the illumination = 0 via the function keys.

    Is there any way to set up universal shortcut keys (or a custom shortcut key that works out of finder) ? Usually you can do it in most UNIX environments, but mac has some weird **** about it.
     
  7. CalBoy macrumors 604

    CalBoy

    Joined:
    May 21, 2007
    #7
    No, no, no, you misunderstood why I posted that pic.

    From that pane, you can control what you have in your hot corners, including screensaver.

    If you select one of your corners to have screensaver, you'll be able to activate it right away-no need to wait for it to automatically start.
    That is strange! :eek:

    I honestly don't have any ideas as to what's going on with that. Maybe your sensor is damaged? :eek:

    Yup, that's what it does.

    Now that you mention that even the keyboard command can't do anything, I'm really wondering what's wrong with your backlight.

    Does the screen brightness adjust itself correctly?
    I'd try messing with the shortcuts in Keyboard & Mouse. It should be the tab that's furthest to the right.

    Then again, I might have the option because I have a hard key; I haven't played enough with the new mbps to know how the shortcuts are treated now.
     
  8. e12a macrumors 68000

    e12a

    Joined:
    Oct 28, 2006
  9. Burnsey macrumors 6502a

    Joined:
    Jul 1, 2007
    Location:
    Canada
    #9
    For the record I would like to add that with the method I described above you can have your MBP open, but use only one main external display with the MBP display off. I'm doing it right now.

    so:
    -close MBP, let it go to sleep
    -click external mouse for it to wake up (while still closed) and your external monitor to be the main and only display
    -open MBP

    :)
     
  10. SJTV1 macrumors newbie

    Joined:
    May 14, 2008
    #10
    Click on your username (right of menu bar), choose Login Window. Thats what I use ...
     
  11. CalBoy macrumors 604

    CalBoy

    Joined:
    May 21, 2007
    #11
    The problem with that method, however, is that it will suspend any activity in your account (ie programs will stop what they were doing).

    The OP wants activity to keep going while he's away, so I think the screensaver is really his best bet.
     
  12. Burnsey macrumors 6502a

    Joined:
    Jul 1, 2007
    Location:
    Canada
    #12
    Nope, downloads keep downloading, itunes keeps playing (doesn't come out of the speakers tho) etc...

    try it!
     
  13. Syndacate thread starter macrumors regular

    Joined:
    Mar 16, 2008
    #13
    You wanna run that by me again? I don't see my username anywhere except "log out", "accounts", and "Finder."

    I guess that's what I did - the screen is off (not just backlight off, but off off) but the lid is up on my MBP.


    I'm sorry, I didn't mis-understand - I knew what you meant - I just don't pay attention to all the weird ass mac names - I thought what's apparently "hot corners" was expose. Please understand, I'm a linux guy, I only use a mac because I need it for programming, stability, and portability and I need something solid, good battery life, good hardware, good OS - I'm not really a die hard mac fan, I couldn't care less either way, so I don't pay much mind to the names and all the "super new 100 billion new features in leopard." I only get a kick out of when pple install windows using boot camp and the mac hyper-zealots flip **** and get all pissy - that's really entertaining to me.

    About the keys, yeah, they all work fine. All the keys are 100% functional, it's just that when I dim it down all the way (off) so that it unchecks "illuminate" in sys preferences, sometimes I'll come back to this room in the morning after sleep and the keys will all be lit up. I don't even have to unlock it to turn the keyboard lights back off - but they shouldn't be flippin on. My guess is it might have something to do with my dad coming into the room and flipping the light on, then turning the light off when he leaves and that's flipping the sensor or something and illuminating the keyboard.
     
  14. kgeier82 macrumors 65816

    Joined:
    Feb 18, 2008
    #14
    do a spotlight search on "keychain access"

    once in there, click on preferences (cmd- ,)

    show status in menubar. Now click on the lock, there is a "lock screen"

    I never knew about this until i was poking around in keychain, and i was like THANK GOD .

    youll have to "require a password to wake computer" so that itll ask for a password.
     
  15. theLimit macrumors 6502a

    theLimit

    Joined:
    Jan 30, 2007
    Location:
    up tha holler, acrost tha crick
    #15
    That's the method I use to lock the screen. Screenshot attached.
     

    Attached Files:

  16. Burnsey macrumors 6502a

    Joined:
    Jul 1, 2007
    Location:
    Canada
    #16
    Go into system pref -> accounts -> login options -> enable fast user switching
     
  17. Syndacate thread starter macrumors regular

    Joined:
    Mar 16, 2008
    #17
    Ah thankyou, that's exactly what I was looking for. Is there a hotkey to trigger it?

    If you "switch user" then you're "not logged in" anymore...I need to remain logged in so apps keep running and the like.
     
  18. Burnsey macrumors 6502a

    Joined:
    Jul 1, 2007
    Location:
    Canada
    #18
    ummm no you don't go to "Switch user" (I don't think that even exists). If you do what I said, an icon of a guy will be added to your menu bar:

    If you go into "login window" you will be transferred to the login window, but in your account, things keep going, downloads keep downloading, itunes keeps playing etc...
     

    Attached Files:

  19. operator207 macrumors 6502

    Joined:
    Jul 24, 2007
    #19
    Install Quicksilver, there is a shell script called fast logout.sh.

    I have that mapped to CMD-O (CMD-L was already taken in many apps)

    Quicksilver is the best app ever for a mac. Hands down. It sounds like your similar to me, though I come from a FreeBSD/WindowMaker setup (never liked Gnome or KDE too much) Keyboard shortcuts are a requirement, none of this "swing you mouse to a corner" to do something. ;) I use the mouse to point, not to direct.

    I moved to OS X when Linux (let alone FreeBSD) on a laptop was poor at best. (unless you bought the specific year old laptop that someone built every driver for) I needed portability and FreeBSD, this was close enough.


    Regardless, if you like keyboard shortcuts, or like typing "CTRL-SPACEBAR > fi RETURN" to open firefox.app go get QuickSilver. http://en.wikipedia.org/wiki/Quicksilver_(software)
     
  20. SJTV1 macrumors newbie

    Joined:
    May 14, 2008
    #20
    Yes, that's exactly what I meant. This method only locky the computer, it does not suspend any activity ... I've been using that sice day 1 on my MBP ...
     
  21. Syndacate thread starter macrumors regular

    Joined:
    Mar 16, 2008
    #21
    Ah, finally, somebody from my territory. Yeah, the mouse points, I hate that hot corners crap. I have quicksilver installed, windows and linux both have equivalents but quicksilver is the best in my opinion, totally kick-ass.

    In any event.

    The reason why I haven't posted in a few was because I wanted to gain a little more input from what my mac was doing.

    Ever since I stopped using "lock my screen" and instead used tip that kgeier82 gave me, about the native lock screen option so it puts the lock at the top menu bar and you just click it >> "lock screen" I haven't had the problem since I've done that. I guess I'll bump this thread if it happens again.

    PS: Thanks everybody for your help.
     
  22. Burnsey macrumors 6502a

    Joined:
    Jul 1, 2007
    Location:
    Canada
    #22
    "lock screen" sounds exactly like "login window", completely unnecessary 3rd party app since OSX does it very similarly and quickly.
     
  23. Syndacate thread starter macrumors regular

    Joined:
    Mar 16, 2008
    #23
    There's a lock screen feature that's native to OS X - I just didn't know about it because it was buried. Now that I got it showing in the menu bar I can just click on it, like kgeier82 described, it has nothing to do with the 3rd party app I was using before (entitled "lock my mac").

    Your way is just as good and if I didn't rad kgeier82's post would have used it, but I didn't for one simple reason: I have a separate account which I chown folders to (then remove viewing privilege of others (700) so I can lock folders. So the login screen (the 3rd party app brought up the login screen, I think lock my mac just brought up the screen (login window) that you were speaking of - which is fine, but with just a lock screen it's one less step (click) to bring up the sign in window, I can just type opposed to clicking with the button (b/c the touchpad doesn't work in the login screen) on my profile.

    It sounds petty, I know, but it really doesn't matter to me, as long as network activity stays active and nobody else can mess with it - so his way is just a slight step faster.

    Thanks for your help though.
     
  24. operator207 macrumors 6502

    Joined:
    Jul 24, 2007
    #24
    I came from a keyboard only background, so to speak. I use the mouse, but if I can do it with the keyboard, I will most likely do it with that.

    I used "focus follows mouse" and the "wire frame and click" to place windows in Windowmaker. Scroll the titlebar, and it rolls up the window. I LOVE that environment. On top of FreeBSD, and I was lovin it! I know some thof those are either native (FFM in terminal) or third party (windowshade for Tiger by panic I think), but having them native, and the wire frame setup was the s***!

    Funny thing is, I was turned on to OS X by a hardcore BSD guy (BSD, not FreeBSD though he used FreeBSD as a workstation). My old company got a bunch of Xserves when they came out, and Apple threw in 3 dual proc. G4's. The admin's got them, then I ended up with one when I became an admin. By that time I had a powerbook. My justification was " its a pretty version of FreeBSD" which essentially it is. That and I wanted a portable *nix environment that had a battery life of more than an hour.

    Ok that was a bit OT, but hey, its not often I find someone who came from a similar environment.

    Oh ya, another nice keyboard shortcut I use constantly: opt +cmd+eject. Sleep immediately.
     
  25. kgeier82 macrumors 65816

    Joined:
    Feb 18, 2008
    #25
    yea the keychain lock, and the user switch lock work a little different. The keychain lock does not allow you to do anything without putting the passsword in. The switching user lock, well you can log into another user.

    I like my way better, its serves my purpose much better :) There is only one user on this pup!

    there is an easy third option here too. Use expose to wire a hot-corner to "start screensaver" and just enable the screensaver to require login password. Does the same thing as a lock, only you just move the mouse to that corner, instead of key-combos
     

Share This Page