Keyboard languages switch from my setup to default after each restart

Discussion in 'Mac Basics and Help' started by sMiK, Jul 5, 2009.

  1. sMiK macrumors regular

    sMiK

    Joined:
    May 8, 2008
    Location:
    Liverpool, UK
    #1
    Hello. I am running leopard, on a macbook pro aluminum 2.53.
    I use two language layouts - British, and Russian. Every time I restart my mac I only have one layout left - US. What's the issue?
     
  2. Mr_Brightside_@ macrumors 68020

    Mr_Brightside_@

    Joined:
    Sep 23, 2005
    Location:
    The 6ix
    #2
    Repair Disk Permissions with Disk Utility (in Applications>Utilities).

    Go to System Preferences>International>Input Menu, and double check that only British and Russian are checked. You can also make a shortcut below that will switch between the sources (so you don't have to go all the way to the menu bar and click the flag).

    If this doesn't work report back.
     
  3. sMiK thread starter macrumors regular

    sMiK

    Joined:
    May 8, 2008
    Location:
    Liverpool, UK
    #3
    After repairing permissions it didn't work. But after I cleaned the cache using ONYX it worked. Though quite frankly I don't understand how did that happen anyway?
     
  4. Mr_Brightside_@ macrumors 68020

    Mr_Brightside_@

    Joined:
    Sep 23, 2005
    Location:
    The 6ix
    #4
    Well that's good, at least you know what you're doing. Sometimes I guess you get "bad" caches or whatever, so cleaning them solved the problem. Nice.
     
  5. sMiK thread starter macrumors regular

    sMiK

    Joined:
    May 8, 2008
    Location:
    Liverpool, UK

Share This Page