Keyboard not working on Log In

Discussion in 'OS X El Capitan (10.11)' started by macpeach55, Nov 9, 2015.

  1. macpeach55 macrumors 6502

    macpeach55

    Joined:
    Aug 26, 2010
    Location:
    Germany, & the Rest of the known World
    #1
    After doing a clean install of El Capitan on my iMac, about every third or fourth time I try to type in my password to unlock the screen from sleep, the password box will just start filling up with the dots that hide your actual password. Delete does not remove them. Also on trying to go to restart or shutdown, it is impossible to even type in the user name (The first letter I type takes some time to show, then often repeats). So the only way to reboot is a hard shutdown. On start up everything is fine again for a while. No problem like this ever on Yosemite, & the keyboard otherwise works fine (The whole rig is a refurb from Apple & only 4 Months old).
    Any thoughts what is wrong here?
     
  2. macpeach55 thread starter macrumors 6502

    macpeach55

    Joined:
    Aug 26, 2010
    Location:
    Germany, & the Rest of the known World
  3. Phil A. Moderator

    Phil A.

    Staff Member

    Joined:
    Apr 2, 2006
    Location:
    Shropshire, UK
    #3
    Happens to me occasionally - on my MBP with Bluetooth keyboard. Turning the keyboard off then back on fixes it and I guess if it's a wired keyboard, unplugging it then plugging it back in would fix it
     
  4. macpeach55 thread starter macrumors 6502

    macpeach55

    Joined:
    Aug 26, 2010
    Location:
    Germany, & the Rest of the known World
    #4
    I tried the turn it off turn it back on & it still did it. Only way is take the batteries out then put them back in - not fun!
     

Share This Page