Keyboard shortcut to CHANGE LANGUAGE TYPED

cheeryble

macrumors regular
Original poster
Feb 1, 2008
199
0
Hi there

I would like to know how to use od set a shortcut to change the little American flag to a Thai flag and back so I can type Thai sometimes without fiddling (yes i have an Anglo/Thai keyboard). Especially annoying when inserting numbers in Thai text as one has to change back to English every time a number goes in.

thanks a lot

Cheeryble
 

cheeryble

macrumors regular
Original poster
Feb 1, 2008
199
0
Thankyou APFHEX

but I still don't quite get it

I went to your Input menu shortcuts. There seems to be no standard shortcut for language change so I pressed +.
I got a box asking me to put in a menu title and a shortcut. (Applications drop box unchangeable above it confusing me too).
What would I put in for a menu title?

Thanx v much again

Cheeryble
 

Mr_Brightside_@

macrumors 68040
Sep 23, 2005
3,246
1,328
Toronto
(In Tiger, Leopard -should- be the same):
Go to System Preferences/ Keyboard and Mouse, then the Keyboard shortcuts tab. Scroll down to Input Menu, there should be two choices: Select the previous input source, and Select the next input source in the Input Menu. Where the shortcut is currently listed, double click either shortcut, then enter the key sequence that you would like to use to switch between sources. Remember that the source has to be in the Input Menu, so go to International, then the Input Menu tab. At the very bottom, ensure that Show input menu in menu bar is checked, then check all the languages in the list that you'll be wanting to switch between.
 

sv1cec

macrumors newbie
Apr 16, 2009
20
0
Why aren't certain key combinations not working? For example, I want to use the "Ctrl-Shift" combination to switch between language input, but it is not accepted at the keyboard shortcuts. Any known way to do this?

Many thanks.
 

jackerin

macrumors 6502a
Jun 29, 2008
848
27
Finland
It could be that it is used for another shortcut, or that it won't work since both those keys are 'modifier' keys.

Personally I've set it to alt-space. Quick switch when typing.
 

sv1cec

macrumors newbie
Apr 16, 2009
20
0
Coming from the PC world, where I have set it so that my switch was Ctrl-Shift, I find Cmd-Space are un-intuitive as Cmd-Space. It's one of the very few things I dislike on the Mac.
 

Mal

macrumors 603
Jan 6, 2002
6,249
17
Orlando
Why aren't certain key combinations not working? For example, I want to use the "Ctrl-Shift" combination to switch between language input, but it is not accepted at the keyboard shortcuts. Any known way to do this?

Many thanks.
You can't use two modifier keys alone as a keyboard shortcut for these types of commands. You need a modifier key or keys along with a standard key.

Since it used to be Cmd-Space before Spotlight took that over, I've been using Ctrl-Space as my command for keyboard layout switching. You can pick whatever you want, but it has to be a combination of one or more modifier keys (Cmd, Opt, Ctrl, Shift) and one other key.

jW
 

bartman423

macrumors newbie
Jul 8, 2010
5
0
locked out by granddaughter

My daughter was over yesterday and said, "Look at this." My granddaughter, Logan, 1 and 1/2, had gotten up on the desk chair and was typing at the keyboard of my Imac. Last night I went to look something up on google and saw that I was typing in what appeared to be arabic. I thought that if I restarted the imac I would get it back to default settings. No such luck and now I can't login as my password won't be accepted. I have tried com, alt, control and shift along with the space bar, both together and sequentially with no luck. How do I get back to english?
 

tscher

macrumors newbie
Dec 5, 2010
1
0
It’s super easy!

I've been looking for answers but nobody has posted the right answer for me. Today, I found out how easy it is to change the language by easily using just a schort cut on a MacBook Keyboard! Just check out the 5 following steps!

1. Just go to “System Preferences”.
2. Choose “Keyboard”.
3. On the top of the “Keyboard” window, choose “Keyboard Shortcuts”.
4. Then look at the left side of the window and choose “Keyboard & Text Input”
5. Click “Select the previous input source”.


Now if you hold the “Command + Shift” keys, the language will be changed to the one you prefer!

That’s it!
 
Last edited:

tangyapple

macrumors newbie
Feb 14, 2011
1
0
Solved!

It’s super easy!

I've been looking for answers but nobody has posted the right answer for me. Today, I found out how easy it is to change the language by easily using just a schort cut on a MacBook Keyboard! Just check out the 5 following steps!

1. Just go to “System Preferences”.
2. Choose “Keyboard”.
3. On the top of the “Keyboard” window, choose “Keyboard Shortcuts”.
4. Then look at the left side of the window and choose “Keyboard & Text Input”
5. Click “Select the previous input source”.


Now if you hold the “Command + Shift” keys, the language will be changed to the one you prefer!

That’s it!
Thanks - that worked for me! :)

I had to alter one thing though - when I clicked on the "Select on the previous input source", two yellow triangles popped up warning me that the shortcut is already being used for "Spotlight" so I had to click on "Spotlight" and then un-tick the "Show spotlight search field" box.

Now I can use the command + space to change language inputs :D
 

giocosi

macrumors newbie
Jun 5, 2011
1
0
Changing the input language

In January I bought a Portuguese layout keyboard as I now live in Brazil, although my iMac is set to English. Occasionally I need to use the accents when writing in Portuguese, hence buying the keyboard. I have spent 6 frustrating months trying to remember the layout of the English keyboard because I cannot find a way to get my iMac to recognise this new keyboard! I have tried following the advice in this forum, I already have the British/Brazilian flags at the top of the screen etc but nothing/nada! Can anyone please relieve me of this misery?! I am using OS X 10.6.7. Thanks.....
 

Objectivesea

macrumors newbie
Jul 7, 2011
1
0
Canada
... or disable Spotlight's default shortcuts

Under "Keyboard Shortcuts" I first restored system defaults. This brought up little yellow triangles warning me that some key shortcuts were defined to mean two different things.

Then in Spotlight, still under "Keyboard Shortcuts", you could deselect the two options: "Show Spotlight search field" and "Show Spotlight window".

Now -- voilà! -- your keyboard shortcuts Cmd-space and Cmd-Option-Space will work to switch between two selected keyboard language layouts.
 

ViktorijaTi

macrumors newbie
Aug 12, 2011
2
0
Can't log into my Mac!

Hi people,

can somebody help me? I changed the language for the first time in my Mac, and then left my PC for a few minnutes. When I came back, I see that I ned to type my password that is in English. But I can't type it cause now the language is not English in the PC!

Can somebody help, please??
 

ViktorijaTi

macrumors newbie
Aug 12, 2011
2
0
Hi, I solved this problem by turning the PC off by pressing turn off button, and when i turned it on again, the language was English automatically.

But now each time I have my language not in English, and when my PC starts sleeping and I need to type password to log in, the shortcut command+space does not work.

It only works when I am working with documents, but it does not when I need to log in. How I could solve this?

Thanks!




Hi people,

can somebody help me? I changed the language for the first time in my Mac, and then left my PC for a few minnutes. When I came back, I see that I ned to type my password that is in English. But I can't type it cause now the language is not English in the PC!

Can somebody help, please??
 

whatevausername

macrumors newbie
Aug 25, 2011
1
0
Swap between languages

Hello,

I'm new to Mac, and have just changed my username to non Latin characters.
So, when prompted to fill in my username and password, I can't type my username in as the default language is English :(
Could anybody help me with this issue, please?
Your help will be greatly appreciated.
 

dwu

macrumors newbie
Sep 7, 2011
1
0
Viktorija & whatevausername

This should answer Viktorija's question, but whatevausername will have to log in as another user to change these preferences.

In system preferences, you can set an option so that the login window will have a little menu to choose keyboard language.

1. Go to "System Preferences":
2. Choose "Accounts"
3. Click "Login Options" (at the bottom of the account list on the left)
4. If the options are grayed out you may have to "click the lock to make changes" and then enter an admin username and password.
5. Select the check box for "Show input menu in login window"

After this, the next time you log in, there will be a small language menu (look for the flag icon) above the list of usernames.



Hi, I solved this problem by turning the PC off by pressing turn off button, and when i turned it on again, the language was English automatically.

But now each time I have my language not in English, and when my PC starts sleeping and I need to type password to log in, the shortcut command+space does not work.

It only works when I am working with documents, but it does not when I need to log in. How I could solve this?

Thanks!
Hello,

I'm new to Mac, and have just changed my username to non Latin characters.
So, when prompted to fill in my username and password, I can't type my username in as the default language is English :(
Could anybody help me with this issue, please?
Your help will be greatly appreciated.
 

kwiosku

macrumors newbie
Sep 10, 2011
2
0
kuwait
It’s super easy!

I've been looking for answers but nobody has posted the right answer for me. Today, I found out how easy it is to change the language by easily using just a schort cut on a MacBook Keyboard! Just check out the 5 following steps!

1. Just go to “System Preferences”.
2. Choose “Keyboard”.
3. On the top of the “Keyboard” window, choose “Keyboard Shortcuts”.
4. Then look at the left side of the window and choose “Keyboard & Text Input”
5. Click “Select the previous input source”.


Now if you hold the “Command + Shift” keys, the language will be changed to the one you prefer!

That’s it!
on my imac it is cmd + space
 

Just-me

macrumors newbie
Jun 6, 2008
17
1
MD
It’s super easy!

I've been looking for answers but nobody has posted the right answer for me. Today, I found out how easy it is to change the language by easily using just a schort cut on a MacBook Keyboard! Just check out the 5 following steps!

1. Just go to “System Preferences”.
2. Choose “Keyboard”.
3. On the top of the “Keyboard” window, choose “Keyboard Shortcuts”.
4. Then look at the left side of the window and choose “Keyboard & Text Input”
5. Click “Select the previous input source”.


Now if you hold the “Command + Shift” keys, the language will be changed to the one you prefer!

That’s it!
Thank you tscher!!!
You are a genius!! (Meaning: I tried and didn't find that option by myself)... :)
 

Dzeras

macrumors newbie
Jan 11, 2012
1
0
Change language

Hi people,

can somebody help me? I changed the language for the first time in my Mac, and then left my PC for a few minnutes. When I came back, I see that I ned to type my password that is in English. But I can't type it cause now the language is not English in the PC!

Can somebody help, please?? How to change the language? Or how to reset my pasword?
 

Damra1984

macrumors newbie
Mar 24, 2012
1
0
Mac's language locked

Hello:

I changed the language bar from US-International to different language and after a few minutes I didn't realize my Mac is locked.

When I type in the password box, it is not in English. So how could I type it in English so I can log in.

Please help.

Dara.
 

windyvation

macrumors newbie
Jul 16, 2014
1
0
MacBook Air OS X 10.9.4

The instructions above were helpful, but for my new mac this was a little different.

1- click on the apple and go to system preferences
2- choose keyboard
3- on the input sources tab you can see the languages you've chosen or choose new languages by pressing the +
4- on the shortcuts tab, choose input sources
5- checking the box for "select next source in input menu" enables the shortcut Shift+Command+Space to toggle among languages (the "select the previous input source" shortcut for Command+Space did not work, but I wanted to keep the original shortcut for Command+Space anyway

Hope this helps!
 

Similar threads

Replies
0
Views
106
Replies
1
Views
366
  • scott59
1
Replies
1
Views
326
Replies
1
Views
332
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.