Keyboard "Sticks" & System Acts Oddly After Long Idle

Discussion in 'Mac Basics and Help' started by mmxbass, Apr 13, 2013.

  1. mmxbass macrumors newbie

    Joined:
    Apr 13, 2013
    #1
    Late 2012 MacMini running Mountain Lion

    After leaving the computer idle (several hours) after the screen has gone to sleep and such. Sometimes (not always) when I press some keys to wake the computer, things get weird:

    First the keyboard gets "sticky". When I press a key, nothing happens, but when I HOLD a key in, it will rapid repeat that key after about a second. I thought this was odd behavior since that kind of "hold to repeat" behavior is common in PCs but doesn't seem to be the case in any recent Mac I've used.

    The mouse is totally unaffected and acts totally normal.

    -IF- the strange keyboard issue happens, many applications will get slow, crashy, refuse to quit, etc. If the issue doesn't happen, everything is fine.

    Rebooting sorts things out but it's rather annoying.

    NVRAM clear did not fix the issue.

    I'm at a loss as to what to try next. Hoping for input.
     
  2. mmxbass thread starter macrumors newbie

    Joined:
    Apr 13, 2013
    #3
    SMC reset seems to have had no effect on the problem. I reset it last night and this morning I'm noticing no change.

    Setting standby/autopoweroff/sleep/hibernatemode all to 0 in pmset has also not appeared to make any difference.
     
  3. mmxbass thread starter macrumors newbie

    Joined:
    Apr 13, 2013
    #4
    I've gone and done a Cmd+R boottime reinstall of OSX. We'll see if that helps. More suggestions while I wait though would be appreciated.
     
  4. mmxbass thread starter macrumors newbie

    Joined:
    Apr 13, 2013
    #5
    Seems to have had no effect. The problem still occurs.
     
  5. mmxbass thread starter macrumors newbie

    Joined:
    Apr 13, 2013
    #6
    Problem solved!

    Cause: Running the "Flurry" screensaver for hours and hours on a dual-monitor setup.

    Solution: Switch to "Message" screensaver and enjoy the hipstery grey-on-black.
     
  6. justperry macrumors 604

    justperry

    Joined:
    Aug 10, 2007
    Location:
    In the core of a black hole.
    #7
    Solution, don't use any screensaver, those were good for the old days with tube monitors.
    Just let the display sleep, saves energy and prolongs the life of the GPU!
     
  7. mmxbass thread starter macrumors newbie

    Joined:
    Apr 13, 2013
    #8
    Probably a good idea in the general case. I used to just let the displays sleep before my monitors broke. Now I only sleep the displays after an hour because once the screens turn off, they won't come back on for 2-3 minutes.
     

Share This Page