keyboard stops working but only in Finder? Help!

Discussion in 'macOS' started by coolskierguy, Mar 4, 2008.

  1. coolskierguy macrumors newbie

    coolskierguy

    Joined:
    Mar 4, 2008
    #1
    My macbook pro keyboard and my silver Apple bluetooth keyboard (primary keyboard) randomly stop working in Finder can anyone explain? Heres the details:

    I usually use my wireless keyboard, and when this happens the keyboard keeps working with everything else, and only stops working in Finder i.e. I can't edit the names of files or even click through files with the arrow keys. (the Macbook Pro keyboard also stops working-only in Finder-during these times too as I just tested..)

    Also, Finder keeps working its not frozen or anything, I can click around in it with the mouse and open files/apps, etc.

    This has only happened approximately 3 or 4 times (I've had the keyboard since the new ones were released and the computer for 1.5 yrs)

    Lastly, when I restart the OS (10.4.11) the problem disappears for a week or more..

    help!
     
  2. mmcxiiad macrumors 6502

    Joined:
    Jul 19, 2002
    #2
    try this:

    create a new user in system preferences.

    log in as that user.

    does the problem still happen in the finder?

    If the answer is no, then it most likely is a problem in your user library. Let us know what you find out after doing this and we can take it from there.
     
  3. coolskierguy thread starter macrumors newbie

    coolskierguy

    Joined:
    Mar 4, 2008
    #3
    wow, someone has a suggestion! thank you, this is the 3rd forum I joined and the 1st where someone had anything at all to suggest about this problem, my buddy just told me this was the best mac forum I guess he was right!

    i'm at work now but ill try that out when i get home..
     
  4. mmcxiiad macrumors 6502

    Joined:
    Jul 19, 2002
    #4
    I had just posted a question to the forum and while I was waiting, I thought it would be nice to see if there were any questions that I could answer. Hope it helps.
     
  5. Isobel macrumors newbie

    Joined:
    Feb 2, 2007
    #5
    Same issue

    Hello,
    One of the users in our office is having the same issue. I re-started the MacBook and it seemed to fix it, however about 15 mins later she reported the same thing again. Could not change filenames of any file in Finder.

    I created another account, as suggested and was able to change filenames under that account. I then logged out and logged in under the original account and it still works fine.

    However i'm not convinced this actually helped, I think something is reset during logon that temporarily fixed the issue as it did before when I re-started. I'm currently waiting for it to happen again so I can try something else...does anyone have any other ideas if it happens again?
     
  6. mmcxiiad macrumors 6502

    Joined:
    Jul 19, 2002
    #6
    logging into a separate account is not the solution, it is a method to see where the problem is. If you can log into a new unused user account on your computer and everything works fine then what does that say:

    1. It isn't a hardware problem because it works now.
    2. It isn't a global software problem either.
    3. I must be something specific to the user account that is having this problem.

    If these statements are true, then it is very likely that it is just a corrupt preference file. Personally, I am not sure which one it would be. My advice was offered more to help narrow down what is causing the problem.
     
  7. coolskierguy thread starter macrumors newbie

    coolskierguy

    Joined:
    Mar 4, 2008
    #7
    Isobel, I experienced the same thing as you when loggin on as another user & also agree this isn't a solution.

    I'm definitely experiencing the same issue as your user with not being able to change filenames etc but everything else in finder working ok and everything else with the keyboard working ok..

    I'm not sure whats happening to the person in your workplace as far as frequency but with me the problem only occurs every once in awhile so even logging out and logging back in as the same user or restarting clears it up - but not permanently and it starts happening again a few days or a week later...
     
  8. wrldwzrd89 macrumors G5

    wrldwzrd89

    Joined:
    Jun 6, 2003
    Location:
    Solon, OH
    #8
    Hey everyone -

    Try digging around in your preferences for a file called com.apple.Keyboard.plist. Move this file elsewhere, then log out and back in for the change to take effect. This file controls settings related to Keyboard behavior, and could very well be the cause of the problem.
     
  9. onepixel macrumors newbie

    Joined:
    Mar 31, 2008
    #9
    experiencing the same problem

    I too am having the same keyboard/finder issue. I have found that using command-option-esc to bring up the force quit dialog allows you to quit and restart the finder and this brings the keyboard back to life. Not a great solution, but better than restarting the machine every time. The frequency seems to be about once a day, more or less, that this is happening.

    I will try the plist trick to see if that helps. Anyone have any luck?

    I am on a 2x2.66 ghz xeon with 10.5.2. The apps that I most frequently use are the Adobe CS3 Creative Suite, Parallels, NetNewsWire, iChat (with Chax installed), itunes, mail, Transmit, and Safari.
     
  10. MacDream macrumors newbie

    Joined:
    Apr 18, 2007
    #10
    I had same problem yesterday.
    I just logged in as Guess , tried the keyboard (everything was ok),
    then logged out as Guess got back to my account, and voilá.
    No mod to plist files was needed.

    By the way, a was runnig:
    iTunes, Transmit, Photoshop CS3, Mail, Firefox, Safari, Parallels, Adium, Time Out, Yahoo! widgets (Mac widgets are disabled), Mail Forward, EasyFind and BatChmod.

    Thank you mmcxiiad.
    Thanks all.
     
  11. tourneur macrumors member

    Joined:
    Jan 25, 2008
    Location:
    Amsterdam
    #11
    I haave this problem too.
    I just logged out and logged in (as myself) and the problem is solved. I hope it's permanent?
     
  12. KyleC macrumors member

    Joined:
    Oct 9, 2004
    Location:
    Dallas, Texas
    #12
    I have this exact same problem with my brand new mac pro and wireless keyboard.

    It really really really makes me want to hate Apple. It really slows down my workflow, none of the solutions posted fix it. PLEASE $#%)%$* FIX THIS APPLE!!!!!!!!!!
     
  13. Bennij macrumors newbie

    Joined:
    Sep 3, 2008
    #13
    I think it might have something to do with the built-in keyboard firmware update.
     
  14. luchomolina macrumors newbie

    Joined:
    Dec 3, 2009
    #14
    Wirkaround

    This worked for me:

    Click on the apple symbol on the right top corner of the screen -> force quit -> select "Finder" -> click relaunch

    Hope it works for everybody
     
  15. nzmark macrumors newbie

    Joined:
    Dec 8, 2009
    Location:
    London, UK
    #15
    Hey just had the problem and tried this, and it worked perfectly - thanks luchomolina!
     
  16. Jay2k1 macrumors newbie

    Joined:
    Dec 15, 2009
    #16
    Hello,

    I too have this problem.

    The keyboard stops working, but only in the finder. Restarting the finder solves the problem temporarily, but it's only a matter of a few minutes until it would occur again.

    It's a Dual G5 PowerMac with 10.4.11 on it, plus MS Office 2004, Adobe CS3 and some rather small utils like VLC.

    It's a standard apple keyboard (the white plastic one).

    I checked the logfiles, created a new user, I did everything I could imagine that could help. I also reset the PRAM and pressed that little button on the mobo. And I have run AHT.
    In the end I gave up and put in a new hard disk and freshly installed OS and software on it.

    And guess what, even that didn't solve the problem.
    So it must be either a hardware problem (which I personally doubt, because it's a finder-only issue) or it has to do with certain software that's installed on the mac.

    Any clues?
     
  17. Gregg2 macrumors 603

    Joined:
    May 22, 2008
    Location:
    Milwaukee, WI
    #17
    Jay, did you try the plist thing suggested above?
     
  18. Jay2k1 macrumors newbie

    Joined:
    Dec 15, 2009
    #18
    Heh, yeah, of course I did. Before I reinstall or even create a new user, I try simpler things.

    EDIT: I only deleted the finder plist, there was no keyboard plist file as suggested in post #8.

    All that was needed though to recreate the problem was creating a new folder somewhere and rename it. After that, you couldn't rename it anymore. Pressing enter didn't do anything, and clicking the folder twice did make the text field appear but then I was unable to write.
    Also, then you are unable to issue other keyboard commands to the finder, such as cmd-n for a new window or navigating folders by pressing letter keys.

    Note that this phenomenon also happened on two other Macs, one of them a Mac Pro with Intel CPU and 10.5, but most of the ~20 Mac workstations we have did not face the problem a single time, although they have more or less the same software installed (CS2 or 3, Office X or 2004, Wacom tablet drivers, Thunderbird, Firefox, VLC and some other stuff). The two machines mentioned above have the problem much less frequently though, like twice a month or so, so their users can live with the restarting finder method. But the Mac we're talking about here is much worse, it's just a matter of doing a few file operations.

    When this first occured and couldn't be solved, we decided to buy PathFinder, but now this is the third Mac with this problem and I somehow refuse to just spend money for something that's not even a solution.
     
  19. Gregg2 macrumors 603

    Joined:
    May 22, 2008
    Location:
    Milwaukee, WI
    #19
    Jay, I found com.apple.keyboardtype.plist in MyHardDrive/Library/Preferences rather than in MyUserName/Library/Preferences. Don't know what happens if you trash it, so I'd suggest moving it to the Desktop, or leaving it alone.

    Of course you did? Ok, but ya gotta say so for anyone else to know. ;)
     
  20. Jay2k1 macrumors newbie

    Joined:
    Dec 15, 2009
    #20
    So I did a find /* -iname *eyboar*.plist -type f in the terminal (as root) and it didn't come up with anything useful, so I guess on this machine there is no such file.

    This is all it got:
    Code:
    ./System/Library/CoreServices/Setup Assistant.app/Contents/Resources/IntroSection.bundle/Contents/Resources/Reg_Keyboard.plist
    ./System/Library/PrivateFrameworks/International.framework/Versions/A/Resources/da.lproj/KeyboardNames.plist
    ./System/Library/PrivateFrameworks/International.framework/Versions/A/Resources/Dutch.lproj/KeyboardNames.plist
    ./System/Library/PrivateFrameworks/International.framework/Versions/A/Resources/fi.lproj/KeyboardNames.plist
    ./System/Library/PrivateFrameworks/International.framework/Versions/A/Resources/French.lproj/KeyboardNames.plist
    ./System/Library/PrivateFrameworks/International.framework/Versions/A/Resources/German.lproj/KeyboardNames.plist
    ./System/Library/PrivateFrameworks/International.framework/Versions/A/Resources/Italian.lproj/KeyboardNames.plist
    ./System/Library/PrivateFrameworks/International.framework/Versions/A/Resources/Japanese.lproj/KeyboardNames.plist
    ./System/Library/PrivateFrameworks/International.framework/Versions/A/Resources/ko.lproj/KeyboardNames.plist
    ./System/Library/PrivateFrameworks/International.framework/Versions/A/Resources/no.lproj/KeyboardNames.plist
    ./System/Library/PrivateFrameworks/International.framework/Versions/A/Resources/pt.lproj/KeyboardNames.plist
    ./System/Library/PrivateFrameworks/International.framework/Versions/A/Resources/SALocaleToKeyboard.plist
    ./System/Library/PrivateFrameworks/International.framework/Versions/A/Resources/Spanish.lproj/KeyboardNames.plist
    ./System/Library/PrivateFrameworks/International.framework/Versions/A/Resources/zh_CN.lproj/KeyboardNames.plist
    ./System/Library/PrivateFrameworks/International.framework/Versions/A/Resources/zh_TW.lproj/KeyboardNames.plist
    
    Gregg, you got 10.4.11 as well?
     
  21. pavinder macrumors member

    Joined:
    Jan 16, 2009
    #21
    I've been having this problem for a couple of months now, running 10.5.8 on an early 2009 iMac.
    Today it is happening every few minutes - unbelievably frustrating and forcing the finder to quit is the only way to get functionality back.

    I too have tried trashing the various preferences, repairing permissions etc. These things work for a short (and variable) time and then the problem recurs.

    Absolutely no idea what to do other than reinstall or upgrade the system to Snow Leopard, but was really hoping someone may have found a solution by now.

    It's definitely an ongoing issue. This thread on the Apple forums had no solution either:
    http://discussions.apple.com/thread.jspa?threadID=1299087&start=15&tstart=0
    yet they've stopped new posts to the thread!

    A couple of people there suggested it may be connected to using Spaces, but still no solution was offered.
     
  22. Gregg2 macrumors 603

    Joined:
    May 22, 2008
    Location:
    Milwaukee, WI
    #22
    Oops, sorry for neglecting to mention that. No, I have 10.5.8
     
  23. Dr. S macrumors newbie

    Joined:
    Jan 13, 2010
    #23
    I have the same problem and the solution of "force quit" for finder works BUT that means if I have a large number of files to rename I must force quit between each one. Not a real solution for me.. Also this problem is not consistent Although my work pattern is the same daily, some days it happens only once the entire day and I rename files, delete files, etc. Other days it is between EVERY single use of Finder. Hope someone is working on this, brushed out my unix today to delete and rename from there. Hmmm
     
  24. aadchrom macrumors newbie

    Joined:
    Aug 9, 2010
    #24
    mbp running 10.5.8

    Hey guys,

    Figured I'd add myself to this chorus, this started happening to me on a machine that I've owned for two years.

    Couldn't find com.apple.Keyboard.plist in Library/preferences.

    I had the motherboard replaced last month when the video card fried itself but otherwise this machine has always been a pleasant dev workhorse.

    Force quitting works but problem returns intermittently. I had tinkertools installed, but took that off. Can't think of anything else that would pertain but it's obviously still a problem.
     
  25. Anic297 macrumors newbie

    Joined:
    Sep 14, 2010
    Location:
    Switzerland
    #25
    I have this problem as well. All related to the keyboard and the Finder stops, which means not only standard inputs, but also all shortcuts (menu items shortcuts (command-n for new window, command-, for preferences, etc), as well as command-up to go to the parent folder).

    I highly doubt it's a preferences file issue as only the Finder is concerned (and the preferences file of the Finder does not involve the keyboard settings).

    My current guess, based on what I've seen (correct me if you have seen something that defeats my analysis) is that's "just" a Finder bug. I'm thinking the Finder does not "fully" get the focus (it does visually, but not programatically, so the keyboard's focus isn't routed to the Finder). In my case, it always happens when I switch to the Finder (using command-tab, as it's the only way I usually switch to it), so it's at that point that the activation of the Finder isn't completed (well, the source code would help understanding "why"). In that theory, since subsequent switches to the Finder don't resolve the problem, something is broken in the "running copy of the Finder" and only relaunching it makes things fine again. It's my current guess, and I'd like to discuss about it, if someone else wants to understand the issue, like I do.

    Also, relaunching the Finder that way (by force quitting it) is a bad idea: you come back to the state the Finder was at its previous launch (windows open/closed since then are lost, etc.). You may also loose modified preferences or such.
    It's better to quit the Finder "normally" (after all, the Finder isn't frozen, it's just the keyboard input that does not reach it).
    For this, you have two ways: either write an AppleScript:
    (script begins here)
    Tell Application "Finder"
    Quit
    Activate
    End Tell
    (script ends here)
    This will quit the finder gracefully and relaunch it immediately. You may save the script as an application and put it, e.g., in the Dock.
    Either (and that's my favourite solution as it does not involve running another application), you can enable the hidden "Quit" menu item of the Finder (because it has one, just hidden by default; search on the web to make it appear) and you can then quit the Finder... using the mouse ;)

    Hope this helps...
     

Share This Page