Keyboard switches automatically

Discussion in 'iOS 9' started by Hyloba, Jan 21, 2016.

  1. Hyloba macrumors 6502

    Joined:
    Sep 30, 2014
    #1
    I believe it was since I installed SwiftKey that whenever I turn off/on the screen with the keyboard popped out, it reverts to stock keyboard. Anyone knows what's going on?
     
  2. Armen macrumors 604

    Armen

    Joined:
    Apr 30, 2013
    Location:
    127.0.0.1
    #2
    Been like that since 3rd party keyboards were introduced. Some keyboards are better than others. I use Fleksy and it doesn't usually revert back to the stock keyboard unless I have to input a password, which is by design.
     
  3. Hyloba thread starter macrumors 6502

    Joined:
    Sep 30, 2014
    #3
    That's bad, it's actually highly annoying as it is right now. I understand the change when entering a password, but now it's always a mess when I leave open the keyboard. Reason I use SwiftKey is because of the multilanguage predictive text. Fleksy doesn't have that so I'd have to switch languages all the time. This sucks...
     
  4. Elisha macrumors 6502a

    Elisha

    Joined:
    Nov 21, 2006
    #4
    Sometimes changing orientation reverts to stock keyboard as well.
     
  5. jgelin macrumors 6502a

    jgelin

    Joined:
    Jul 30, 2015
    Location:
    St Petersburg, FL
    #5
    Have you in keyboard settings pressed edit and drug the new 3rd party keyboard to the top of the list. I have also "deleted" the stock English input method from the list too.
    This will result in always having Swiftkey.
     
  6. Hyloba thread starter macrumors 6502

    Joined:
    Sep 30, 2014
    #6
    I did drag it to the top but haven't deleted the other keyboards. I have now and I think the problem is solved. Thanks!
     
  7. steve23094, Jan 22, 2016
    Last edited: Jan 23, 2016

    steve23094 macrumors 68000

    steve23094

    Joined:
    Apr 23, 2013
    #7
    It's unlikely this will solve your problem. Why would I know that? I have taken the same steps and my Swype keyboard still sometimes reverts to stock. 3rd party keyboards have been buggy as hell since they were introduced. They're getting better but can still be flaky.
     
  8. Max(IT) Suspended

    Max(IT)

    Joined:
    Dec 8, 2009
    Location:
    Italy
    #8
    I gave up on third party keyboard for their inconsistency...
    I hope Apple will finally release a swiping keyboard in the future.
     
  9. jgelin macrumors 6502a

    jgelin

    Joined:
    Jul 30, 2015
    Location:
    St Petersburg, FL
    #9
    why I can't stay dedicated is the performance issues and there not being dictation on 3rd party keyboards.

    Swype is cool and all, but when I can't use my voice I'm out.
     
  10. Yptcn, Jan 25, 2016
    Last edited: Jan 25, 2016

    Yptcn macrumors 6502a

    Yptcn

    Joined:
    Aug 24, 2012
    Location:
    Paris
    #10
    I speak and write in two languages . I use Swiftkey . Is it possible to delete all stock keyboards and only keep Swiftkey ?
     
  11. Hyloba thread starter macrumors 6502

    Joined:
    Sep 30, 2014
    #11
    Yes
     
  12. steve23094 macrumors 68000

    steve23094

    Joined:
    Apr 23, 2013
    #12
    Yes but it doesn't actually achieve anything, all it will do is stop you manually selecting the stock keyboard.

    Swiftkey will still occasionally bug back to stock. The code is built into iOS, I assume so it can handle password duty if you have that option enabled.
     
  13. Yptcn macrumors 6502a

    Yptcn

    Joined:
    Aug 24, 2012
    Location:
    Paris
  14. Hyloba thread starter macrumors 6502

    Joined:
    Sep 30, 2014
    #14
    Well it helped a lot for me to delete the stock keyboard. Otherwise whenever I turned off the screen with the keyboard out, or mostly any other time, it got reverted to stock. Now I haven't got reverted to stock yet for a week, except for passwords but that's normal.
     
  15. Yptcn macrumors 6502a

    Yptcn

    Joined:
    Aug 24, 2012
    Location:
    Paris
    #15
    I know what your saying ...it was driving me nuts !
     

Share This Page