Keyboard viewer and character palette icon in menu bar

Discussion in 'macOS' started by shotters-nation, Aug 29, 2009.

  1. shotters-nation macrumors newbie

    Joined:
    Oct 5, 2007
    #1
    Does anybody know how i can get the "Keyboard viewer and character palette" option in menu bar back with the country flag and not the ugly "character palette" icon?

    ...sounds ridiculous but under Leopard that was different....:rolleyes: -> human is a creature of habit
     

    Attached Files:

  2. drlunanerd macrumors 65816

    drlunanerd

    Joined:
    Feb 14, 2004
    Location:
    UK
    #2
    Yeah I noticed that.

    I managed to get the flag back but it seems a little flaky.

    Try going into System Preferences - Keyboard, then turn on Show Keyboard & Character Viewer in Menu Bar, then turn it off again. Flag should then appear.

    BTW in Language & Text, under Input Sources the Keyboard & Character Viewer needs to be turned off for this to work.

    Edit: just tried this again and the flag didn't come back. I think it's buggy.
     
  3. shotters-nation thread starter macrumors newbie

    Joined:
    Oct 5, 2007
    #3
    Did not work for me. :(

    I still want the Keyboard Viewer in the menu bar (don't know every special character as keyboard shortcut) but that icon is quite ugly...
    Shame on you Apple ;)
     
  4. AimeeW macrumors newbie

    Joined:
    Aug 31, 2009
    #4
    In the Input Sources panel of Language & Text preferences, select a second "language".

    I have ticked British and "Unicode Hex Input", which then gives those as choices on the drop down menu and shows the flag in the menu bar for whichever you have selected :)
     
  5. dcnicholls macrumors newbie

    Joined:
    Dec 13, 2007
    Location:
    Canberra, Australia
    #5
    Procedure for SL and Lion

    This is still an irritation. To show the correct flag and still have access to the character palette, go System Settings > Language & Text and check 'Show Keyboard & Character viewer', then click the Input Sources button and check your country and a second one (must select the second one or the flag doesn't show, just the stupid icon). In my case I selected the Australian box and the US box. The menu bar flag defaults to the first selected, in the list, AFAIK.

    Everything you need is now available through the flag icon, as it was in Leopard.

    DN
     
  6. simsaladimbamba

    Joined:
    Nov 28, 2010
    Location:
    located
    #6
    You do realise that the thread is from 2009 and it has already been solved, don't you?
     
  7. dcnicholls macrumors newbie

    Joined:
    Dec 13, 2007
    Location:
    Canberra, Australia
    #7
    Yes, but if I can find the thread via Google without it being clear what the solution was, others can too. So tying off loose ends seemed like a good idea.

    Dn
     

Share This Page