Keychain Access Problems - Fixed

Discussion in 'macOS' started by pubwvj, Apr 5, 2011.

  1. pubwvj macrumors 68000

    pubwvj

    Joined:
    Oct 1, 2004
    Location:
    Mountains of Vermont
    #1
    I had problems with keychain making DejaVu backup software (great program) not be able to auto-mount remote server volume Earth. Running the first aid on the disk and on the keychain did not solve the problem. Lots of things tried - No joy.

    With much trepidation I ended up doing KeychainAccess:preferences:ResetMyKeychain which created a new clean keychain. Then I needed to regive the password for the airport network and for the Earth drive on the Airport Base Station (Extreme). This solved the problem for DejaVue Auto-mount. Keychain Access renamed the old login.keychain to set it asside.

    In order to get all my old certificates, passwords, etc working again I then used KeychainAccess:Edit:KeychainList, selected User, pressed + and added the old renamed login_renamed1.keychain and set it as shared. Then I was able to run Mail and all my email accounts were able to pickup their mail thus proving the keychain access of the old passwords was working.

    Joy, finally.

    The problem wasn't DejaVu but rather the keychain data file being corrupt in the user ~/Library/Keychains/ I found a singular lack of information on the net about how to fix this. Propaganda Software, with reservations, did suggest the possible throwing away of the keychain but that left the question of how to get back all of one's old certificates and passwords. I thought others might want to know how to resolve it.

    Relevant specifications:
    MacOSX 10.4.11 Tiger - All up-to-date
    DejaVu 3.3.3
     
  2. 2ndMouse macrumors newbie

    Joined:
    Jan 9, 2012
    #2
    Registered just to say ...

    ... really useful, thanks very much (Snow Leopard, mail prefs seem to be corrupting when syncing with iphone ... ).
     

Share This Page