Keychain cannot be found after changing home folder

Discussion in 'Mac OS X Lion (10.7)' started by ExnomenDei, Aug 4, 2011.

  1. ExnomenDei, Aug 4, 2011
    Last edited: Aug 4, 2011

    ExnomenDei macrumors regular

    Mar 2, 2010
    Hey guys,

    27" 2011 iMac.

    I have a brand-new SSD on Firewire, but it's only 60GB and I want to put my home folder on the internal drive. I did this with a Hackintosh before and it worked very well, but now I seem to be failing. The Hackintosh ran 10.6, and this runs 10.7, but I doubt it makes a difference.

    I drag-drop my home folder (called exnomendei) onto the partition on my internal hard drive I want it to be at, and I go to Users & Accounts -> Advanced and change my home folder there. I reboot, and I can log in, but Keychain isn't working and I think my resume is broken as well - it keeps restoring to the same pages.

    I can't repair permissions since there's no OS X on that disk, apparently.

    Any fixes for this?



    sudo su
    ls /Volumes/whereveryouputthehomefoldercopy
    chown -R username:usergroup homefoldername

    That fixed it. Basic permissions error, apparently.

Share This Page