keychain issues in os sierra

Discussion in 'macOS Sierra (10.12)' started by plafferty, Sep 29, 2016.

  1. plafferty macrumors newbie

    plafferty

    Joined:
    Sep 28, 2016
    Location:
    Dallas, TX
    #1
    console log reporting an almost unremitting string of keychain calls

    don't know if my imac late 2013's beach balling issues stem from this kind of processing-commitment, but it seems like a good candidate. can anyone decipher or resolve these

    default 08:35:50.992265 -0500 accountsd switching to keychain-db: /Users/pclafferty/Library/Keychains/login.keychain-db from /Users/pclafferty/Library/Keychains/login.keychain (0 1 1 1)
    default 08:35:50.992329 -0500 accountsd switching to keychain-db: /Users/pclafferty/Library/Keychains/pclafferty.keychain-db from /Users/pclafferty/Library/Keychains/pclafferty.keychain (0 1 1 1)
    default 08:35:50.992363 -0500 accountsd not switching as we're not in ~/Library/Keychains/: /Library/Keychains/System.keychain (0)
    default 08:35:51.019633 -0500 trustd 0x7fb1617501d0 free /System/Library/Keychains/SystemRootCertificates.keychain buffer 0x106755000
    default 08:35:51.404524 -0500 com.apple.iCloudHelper switching to keychain-db: /Users/pclafferty/Library/Keychains/login.keychain-db from /Users/pclafferty/Library/Keychains/login.keychain (0 1 1 1)
    default 08:35:51.404573 -0500 com.apple.iCloudHelper switching to keychain-db: /Users/pclafferty/Library/Keychains/pclafferty.keychain-db from /Users/pclafferty/Library/Keychains/pclafferty.keychain (0 1 1 1)
    default 08:35:51.404600 -0500 com.apple.iCloudHelper not switching as we're not in ~/Library/Keychains/: /Library/Keychains/System.keychain (0)
    default 08:35:51.404726 -0500 com.apple.iCloudHelper switching to keychain-db: /Users/pclafferty/Library/Keychains/login.keychain-db from /Users/pclafferty/Library/Keychains/login.keychain (0 1 1 1)
    default 08:35:51.404758 -0500 com.apple.iCloudHelper switching to keychain-db: /Users/pclafferty/Library/Keychains/pclafferty.keychain-db from /Users/pclafferty/Library/Keychains/pclafferty.keychain (0 1 1 1)
     
  2. Crazy Badger macrumors 65816

    Crazy Badger

    Joined:
    Apr 1, 2008
    Location:
    Scotland
    #2
    I had problems with my keychain on my MBA which I upgraded to macOS last week. In the end, I ended up resetting everything which solved the problem. Meant having to re-enter lots of passwords and certificates, but relatively easily solved. No problems on my iMac that I'd been running the DP of macOS.
     
  3. wallmaxx macrumors newbie

    wallmaxx

    Joined:
    Aug 31, 2011
    Location:
    WA state
    #3

    I feel that I shouldn't 'have to reset everything' since 'everything' worked just fine before my upgrade to sierra. They broke something. JMO
     
  4. syedzaidi.nyc macrumors newbie

    Joined:
    Jan 13, 2011
    Location:
    NYC
    #4
    I am having the same issue. They broke something in the last week!
     
  5. mikepro macrumors 6502

    Joined:
    Sep 3, 2010
    #5
    I'm having similar issues. (Got new retina MBP. Restored settings from Time Machine. Updated to Sierra).

    Now get lots of messages in console about keychain:

    not switching as we're not in ~/Library/Keychains/: /System/Library/Keychains/SystemRootCertificates.keychain

    from processes like trustd, helpd, Keychain Access

    I disabled iCould drive and iCould Keychain sharing. That seemed to slow down some of the messages, but still getting alot.

    Anyone make any progress on this? It doesn't _seem_ like this is doing anything "bad", but it must be chewing up CPU cycles.

    Can I just delete everything in Keychain and start fresh?
     
  6. dannys1 macrumors 68020

    dannys1

    Joined:
    Sep 19, 2007
    Location:
    UK
    #6
    Same here - i'm getting spinning beachball every time I try to access a saved password field in Safari. Presume this is related.
     
  7. RedTomato macrumors 68040

    RedTomato

    Joined:
    Mar 4, 2005
    Location:
    .. London ..
    #7
    I am having trouble with a client's iMac with the same issues.

    Have you had a look in Keychain Access? (Applications/Utilities/Keychain Access)

    I found 3200 copies of client's iCloud password in there, and 1500 copies of iMessage password, and several hundred copies of various apple-related passwords in there. Deleting all but 2 copies of each (keep a copy each of the public/private pairs) has helped computer speed somewhat.

    Console is still going crazy though and this is just a temporary bandaid.

    A poster above suggested just deleting the whole keychain and starting again. I am reluctant to do this as I don't want client to have to enter all her passwords, and she probably has no other record of many of them.
     

Share This Page