Keychain 'login' cannot be found?

Discussion in 'macOS Sierra (10.12)' started by 212rikanmofo, Aug 13, 2016.

  1. 212rikanmofo macrumors 65816

    Joined:
    Jan 31, 2003
    #1
    I'm having a very weird issue, this just popped up out of nowhere, now I cannot fix this problem.

    I tried to launch Keychain Access.app

    and I cannot seem to unluck my login keychain... it says (read only). I'm not sure if this is a bug in beta 5 of macOS Sierra or what. Sigh. I tried to log out of my iCloud account in system preferences , and now I cannot log back in because it keeps popping up a window saying 'Keychain login cannot be found to store "7879348" and it gives me an option to Reset to Defaults. So I try that and it keeps saying keychain login cannot be found to store blah@blah.com, it's like an endless loop that takes me nowhere and I cannot seem to fix this issue.

    Anyone know how to fix this or know why it's happening?
     
  2. dsjr2006 macrumors regular

    Joined:
    Jun 29, 2007
    Location:
    Metro Detroit
    #2
    It seems your login keychain is out of sync with system login. I've had this issue before and ended up finding a couple of tutorials via Google search to fix it.
     
  3. 212rikanmofo thread starter macrumors 65816

    Joined:
    Jan 31, 2003
    #3
    I've tried a few of those tutorials and it didn't fix the problem at all. Could someone point me to a working solution.
     
  4. eroux macrumors newbie

    eroux

    Joined:
    Apr 24, 2013
    Location:
    South Africa
    #4
    I found the root-cause with my keychain issues lying with the System Keychain.

    Caveats: I have the iCloud Keychain enabled and have no fear of rebooting my Macbook or using the Command Line.

    From a terminal session,

    1. test your current system keychain using "systemkeychain -tv"
    2. if you see a line reading "System unlock is NOT working", the System Keychain may have issues
    3. if that is the case, run "sudo systemkeychain -vfcC"; this will reset your System Keychain
    4. you should see a line reading "/Library/Keychains/System.keychain installed as system keychain"
    5. reboot
    6. now you may test your new System Keychain, hopefully seeing a line reading "System unlock is working"

    If running "$ sudo systemkeychain -vfcC" gives you "/Library/Keychains/System.keychain: One or more parameters passed to a function were not valid.", you may have to delete or move the System Keychain:

    sudo mv /Library/Keychains/System.keychain ~/Desktop/

    and then try, again, recreating it:

    sudo systemkeychain -vfcC

    Hope this gets fixed soon, though, because it is rather annoying having to do this at least daily.
     
  5. rweed macrumors member

    Joined:
    Dec 29, 2012
    #5
    I get this after logging in to 4-6 accounts on my iMac. Once the error occurs, the systemkeychain -tv says unlock is not working. At that point, I usually cannot access https sites in safari and various other encryption related stuff stops working. Simply rebooting resolves it...until it happens again.

    I've begun to think about going back to Linux. This is totally unacceptable.
     
  6. eroux macrumors newbie

    eroux

    Joined:
    Apr 24, 2013
    Location:
    South Africa
    #6
    I'll readily admit to it driving me absolutely batsh!t as well; and this seems to be happening with greater regularity lately.

    Switching back to Linux sounds like a better idea all the time. At least there I can read the source code to figure out exactly what's breaking… /grrr
     

Share This Page