Keychain message... Virus?

psychspirit

macrumors member
Original poster
Jul 25, 2006
60
3
When I restart my mac I get hit with many pop ups asking for password.

"accountsd wants to use "login" keychain"

"cloudd wants to use the "login keychain"

"cloudpaird wants to use the "login" keychain"

"messages Agent wants to use the "login" keychain "

I've already tried to restore it by erasing the hard drive and using Internet recovery.

Can anyone confirm if this is malware?
 

keysofanxiety

macrumors G3
Nov 23, 2011
9,534
25,266
When I restart my mac I get hit with many pop ups asking for password.

"accountsd wants to use "login" keychain"

"cloudd wants to use the "login keychain"

"cloudpaird wants to use the "login" keychain"

"messages Agent wants to use the "login" keychain "

I've already tried to restore it by erasing the hard drive and using Internet recovery.

Can anyone confirm if this is malware?
Not malware, it's a Keychain problem. It's a real stupid issue on OS X. This is how you solve it.

1) Open the Library by clicking the 'Go' menu in Finder. Hold down the 'Alt' key, and Library will be visible.

2) Navigate to the folder called 'Keychains'. Open this folder.

3) Delete all folders you see in the Keychain folder. You won't be able to empty the Trash, so don't worry about trying to empty it.

4) Restart your Mac.

5) If it prompts you for a keychain at the start, click 'Create new keychain'

You'll have to re-enter saved passwords and stuff like that, but this should fix the issue.

While you're doing this, if you get the keychain error, just click 'Cancel'.
 

psychspirit

macrumors member
Original poster
Jul 25, 2006
60
3
Ok thanks! I will try this. My imac also feels a bit different like sometimes it doesn't load a page.. Takes longer. That's why it felt like a malware.. Its strange how most incidents online claim it's the keychain issue. It sure feels like a virus. On the popups if you mouse-over the little question mark to the left nothing pops up...felt like a mock up to look like it was coming from apple.
 

Sbgirl

macrumors newbie
Nov 18, 2015
1
0
Not malware, it's a Keychain problem. It's a real stupid issue on OS X. This is how you solve it.

1) Open the Library by clicking the 'Go' menu in Finder. Hold down the 'Alt' key, and Library will be visible.

2) Navigate to the folder called 'Keychains'. Open this folder.

3) Delete all folders you see in the Keychain folder. You won't be able to empty the Trash, so don't worry about trying to empty it.

4) Restart your Mac.

5) If it prompts you for a keychain at the start, click 'Create new keychain'

You'll have to re-enter saved passwords and stuff like that, but this should fix the issue.

While you're doing this, if you get the keychain error, just click 'Cancel'.
Super thrilled! This worked like a charm! Thanks!
 
Last edited by a moderator:

Botti

macrumors newbie
Dec 10, 2015
1
0
Not malware, it's a Keychain problem. It's a real stupid issue on OS X. This is how you solve it.

1) Open the Library by clicking the 'Go' menu in Finder. Hold down the 'Alt' key, and Library will be visible.

2) Navigate to the folder called 'Keychains'. Open this folder.

3) Delete all folders you see in the Keychain folder. You won't be able to empty the Trash, so don't worry about trying to empty it.

4) Restart your Mac.

5) If it prompts you for a keychain at the start, click 'Create new keychain'

You'll have to re-enter saved passwords and stuff like that, but this should fix the issue.

While you're doing this, if you get the keychain error, just click 'Cancel'.

Did all of this, then created account to say I've still got the "accountsd wants to use" yada yada. There is no Cancel button, just "Always Allow," "Deny," or "Allow." Clicking any of them simply makes another pop-up occur still seeking password. Any other suggestions? Driving me mad and I've been trying to fix/get rid of for more than 5 hours now.

WOW - Don't know what happened but decided to repeat the process and in closing everything out, the "accountsd" box closed down. Guess the test will be if it returns after a limited night's sleep. Thanks for at least allowing me to go to bed thinking it's solved.
 
Last edited:

Mcyogi

macrumors newbie
Dec 14, 2015
1
0
I was having the same issue and this seems to have worked for me. I was so worried that it was a virus, so I'm VERY thankful that this helped. Thanks!
 

coco0612

macrumors newbie
Sep 5, 2008
14
0
Hey guys,

I'm having the exact same issue, however i have a different story.
Yesterday i unfortunately clicked on a link i think i shouldn't have clicked on, it was at least meant to be a wikipedia page link, when i clicked on it, i was shown a black page which i thought was very very weird so i turned my computer off instantly and when turned it back on i changed my administrator password and ran some malware detection application which did not find anything.

Now i have "accountsd" asking me to use the login keychain. I have also been asked by Safari.
Is this solely due to the fact i changed my Admin password ? or could it be related to a hack or virus of some sort?

Any advice would be great as i am really afraid i clicked on a virus type link.

Thanks
 

BrooklynNoise

macrumors newbie
Oct 18, 2008
17
0
Hey guys,

I'm having the exact same issue, however i have a different story.
Yesterday i unfortunately clicked on a link i think i shouldn't have clicked on, it was at least meant to be a wikipedia page link, when i clicked on it, i was shown a black page which i thought was very very weird so i turned my computer off instantly and when turned it back on i changed my administrator password and ran some malware detection application which did not find anything.

Now i have "accountsd" asking me to use the login keychain. I have also been asked by Safari.
Is this solely due to the fact i changed my Admin password ? or could it be related to a hack or virus of some sort?

Any advice would be great as i am really afraid i clicked on a virus type link.

Thanks
I've got this same issue. Clicked on a link that I shouldn't have and a popup showed up that seemed like malware or spyware. Since my only option was to hit "ok" I shutdown the computer. Thereafter I got the string of popups like:

accountsd wants to use login keychain

cloudd wants to use login keychain

cloudpaird wants to use login keychain

everytime i hit cancel a new one pops up and won't leave. I scanned my computer and no virus was detected. The fact that this issue followed the suspicious webpage makes me think the two issues are related.

I followed the instructions regarding deleting all items in the keychain folder and restarted (a hard shutdown since the laptop was giving me the spinning rainbow of death). Upon restarting I again got popups asking for keychain access and canceling them only brought more. I finally gave up and typed my keychain password and, after a few times of providing it, the pop ups stopped. But now I am worried I handed the keys to my computer to some malware.

Should I be concerned? And if so, any recommendations on how to repair this?
 

tuckerdogavl

macrumors newbie
Jan 13, 2009
21
1
Not malware, it's a Keychain problem. It's a real stupid issue on OS X. This is how you solve it.

1) Open the Library by clicking the 'Go' menu in Finder. Hold down the 'Alt' key, and Library will be visible.

2) Navigate to the folder called 'Keychains'. Open this folder.

3) Delete all folders you see in the Keychain folder. You won't be able to empty the Trash, so don't worry about trying to empty it.

4) Restart your Mac.

5) If it prompts you for a keychain at the start, click 'Create new keychain'

You'll have to re-enter saved passwords and stuff like that, but this should fix the issue.

While you're doing this, if you get the keychain error, just click 'Cancel'.
[doublepost=1459783533][/doublepost]"You'll have to reenter passwords and stuff like that..." means what? All the pages of passwords or just for accountsd? My problem seems to be if I lock the keychain I get "accountsd wants to blah blah blah" and when I then put the password in for the mac, the keychain remains open again. I've done this enough times for it to be the definition of insanity. :)
 

keysofanxiety

macrumors G3
Nov 23, 2011
9,534
25,266
[doublepost=1459783533][/doublepost]"You'll have to reenter passwords and stuff like that..." means what? All the pages of passwords or just for accountsd? My problem seems to be if I lock the keychain I get "accountsd wants to blah blah blah" and when I then put the password in for the mac, the keychain remains open again. I've done this enough times for it to be the definition of insanity. :)
Did you delete all the folders inside the keychain application? If it still doesn't work, try deleting other ones. Normally the one called login should do it. Then restart.

And yeah you'll have to re-enter all your saved passwords, whatever's listed in keychain access really — Internet browser, etc.
 

twizland

macrumors newbie
Sep 16, 2016
1
1
DUDE! this is huge. Same problem. Checked out all these blogs and directions about what do do, uber complicated, and then found this. EASY SOLVE! IT WORKED! THANK YOU!. Now I can make my filthy comedy rap music video. cheers
 
  • Like
Reactions: MissMeg

Bigmacattack38

macrumors newbie
Sep 21, 2016
1
0
Did you delete all the folders inside the keychain application? If it still doesn't work, try deleting other ones. Normally the one called login should do it. Then restart.

And yeah you'll have to re-enter all your saved passwords, whatever's listed in keychain access really — Internet browser, etc.
Will this delete the keychain data for all users of the same Mac? Or only for the user logged in?
[doublepost=1474512752][/doublepost]
Will this delete the keychain data for all users of the same Mac? Or only for the user logged in?
I discovered it was a password issue. The keychains were not synced when the password was changed on another device.
 

keysofanxiety

macrumors G3
Nov 23, 2011
9,534
25,266
Will this delete the keychain data for all users of the same Mac? Or only for the user logged in?
I'm not too sure. However the keychain files to delete are located in the user Library (access through Go in Finder), rather than the OS Library in Macintosh HD. So I'd assume it's only for the user logged in.

If you'd be happy to let me know what happens, that'll be great for future reference!
 

mdtkp7541

macrumors newbie
Jan 9, 2017
1
1
Toronto, Ontario
Not malware, it's a Keychain problem. It's a real stupid issue on OS X. This is how you solve it.

1) Open the Library by clicking the 'Go' menu in Finder. Hold down the 'Alt' key, and Library will be visible.

2) Navigate to the folder called 'Keychains'. Open this folder.

3) Delete all folders you see in the Keychain folder. You won't be able to empty the Trash, so don't worry about trying to empty it.

4) Restart your Mac.

5) If it prompts you for a keychain at the start, click 'Create new keychain'

You'll have to re-enter saved passwords and stuff like that, but this should fix the issue.

While you're doing this, if you get the keychain error, just click 'Cancel'.
[doublepost=1483987377][/doublepost]Thank you for help! Working well, now.
 
  • Like
Reactions: keysofanxiety

batmanners

macrumors member
Oct 14, 2014
45
3
Is there a reason you shouldn't just put in your keychain password when it prompts you? Does the message come up because of some third party wanting your password?

I had a similar issue with one of the posters above, where it started happening after I clicked on a suspicious link. No malware detected, but I want to make sure it's just a system issue before I enter my password.
 

LuckyBubba

macrumors member
Jun 2, 2015
71
68
Not malware, it's a Keychain problem. It's a real stupid issue on OS X. This is how you solve it.

1) Open the Library by clicking the 'Go' menu in Finder. Hold down the 'Alt' key, and Library will be visible.

2) Navigate to the folder called 'Keychains'. Open this folder.

3) Delete all folders you see in the Keychain folder. You won't be able to empty the Trash, so don't worry about trying to empty it.

4) Restart your Mac.

5) If it prompts you for a keychain at the start, click 'Create new keychain'

You'll have to re-enter saved passwords and stuff like that, but this should fix the issue.

While you're doing this, if you get the keychain error, just click 'Cancel'.

Thank you!! This worked and I'm back in Business - 9/26/2017

2011 iMac 2.7 i5 processor - Sierra - 16 GB Ram
 
  • Like
Reactions: keysofanxiety

MissMeg

macrumors newbie
Oct 17, 2017
1
1
Not malware, it's a Keychain problem. It's a real stupid issue on OS X. This is how you solve it.

1) Open the Library by clicking the 'Go' menu in Finder. Hold down the 'Alt' key, and Library will be visible.

2) Navigate to the folder called 'Keychains'. Open this folder.

3) Delete all folders you see in the Keychain folder. You won't be able to empty the Trash, so don't worry about trying to empty it.

4) Restart your Mac.

5) If it prompts you for a keychain at the start, click 'Create new keychain'

You'll have to re-enter saved passwords and stuff like that, but this should fix the issue.

While you're doing this, if you get the keychain error, just click 'Cancel'.
Thanks!! Much better. I was thinking it was a virus too.
 
  • Like
Reactions: keysofanxiety

mrcsph

macrumors newbie
Nov 17, 2017
1
1
Not malware, it's a Keychain problem. It's a real stupid issue on OS X. This is how you solve it.

1) Open the Library by clicking the 'Go' menu in Finder. Hold down the 'Alt' key, and Library will be visible.

2) Navigate to the folder called 'Keychains'. Open this folder.

3) Delete all folders you see in the Keychain folder. You won't be able to empty the Trash, so don't worry about trying to empty it.

4) Restart your Mac.

5) If it prompts you for a keychain at the start, click 'Create new keychain'

You'll have to re-enter saved passwords and stuff like that, but this should fix the issue.

While you're doing this, if you get the keychain error, just click 'Cancel'.
THANKS A LOT¡ IT WORKS FOR ME.
 
  • Like
Reactions: keysofanxiety
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.