Keychain on Macbook---STOP!! Please....

Discussion in 'MacBook Pro' started by mrlewp87, Nov 8, 2017.

Tags:
  1. mrlewp87 macrumors newbie

    mrlewp87

    Joined:
    Mar 6, 2014
    Location:
    Florida
    #1
    I don't care what were going to call it- disable, lock, turn off? It's just one of numerous!! Apple "features" that I have no use for. I was just reading a long list of complaints about it in a forum, was itching to jump in. Turned out to be from 2003!! I just want it to stop filling in a 2 year old password !!
    *) I dumped all History, passwords etc. in both Chrome and Safari browsers
    *) I Disabled all Password and Auto Form fill features in both browsers
    *) I checked my password manager again to assure it contained the correct password,..... then
    ... I even disabled Auto-Fill in my password manager.

    And still, each time I try to log into FarceBook, an error pops up. Something about the auto-entered password being 2 yrs. old, and that I changed it back then!
    It ain't the browsers, and it ain't my password manager. That leaves only the wonderful skills of Keychain as the last possible culprit.
    I DID manage to disable/ turn off Keychain on my iPhone and iPad. But on the MacBook Pro, I can uncheck it under iCloud settings, only to see it RE-check itself back on. Thank you very much Apple, for knowing better than I what I want.
     
  2. New_Mac_Smell macrumors 68000

    New_Mac_Smell

    Joined:
    Oct 17, 2016
    Location:
    Shanghai
    #2
    Try the OS forum firstly.

    Have you disabled things in Safari preferences? Like 'Autofill names and passwords'? It won't automatically enter anything, you have to manually select. So if you go to facebook, it'll give you a list of usernames that you can select and will then automatically enter the password from whichever you select. If it's out of date then why not just update the password for the new one? Everything is in Safari password preferences to do this.

    Keychain is just something that syncs these passwords across your Apple devices.

    I don't know what password manager you're using but it sounds like it could be the thing causing issue here by conflicting. If it's 1Password it should be fine however.
     
  3. mrlewp87 thread starter macrumors newbie

    mrlewp87

    Joined:
    Mar 6, 2014
    Location:
    Florida
    #3
    Instead of using numbers in my starting thread, I used *), and answered your questions. How'd I do that? I purposely didnt note my password manager, knowing it would be targeted. I had Disabled Autofill in it for Farcebook, along with any and all pswd/ autofill settings in both browsers mentioned. Plus deleted all Histories. Oh,... said that.
     
  4. New_Mac_Smell macrumors 68000

    New_Mac_Smell

    Joined:
    Oct 17, 2016
    Location:
    Shanghai
    #4
    I purposefully did mention your password manager as what you described is not the way Keychain works.

    Hey if you want to keep blaming Apple for software issues on a MBP forum then go ahead. But I'd look to your choice of software as the main culprit. For instance, you said you disabled stuff from Chrome and yet it's still happening - Hint, Keychain doesn't do squat for Chrome, unless you've added something such as 3rd party software :confused:.
     
  5. leman macrumors G3

    Joined:
    Oct 14, 2008
    #5
    If you have an old password in your keychain, just remove it? Why would one ever want to disable keychain completely? Built-in password and secure notes syncing is one of the best features of Apple software in the first place.
     

Share This Page

4 November 8, 2017